aboutsummaryrefslogtreecommitdiff
path: root/palm/py-synce-librra/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-07 16:03:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-07 16:03:36 +0000
commit27d8aafe1b6a1a68dd2108049f5831820ee57d20 (patch)
tree82a2b91740773d124a5c27edfc5227a701b44158 /palm/py-synce-librra/Makefile
parent38bfe44a05de321dfc561c9fefa6e4e1f6a76bba (diff)
downloadports-27d8aafe1b6a1a68dd2108049f5831820ee57d20.tar.gz
ports-27d8aafe1b6a1a68dd2108049f5831820ee57d20.zip
SynCE is a project for connecting to devices running Windows CE or Pocket PC.
RRA implements the Remote Replication Agent Connection protocol for synchronising objects between a Windows CE device and other computer. WWW: http://synce.sourceforge.net/ PR: ports/126136 Submitted by: Ilya Bakulin <webmaster at kibab.com>
Notes
Notes: svn path=/head/; revision=220142
Diffstat (limited to 'palm/py-synce-librra/Makefile')
-rw-r--r--palm/py-synce-librra/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/palm/py-synce-librra/Makefile b/palm/py-synce-librra/Makefile
new file mode 100644
index 000000000000..56e28ba073af
--- /dev/null
+++ b/palm/py-synce-librra/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-synce-librra
+# Date created: 19 Jun 2008
+# Whom: Ilya Bakulin <webmaster@kibab.com>
+#
+# $FreeBSD$
+
+CATEGORIES= palm python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}synce-
+
+MAINTAINER= webmaster@kibab.com
+COMMENT= Python bindings for the SynCE RRA library
+
+LIB_DEPENDS= rra.0:${PORTSDIR}/palm/synce-librra
+BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
+
+MASTERDIR= ${.CURDIR}/../synce-librra
+
+USE_PYTHON= yes
+
+PLIST= ${.CURDIR}/pkg-plist
+
+RRA_SLAVE= pythonb
+
+do-install:
+ @(cd ${WRKSRC}/python && ${MAKE} install)
+
+.include "${MASTERDIR}/Makefile"