aboutsummaryrefslogtreecommitdiff
path: root/palm/synce-hal
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-27 14:39:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-27 14:39:21 +0000
commit47bc99b045917c919f79eb5facc2e353588ed306 (patch)
treefee188fe6c7e4a941acba528010377b39703ab64 /palm/synce-hal
parentc858b187095046f4616c5443ce0f1d5a4a802197 (diff)
downloadports-47bc99b045917c919f79eb5facc2e353588ed306.tar.gz
ports-47bc99b045917c919f79eb5facc2e353588ed306.zip
SynCE is a project for connecting to devices running Windows CE or Pocket PC.
synce-hal manages device connection process and advertises device info to other programs through HAL interface. WWW: http://synce.sourceforge.net/ PR: ports/125438 Submitted by: Ilya Bakulin <webmaster at kibab.com>
Notes
Notes: svn path=/head/; revision=217671
Diffstat (limited to 'palm/synce-hal')
-rw-r--r--palm/synce-hal/Makefile35
-rw-r--r--palm/synce-hal/distinfo3
-rw-r--r--palm/synce-hal/pkg-descr5
3 files changed, 43 insertions, 0 deletions
diff --git a/palm/synce-hal/Makefile b/palm/synce-hal/Makefile
new file mode 100644
index 000000000000..849f5975f942
--- /dev/null
+++ b/palm/synce-hal/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: synce-hal
+# Date created: 14 May 2008
+# Whom: Ilya Bakulin <webmaster@kibab.com>
+#
+# $FreeBSD$
+
+PORTNAME= hal
+PORTVERSION= 0.2
+CATEGORIES= palm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+PKGNAMEPREFIX= synce-
+DISTNAME= synce-hal-${PORTVERSION}
+
+MAINTAINER= webmaster@kibab.com
+COMMENT= SynCE part: manages devices' connections
+
+LIB_DEPENDS= synce.0:${PORTSDIR}/palm/synce-libsynce \
+ hal.1:${PORTSDIR}/sysutils/hal \
+ gnet-2.0.0:${PORTSDIR}/net/gnet2 \
+ dbus-1.3:${PORTSDIR}/devel/dbus \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+
+PLIST_FILES= libexec/hal-dccm \
+ libexec/synce-serial-chat \
+ libexec/hal-synce-rndis \
+ libexec/hal-synce-serial \
+ share/hal/fdi/policy/20thirdparty/10-synce.fdi
+
+.include <bsd.port.mk>
diff --git a/palm/synce-hal/distinfo b/palm/synce-hal/distinfo
new file mode 100644
index 000000000000..7ebb759ebebc
--- /dev/null
+++ b/palm/synce-hal/distinfo
@@ -0,0 +1,3 @@
+MD5 (synce-hal-0.2.tar.gz) = 06c7fe3d2b9c130cd485272d6756f599
+SHA256 (synce-hal-0.2.tar.gz) = 3ac94e8bf92108ef84862f93c5bbd3af534476890b0ba157352cf8ee929afef4
+SIZE (synce-hal-0.2.tar.gz) = 358413
diff --git a/palm/synce-hal/pkg-descr b/palm/synce-hal/pkg-descr
new file mode 100644
index 000000000000..9af533b51db8
--- /dev/null
+++ b/palm/synce-hal/pkg-descr
@@ -0,0 +1,5 @@
+SynCE is a project for connecting to devices running Windows CE or Pocket PC.
+synce-hal manages device connection process and advertises device info
+to other programs through HAL interface.
+
+WWW: http://synce.sourceforge.net/