aboutsummaryrefslogtreecommitdiff
path: root/palm/synce-rra
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-13 21:44:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-13 21:44:14 +0000
commit4bce300b24d96812cb21f05eae1bfe0dcb2e3cd1 (patch)
tree8acc30650d738d7146050a2b9be83c8a43500177 /palm/synce-rra
parentcf1d11951308fb8f82f8a9e57e4271cda429ba3a (diff)
downloadports-4bce300b24d96812cb21f05eae1bfe0dcb2e3cd1.tar.gz
ports-4bce300b24d96812cb21f05eae1bfe0dcb2e3cd1.zip
Add synce-rra, a project for connecting to devices running Windows CE or Pocket PC.
RRA implements the Remote Replication Agent Connection protocol for synchronising objects between a Windows CE device and other computer. PR: ports/64135 Submitted by: Sam Lawrance <boris@brooknet.com.au>
Notes
Notes: svn path=/head/; revision=103904
Diffstat (limited to 'palm/synce-rra')
-rw-r--r--palm/synce-rra/Makefile38
-rw-r--r--palm/synce-rra/distinfo4
-rw-r--r--palm/synce-rra/files/patch-src-rra-decode.c11
-rw-r--r--palm/synce-rra/files/patch-src-rra-timezone.c8
-rw-r--r--palm/synce-rra/pkg-descr5
-rw-r--r--palm/synce-rra/pkg-plist14
6 files changed, 80 insertions, 0 deletions
diff --git a/palm/synce-rra/Makefile b/palm/synce-rra/Makefile
new file mode 100644
index 000000000000..cb09c001c3f6
--- /dev/null
+++ b/palm/synce-rra/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: synce-rra
+# Date created: March 2004
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+
+PORTNAME= synce-rra
+PORTVERSION= 0.8.9
+CATEGORIES= palm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+PATCH_SITES= http://sam.stral.net/freebsd/
+PATCHFILES= librra-synce-kde-0.7-freebsd.diff
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= Remote Replication Agent Connection protocol library
+
+LIB_DEPENDS= synce.0:${PORTSDIR}/palm/synce-libsynce \
+ rapi.2:${PORTSDIR}/palm/synce-librapi2
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmimedir.a:${PORTSDIR}/devel/libmimedir
+RUN_DEPENDS= ${LOCALBASE}/lib/libmimedir.a:${PORTSDIR}/devel/libmimedir
+
+MAN1= synce-matchmaker.1
+
+USE_ICONV= yes
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --with-libsynce=${LOCALBASE}
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|stdint.h|sys/types.h|' \
+ ${WRKSRC}/lib/generator.h ${WRKSRC}/lib/recurrence_internal.h \
+ ${WRKSRC}/lib/rrac.h
+
+.include <bsd.port.mk>
diff --git a/palm/synce-rra/distinfo b/palm/synce-rra/distinfo
new file mode 100644
index 000000000000..5cc0ad3af65a
--- /dev/null
+++ b/palm/synce-rra/distinfo
@@ -0,0 +1,4 @@
+MD5 (synce-rra-0.8.9.tar.gz) = f7ff0ee6478e8a7dc424731ccee94313
+SIZE (synce-rra-0.8.9.tar.gz) = 246733
+MD5 (librra-synce-kde-0.7-freebsd.diff) = f3fc24bd674b348ad939baecd9ec5559
+SIZE (librra-synce-kde-0.7-freebsd.diff) = 4181
diff --git a/palm/synce-rra/files/patch-src-rra-decode.c b/palm/synce-rra/files/patch-src-rra-decode.c
new file mode 100644
index 000000000000..be6e7112a087
--- /dev/null
+++ b/palm/synce-rra/files/patch-src-rra-decode.c
@@ -0,0 +1,11 @@
+--- src/rra-decode.c.orig Thu Mar 11 22:13:04 2004
++++ src/rra-decode.c Thu Mar 11 22:13:26 2004
+@@ -218,7 +218,7 @@
+ time_t unix_time = filetime_to_unix_time(&propvals[i].val.filetime);
+ char* time_str = ctime(&unix_time);
+ time_str[strlen(time_str)-1] = '\0'; /* remove trailing newline */
+- printf("%s (%lu)", time_str, unix_time);
++ printf("%s (%lu)", time_str, (long unsigned)unix_time);
+ db_dump(&propvals[i].val.filetime, sizeof(FILETIME));
+ }
+ break;
diff --git a/palm/synce-rra/files/patch-src-rra-timezone.c b/palm/synce-rra/files/patch-src-rra-timezone.c
new file mode 100644
index 000000000000..73c4413bae07
--- /dev/null
+++ b/palm/synce-rra/files/patch-src-rra-timezone.c
@@ -0,0 +1,8 @@
+--- src/rra-timezone.c.orig Thu Mar 11 22:26:25 2004
++++ src/rra-timezone.c Thu Mar 11 22:26:39 2004
+@@ -1,5 +1,4 @@
+ /* $Id: rra-timezone.c,v 1.6 2003/12/08 09:44:02 twogood Exp $ */
+-#define _POSIX_C_SOURCE 2 /* for getopt */
+ #define _BSD_SOURCE
+ #include "../lib/timezone.h"
+ #include "../lib/generator.h"
diff --git a/palm/synce-rra/pkg-descr b/palm/synce-rra/pkg-descr
new file mode 100644
index 000000000000..eb43639a8c34
--- /dev/null
+++ b/palm/synce-rra/pkg-descr
@@ -0,0 +1,5 @@
+SynCE is a project for connecting to devices running Windows CE or Pocket PC.
+RRA implements the Remote Replication Agent Connection protocol for
+synchronising objects between a Windows CE device and other computer.
+
+WWW: http://synce.sourceforge.net/
diff --git a/palm/synce-rra/pkg-plist b/palm/synce-rra/pkg-plist
new file mode 100644
index 000000000000..0279c4f8ca1b
--- /dev/null
+++ b/palm/synce-rra/pkg-plist
@@ -0,0 +1,14 @@
+bin/synce-matchmaker
+include/rra/appointment.h
+include/rra/contact.h
+include/rra/matchmaker.h
+include/rra/syncmgr.h
+include/rra/task.h
+include/rra/timezone.h
+include/rra/uint32vector.h
+lib/librra.a
+lib/librra.la
+lib/librra.so
+lib/librra.so.0
+share/aclocal/rra.m4
+@dirrm include/rra