aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-11 09:28:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-11 09:28:50 +0000
commit9efe26073b6463b04d43f55c460173ce9b810d9b (patch)
tree46c4b50b9bb4340ebd48b50fbcb75b1df55b6ea5 /palm
parent28d24d2e6717b13fab78ddbd713f3521bf152f71 (diff)
downloadports-9efe26073b6463b04d43f55c460173ce9b810d9b.tar.gz
ports-9efe26073b6463b04d43f55c460173ce9b810d9b.zip
- Fix build on 5.x and unbreak
PR: ports/66488 Submitted by: Arne Woerner <arne_woerner@yahoo.com>
Notes
Notes: svn path=/head/; revision=108911
Diffstat (limited to 'palm')
-rw-r--r--palm/coldsync/Makefile4
-rw-r--r--palm/coldsync/files/patch-src_symboltable.cc22
2 files changed, 13 insertions, 13 deletions
diff --git a/palm/coldsync/Makefile b/palm/coldsync/Makefile
index f9ab749635f3..83949d638382 100644
--- a/palm/coldsync/Makefile
+++ b/palm/coldsync/Makefile
@@ -45,10 +45,6 @@ MANCOMPRESSED= no
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
CFLAGS+= -D__BSD_VISIBLE=1
CONFIGURE_ARGS+= --with-i18n --disable-pedantic --without-perl
diff --git a/palm/coldsync/files/patch-src_symboltable.cc b/palm/coldsync/files/patch-src_symboltable.cc
index a1dae9425f02..f39b7b198263 100644
--- a/palm/coldsync/files/patch-src_symboltable.cc
+++ b/palm/coldsync/files/patch-src_symboltable.cc
@@ -1,14 +1,18 @@
-
-$FreeBSD$
-
---- src/symboltable.cc.orig Fri Feb 21 23:32:21 2003
-+++ src/symboltable.cc Fri Feb 21 23:35:23 2003
-@@ -13,6 +13,8 @@
+--- src/symboltable.cc.orig Tue Nov 13 16:48:07 2001
++++ src/symboltable.cc Tue May 11 11:19:40 2004
+@@ -7,11 +7,15 @@
+ * $Id: symboltable.cc,v 2.2 2001/10/18 01:38:55 arensb Exp $
+ */
+
++#include <stdio.h>
++#include <wchar.h>
+ #include "config.h"
+ #include <string>
+ #include <map>
#include <cstdlib> // For malloc() and friends
#include "symboltable.h"
-
-+using namespace std;
+
++using namespace std;
+
static char *make_c_string(const string &s);
- map<string,string> table; /* XXX - Is this going to cause problems on