aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorNik Clayton <nik@FreeBSD.org>1999-12-24 01:11:12 +0000
committerNik Clayton <nik@FreeBSD.org>1999-12-24 01:11:12 +0000
commit7029014e918dc90019bdfb46bb6624a32188c108 (patch)
tree48fe552db30637b5f0dfbb03a556426284947427 /palm
parent53b3842137ec584d57c2cc03886358d3a2a86061 (diff)
downloadports-7029014e918dc90019bdfb46bb6624a32188c108.tar.gz
ports-7029014e918dc90019bdfb46bb6624a32188c108.zip
iSilo: Convert text/HTML files to files suitable for installing on a
Palm Pilot, and reading with the iSilo Palm Document reader. A reasonable attempt at retaining the HTML formatting is performed (and images are retained) making this great for building a Palm-able version of the FAQ or Handbook. . .
Notes
Notes: svn path=/head/; revision=23946
Diffstat (limited to 'palm')
-rw-r--r--palm/isilo/Makefile30
-rw-r--r--palm/isilo/distinfo1
-rw-r--r--palm/isilo/files/Makefile10
-rw-r--r--palm/isilo/pkg-comment1
-rw-r--r--palm/isilo/pkg-descr19
-rw-r--r--palm/isilo/pkg-plist1
6 files changed, 62 insertions, 0 deletions
diff --git a/palm/isilo/Makefile b/palm/isilo/Makefile
new file mode 100644
index 000000000000..4bfbe28a1d68
--- /dev/null
+++ b/palm/isilo/Makefile
@@ -0,0 +1,30 @@
+# New ports collection Makefile for: isilo
+# Version required: 2.51
+# Date created: 20 December 1999
+# Whom: nik
+#
+# $FreeBSD$
+#
+
+DISTNAME= iSilo386
+USE_ZIP= yes
+PKGNAME= isilo-2.51
+
+CATEGORIES= palm textproc
+MASTER_SITES= ftp://ftp.iSilo.com/pub/
+
+MAINTAINER= nik
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+MAN1= iSilo386.1
+MANCOMPRESSED= no
+
+post-extract:
+ ${CP} files/Makefile files/iSilo386.1 ${WRKDIR}
+
+post-install:
+ @${CAT} pkg/MESSAGE
+
+.include <bsd.port.mk>
diff --git a/palm/isilo/distinfo b/palm/isilo/distinfo
new file mode 100644
index 000000000000..fd992be0747f
--- /dev/null
+++ b/palm/isilo/distinfo
@@ -0,0 +1 @@
+MD5 (iSilo386.zip) = 7272a10eb034385cc788541f6cf72c54
diff --git a/palm/isilo/files/Makefile b/palm/isilo/files/Makefile
new file mode 100644
index 000000000000..321a30200a50
--- /dev/null
+++ b/palm/isilo/files/Makefile
@@ -0,0 +1,10 @@
+# Use BSD_INSTALL_SCRIPT so that it doesn't try to strip the binary,
+# which breaks Linux apps.
+#
+# $FreeBSD$
+
+install:
+ ${BSD_INSTALL_SCRIPT} iSilo386 ${PREFIX}/bin
+ /usr/bin/brandelf -t Linux ${PREFIX}/bin/iSilo386
+ @${BSD_INSTALL_MAN} iSilo386.1 ${PREFIX}/man/man1
+
diff --git a/palm/isilo/pkg-comment b/palm/isilo/pkg-comment
new file mode 100644
index 000000000000..dcc729d8ae98
--- /dev/null
+++ b/palm/isilo/pkg-comment
@@ -0,0 +1 @@
+Converts documents from text/HTML to iSilo format for reading on a Palm Pilot
diff --git a/palm/isilo/pkg-descr b/palm/isilo/pkg-descr
new file mode 100644
index 000000000000..129f96dd0fb1
--- /dev/null
+++ b/palm/isilo/pkg-descr
@@ -0,0 +1,19 @@
+iSilo converts text or HTML documents to the Palm Pilot .pdb format. These
+can then be installed on a Palm Pilot, using tools in the palm/pilot-link
+port.
+
+These files are only readable using the iSilo reader, available from the
+web site. A free reader exists, as does a more featureful shareware
+reader. Their primary advantages over other Palm Pilot DOC readers are
+
+ 1. Internal links in the original HTML are maintained.
+
+ 2. A reasonable facsimile of the original HTML formatting is maintained.
+
+ 3. Images in the original HTML file are dithered and scaled, for viewing
+ on the Pilot.
+
+WWW: http://www.iSilo.com/
+
+- Nik
+nik@FreeBSD.org
diff --git a/palm/isilo/pkg-plist b/palm/isilo/pkg-plist
new file mode 100644
index 000000000000..bf1f0f089906
--- /dev/null
+++ b/palm/isilo/pkg-plist
@@ -0,0 +1 @@
+bin/iSilo386