aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-18 11:27:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-18 11:27:47 +0000
commitb1c8dca0dc3212bb9c79dfc2bfef091ad78436ae (patch)
treec01dec810907e7c56eb512a4184f687deebb6241 /palm
parentb0425286eba65b594c9f1573fdfdc8f9c509c032 (diff)
downloadports-b1c8dca0dc3212bb9c79dfc2bfef091ad78436ae.tar.gz
ports-b1c8dca0dc3212bb9c79dfc2bfef091ad78436ae.zip
- Update to 0.1
PR: 126029 Submitted by: Alexander Logvinov <ports@logvinov.com>
Notes
Notes: svn path=/head/; revision=218757
Diffstat (limited to 'palm')
-rw-r--r--palm/synce-gvfs/Makefile32
-rw-r--r--palm/synce-gvfs/distinfo6
-rw-r--r--palm/synce-gvfs/files/patch-src-libsyncevfs.c26
-rw-r--r--palm/synce-gvfs/pkg-descr9
-rw-r--r--palm/synce-gvfs/pkg-plist18
5 files changed, 28 insertions, 63 deletions
diff --git a/palm/synce-gvfs/Makefile b/palm/synce-gvfs/Makefile
index 285076965828..b6ec90ebabbf 100644
--- a/palm/synce-gvfs/Makefile
+++ b/palm/synce-gvfs/Makefile
@@ -5,32 +5,22 @@
# $FreeBSD$
#
-PORTNAME= synce-gnomevfs
-PORTVERSION= 0.9.0
-PORTREVISION= 6
+PORTNAME= synce-gvfs
+PORTVERSION= 0.1
CATEGORIES= palm
MASTER_SITES= SF/synce
MAINTAINER= ports@logvinov.com
-COMMENT= Gnome VFS module for WinCE devices
+COMMENT= GVFS module for access Windows Mobile devices
LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2
-USE_AUTOTOOLS= libtool:15
-USE_GNOME= gnomeprefix gnometarget gnomevfs2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
- --with-libsynce=${LOCALBASE}
-
-BROKEN= No longer supported by developers
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE= 2008-08-24
-
-USE_LDCONFIG= yes
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- ${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/src/Makefile.in
-
-.include <bsd.port.post.mk>
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomeprefix gnomehack gnometarget gvfs
+INSTALLS_ICONS= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.mk>
diff --git a/palm/synce-gvfs/distinfo b/palm/synce-gvfs/distinfo
index 06b48fe7eeb0..2156c4dd5d80 100644
--- a/palm/synce-gvfs/distinfo
+++ b/palm/synce-gvfs/distinfo
@@ -1,3 +1,3 @@
-MD5 (synce-gnomevfs-0.9.0.tar.gz) = 1fa8d653297331479edcd5d983a0f75e
-SHA256 (synce-gnomevfs-0.9.0.tar.gz) = 2dc8d4905b81e4303e9131dd8f737e7facae9ca7065ec7f9faba15238774b5cd
-SIZE (synce-gnomevfs-0.9.0.tar.gz) = 303885
+MD5 (synce-gvfs-0.1.tar.gz) = 0ab01d4c520f7c1f419cfcd6e014f340
+SHA256 (synce-gvfs-0.1.tar.gz) = 9fd621534bdb200397e74ee4cf9bd17ac828c32c85b0f956fb80d2ab1dfeb7d5
+SIZE (synce-gvfs-0.1.tar.gz) = 461277
diff --git a/palm/synce-gvfs/files/patch-src-libsyncevfs.c b/palm/synce-gvfs/files/patch-src-libsyncevfs.c
deleted file mode 100644
index 6995549fca65..000000000000
--- a/palm/synce-gvfs/files/patch-src-libsyncevfs.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/libsyncevfs.c.orig Sun Aug 22 21:06:29 2004
-+++ src/libsyncevfs.c Sat Jan 8 18:40:37 2005
-@@ -126,8 +126,9 @@
- {
- if (!initialized_rapi)
- {
-+ HRESULT hr;
- MUTEX_LOCK (mutex);
-- HRESULT hr = CeRapiInit();
-+ hr = CeRapiInit();
- MUTEX_UNLOCK (mutex);
-
- if (FAILED(hr))
-@@ -145,9 +146,10 @@
-
- static int get_location(GnomeVFSURI *uri, gchar **location)/*{{{*/
- {
-- int result = INDEX_INVALID;
-- *location = NULL;
-+ int result;
- gchar **path = NULL;
-+ *location = NULL;
-+ result = INDEX_INVALID;
-
- path = g_strsplit(gnome_vfs_unescape_string(gnome_vfs_uri_get_path(uri),"\\"), "/", 0);
-
diff --git a/palm/synce-gvfs/pkg-descr b/palm/synce-gvfs/pkg-descr
index f1da757cafc5..81aa54189e0d 100644
--- a/palm/synce-gvfs/pkg-descr
+++ b/palm/synce-gvfs/pkg-descr
@@ -1,5 +1,6 @@
-SynCE is a project for connecting to devices running Windows CE or Pocket PC.
-Gnomevfs gives Gnome applications like Nautilus the ability to access the file
-system on a Windows CE device via gnomevfs.
+This is an implementation of a gvfs backend for SynCE. Gvfs is a
+replacement for gnome-vfs, allowing applications to access a
+variety of filesystems in userspace, in this case a Windows
+Mobile device via SynCE.
-WWW: http://synce.sourceforge.net/
+WWW: http://www.synce.org/moin/
diff --git a/palm/synce-gvfs/pkg-plist b/palm/synce-gvfs/pkg-plist
index 7f0dff7e1d18..0d751d7bb920 100644
--- a/palm/synce-gvfs/pkg-plist
+++ b/palm/synce-gvfs/pkg-plist
@@ -1,9 +1,9 @@
-bin/synce-in-computer-folder
-etc/gnome-vfs-2.0/modules/synce-module.conf
-share/pixmaps/synce/synce-color.png
-share/synce/synce-in-computer-folder.sh
-lib/gnome-vfs-2.0/modules/libsyncevfs.a
-lib/gnome-vfs-2.0/modules/libsyncevfs.la
-lib/gnome-vfs-2.0/modules/libsyncevfs.so
-@dirrmtry share/pixmaps/synce
-@dirrmtry share/synce
+libexec/gvfsd-synce
+share/gvfs/mounts/synce.mount
+share/icons/gnome/48x48/apps/synce-gvfs.png
+@dirrmtry share/gvfs/mounts
+@dirrmtry share/gvfs
+@dirrmtry share/icons/gnome/48x48/apps
+@dirrmtry share/icons/gnome/48x48
+@dirrmtry share/icons/gnome
+@dirrmtry share/icons