aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
commit741aa714833b9bb1e9afaaf5124d3f5c60b5e49c (patch)
treee9b79b363f2fc4a63535a25c71491fa49a79b556 /palm
parente6b2e4b3537ce43e377d2f4fe0ac46b6ab8c4395 (diff)
downloadports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.tar.gz
ports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=218938
Diffstat (limited to 'palm')
-rw-r--r--palm/synce-hal/Makefile1
-rw-r--r--palm/synce-kde/Makefile1
-rw-r--r--palm/synce-libsynce/Makefile1
3 files changed, 0 insertions, 3 deletions
diff --git a/palm/synce-hal/Makefile b/palm/synce-hal/Makefile
index 849f5975f942..8c7cc1b18e20 100644
--- a/palm/synce-hal/Makefile
+++ b/palm/synce-hal/Makefile
@@ -23,7 +23,6 @@ LIB_DEPENDS= synce.0:${PORTSDIR}/palm/synce-libsynce \
USE_ICONV= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
PLIST_FILES= libexec/hal-dccm \
diff --git a/palm/synce-kde/Makefile b/palm/synce-kde/Makefile
index a34186cb9e7f..bf0ae5406f9b 100644
--- a/palm/synce-kde/Makefile
+++ b/palm/synce-kde/Makefile
@@ -30,7 +30,6 @@ USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_ICONV= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
INSTALLS_ICONS= yes
diff --git a/palm/synce-libsynce/Makefile b/palm/synce-libsynce/Makefile
index 60f97f679b9d..b4a45f289fcb 100644
--- a/palm/synce-libsynce/Makefile
+++ b/palm/synce-libsynce/Makefile
@@ -20,7 +20,6 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
USE_ICONV= yes
USE_GNOME= gnomehack gnometarget
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-libiconv-prefix="${LOCALBASE}" \
--enable-dccm-file-support=no \
--enable-hal-support=yes \