aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1998-11-06 21:17:33 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1998-11-06 21:17:33 +0000
commit79337a0bf003ff0a9fc1225cf80a6300bad30947 (patch)
tree94b2cda0604c0f7428b7dde76e2b554894c97e78 /palm
parent40f2086af44d51593192929b6b60b42ff547379c (diff)
downloadports-79337a0bf003ff0a9fc1225cf80a6300bad30947.tar.gz
ports-79337a0bf003ff0a9fc1225cf80a6300bad30947.zip
Previous commit for ELF broke a.out.
Alerted by: Satoshi Asami <asami@freebsd.org>
Notes
Notes: svn path=/head/; revision=14376
Diffstat (limited to 'palm')
-rw-r--r--palm/kpilot/Makefile5
-rw-r--r--palm/kpilot/files/patch-ab33
-rw-r--r--palm/kpilot/files/patch-ad11
-rw-r--r--palm/kpilot/files/patch-ae11
4 files changed, 46 insertions, 14 deletions
diff --git a/palm/kpilot/Makefile b/palm/kpilot/Makefile
index 175a81f0df85..bf4cbc2ad228 100644
--- a/palm/kpilot/Makefile
+++ b/palm/kpilot/Makefile
@@ -3,7 +3,7 @@
# Date created: 09 April 1998
# Whom: Stefan Eßer <se@freebsd.org>
#
-# $Id: Makefile,v 1.18 1998/11/04 03:35:10 nectar Exp $
+# $Id: Makefile,v 1.19 1998/11/06 04:20:59 asami Exp $
#
DISTNAME= kpilot-3.0.2
@@ -34,6 +34,7 @@ CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" \
MAKE_ENV= KDEDIR="${KDEDIR}"
pre-configure:
- ${CP} ${FILESDIR}/libtool ${FILESDIR}/ltmain.sh $(WRKSRC)/kpilot/libpilot
+ ${CP} ${FILESDIR}/libtool.${PORTOBJFORMAT} ${WRKSRC}/kpilot/libpilot/libtool
+ ${CP} ${FILESDIR}/ltmain.sh ${WRKSRC}/kpilot/libpilot/ltmain.sh
.include <bsd.port.mk>
diff --git a/palm/kpilot/files/patch-ab b/palm/kpilot/files/patch-ab
index b5ad96c1e907..dbada9a8300f 100644
--- a/palm/kpilot/files/patch-ab
+++ b/palm/kpilot/files/patch-ab
@@ -1,12 +1,21 @@
-*** kpilot/Makefile.in~ Sat Mar 7 14:21:14 1998
---- kpilot/Makefile.in Sat Mar 7 14:21:25 1998
-***************
-*** 582,587 ****
---- 582,588 ----
- $(INSTALL_DATA) kpilprc.xpm $(kde_icondir)
- $(mkinstalldirs) $(kde_minidir)
- $(INSTALL_DATA) mini-kpilot.xpm $(kde_minidir)/kpilot.xpm
-+ $(mkinstalldirs) $(kde_mimedir)
- grep kpilot $(MAGIC) 2>&1 >/dev/null || { cat kpilot.magic >> $(MAGIC); }
- $(mkinstalldirs) $(kde_mimedir)/palmpilot
- $(INSTALL_DATA) application.kdelnk $(kde_mimedir)/palmpilot
+--- kpilot/Makefile.in.orig Sun Apr 26 04:26:18 1998
++++ kpilot/Makefile.in Fri Nov 6 14:44:22 1998
+@@ -170,8 +170,8 @@
+ messageDialog.cc pilotLocalDatabase.cc kpilotlink.cc
+
+ # the library search path
+-kpilot_LDFLAGS = @all_libraries@ -L`pwd`/libpilot/_libs
+-kpilotDaemon_LDFLAGS = @all_libraries@ -L`pwd`/libpilot/_libs
++kpilot_LDFLAGS = -L`pwd`/libpilot/.libs @all_libraries@
++kpilotDaemon_LDFLAGS = -L`pwd`/libpilot/.libs @all_libraries@
+
+ # the libraries to link against. Be aware of the order. First the libraries,
+ # that depend on the following ones.
+@@ -582,6 +582,7 @@
+ $(INSTALL_DATA) kpilprc.xpm $(kde_icondir)
+ $(mkinstalldirs) $(kde_minidir)
+ $(INSTALL_DATA) mini-kpilot.xpm $(kde_minidir)/kpilot.xpm
++ $(mkinstalldirs) $(kde_mimedir)
+ grep kpilot $(MAGIC) 2>&1 >/dev/null || { cat kpilot.magic >> $(MAGIC); }
+ $(mkinstalldirs) $(kde_mimedir)/palmpilot
+ $(INSTALL_DATA) application.kdelnk $(kde_mimedir)/palmpilot
diff --git a/palm/kpilot/files/patch-ad b/palm/kpilot/files/patch-ad
new file mode 100644
index 000000000000..9ae35e02c700
--- /dev/null
+++ b/palm/kpilot/files/patch-ad
@@ -0,0 +1,11 @@
+--- conduits/vcalconduit/Makefile.in.orig Fri Nov 6 14:48:00 1998
++++ conduits/vcalconduit/Makefile.in Fri Nov 6 14:48:23 1998
+@@ -157,7 +157,7 @@
+ vcalconduit_SOURCES= vcal-conduit.cc vcal-setup.cc
+
+ # the library search path
+-vcalconduit_LDFLAGS = @all_libraries@ -L`pwd`/versit -L`pwd`/../../kpilot -L`pwd`/../../kpilot/libpilot/_libs
++vcalconduit_LDFLAGS = -L`pwd`/versit -L`pwd`/../../kpilot -L`pwd`/../../kpilot/libpilot/.libs @all_libraries@
+
+ # the libraries to link against. Be aware of the order. First the libraries,
+ # that depend on the following ones.
diff --git a/palm/kpilot/files/patch-ae b/palm/kpilot/files/patch-ae
new file mode 100644
index 000000000000..143a93d674f0
--- /dev/null
+++ b/palm/kpilot/files/patch-ae
@@ -0,0 +1,11 @@
+--- conduits/popmail/Makefile.in.orig Mon May 18 17:35:38 1998
++++ conduits/popmail/Makefile.in Fri Nov 6 14:50:31 1998
+@@ -157,7 +157,7 @@
+ popmail_conduit_SOURCES= popmail-conduit.cc passworddialog.cc parsedate.c setupDialog.cc
+
+ # the library search path
+-popmail_conduit_LDFLAGS = @all_libraries@ -L`pwd`/../../kpilot -L`pwd`/../../kpilot/libpilot/_libs
++popmail_conduit_LDFLAGS = -L`pwd`/../../kpilot -L`pwd`/../../kpilot/libpilot/.libs @all_libraries@
+
+ # the libraries to link against. Be aware of the order. First the libraries,
+ # that depend on the following ones.