aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-16 19:59:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-16 19:59:49 +0000
commit33204a44d3e45c5a0f8057d3b9a7768d9ba7896a (patch)
tree58620d96834e9f6470d8bb97911115bb2066b2e7 /palm
parenta869664db77bef617ca90adf4f75fa34766fcb59 (diff)
downloadports-33204a44d3e45c5a0f8057d3b9a7768d9ba7896a.tar.gz
ports-33204a44d3e45c5a0f8057d3b9a7768d9ba7896a.zip
Add synce-gnomevfs, a GNOME2 VFS module giving gnome-vfs aware applications
like Nautilus access to WinCE/PocketPC device file system. PR: ports/56067 Submitted by: Sam Lawrance <boris@brooknet.com.au>
Notes
Notes: svn path=/head/; revision=95962
Diffstat (limited to 'palm')
-rw-r--r--palm/Makefile1
-rw-r--r--palm/synce-gnomevfs/Makefile25
-rw-r--r--palm/synce-gnomevfs/distinfo1
-rw-r--r--palm/synce-gnomevfs/pkg-descr5
-rw-r--r--palm/synce-gnomevfs/pkg-plist4
-rw-r--r--palm/synce-gvfs/Makefile25
-rw-r--r--palm/synce-gvfs/distinfo1
-rw-r--r--palm/synce-gvfs/pkg-descr5
-rw-r--r--palm/synce-gvfs/pkg-plist4
9 files changed, 71 insertions, 0 deletions
diff --git a/palm/Makefile b/palm/Makefile
index 1a8167992cee..43a26be0ffc2 100644
--- a/palm/Makefile
+++ b/palm/Makefile
@@ -30,6 +30,7 @@
SUBDIR += sitescooper
SUBDIR += syncal
SUBDIR += synce-dccm
+ SUBDIR += synce-gnomevfs
SUBDIR += synce-librapi2
SUBDIR += synce-libsynce
SUBDIR += synce-serial
diff --git a/palm/synce-gnomevfs/Makefile b/palm/synce-gnomevfs/Makefile
new file mode 100644
index 000000000000..3be4efba0645
--- /dev/null
+++ b/palm/synce-gnomevfs/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: synce-gnomevfs
+# Date created: 28 August 2003
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+
+PORTNAME= synce-gnomevfs
+PORTVERSION= 0.8
+CATEGORIES= palm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= Gnome VFS module for WinCE devices
+
+LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2
+
+USE_GNOME= gnomeprefix gnometarget gnomevfs2
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS+= --with-librapi=${LOCALBASE}
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/palm/synce-gnomevfs/distinfo b/palm/synce-gnomevfs/distinfo
new file mode 100644
index 000000000000..4d8ed2025187
--- /dev/null
+++ b/palm/synce-gnomevfs/distinfo
@@ -0,0 +1 @@
+MD5 (synce-gnomevfs-0.8.tar.gz) = 1a85feb769215ee6f6c7da4a094d5382
diff --git a/palm/synce-gnomevfs/pkg-descr b/palm/synce-gnomevfs/pkg-descr
new file mode 100644
index 000000000000..f1da757cafc5
--- /dev/null
+++ b/palm/synce-gnomevfs/pkg-descr
@@ -0,0 +1,5 @@
+SynCE is a project for connecting to devices running Windows CE or Pocket PC.
+Gnomevfs gives Gnome applications like Nautilus the ability to access the file
+system on a Windows CE device via gnomevfs.
+
+WWW: http://synce.sourceforge.net/
diff --git a/palm/synce-gnomevfs/pkg-plist b/palm/synce-gnomevfs/pkg-plist
new file mode 100644
index 000000000000..d7c01cee7129
--- /dev/null
+++ b/palm/synce-gnomevfs/pkg-plist
@@ -0,0 +1,4 @@
+etc/gnome-vfs-2.0/modules/synce-module.conf
+lib/gnome-vfs-2.0/modules/libsyncevfs.a
+lib/gnome-vfs-2.0/modules/libsyncevfs.la
+lib/gnome-vfs-2.0/modules/libsyncevfs.so
diff --git a/palm/synce-gvfs/Makefile b/palm/synce-gvfs/Makefile
new file mode 100644
index 000000000000..3be4efba0645
--- /dev/null
+++ b/palm/synce-gvfs/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: synce-gnomevfs
+# Date created: 28 August 2003
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+
+PORTNAME= synce-gnomevfs
+PORTVERSION= 0.8
+CATEGORIES= palm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= Gnome VFS module for WinCE devices
+
+LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2
+
+USE_GNOME= gnomeprefix gnometarget gnomevfs2
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS+= --with-librapi=${LOCALBASE}
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/palm/synce-gvfs/distinfo b/palm/synce-gvfs/distinfo
new file mode 100644
index 000000000000..4d8ed2025187
--- /dev/null
+++ b/palm/synce-gvfs/distinfo
@@ -0,0 +1 @@
+MD5 (synce-gnomevfs-0.8.tar.gz) = 1a85feb769215ee6f6c7da4a094d5382
diff --git a/palm/synce-gvfs/pkg-descr b/palm/synce-gvfs/pkg-descr
new file mode 100644
index 000000000000..f1da757cafc5
--- /dev/null
+++ b/palm/synce-gvfs/pkg-descr
@@ -0,0 +1,5 @@
+SynCE is a project for connecting to devices running Windows CE or Pocket PC.
+Gnomevfs gives Gnome applications like Nautilus the ability to access the file
+system on a Windows CE device via gnomevfs.
+
+WWW: http://synce.sourceforge.net/
diff --git a/palm/synce-gvfs/pkg-plist b/palm/synce-gvfs/pkg-plist
new file mode 100644
index 000000000000..d7c01cee7129
--- /dev/null
+++ b/palm/synce-gvfs/pkg-plist
@@ -0,0 +1,4 @@
+etc/gnome-vfs-2.0/modules/synce-module.conf
+lib/gnome-vfs-2.0/modules/libsyncevfs.a
+lib/gnome-vfs-2.0/modules/libsyncevfs.la
+lib/gnome-vfs-2.0/modules/libsyncevfs.so