aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2001-02-14 22:50:24 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2001-02-14 22:50:24 +0000
commit607710a9e8020c62c06c22e514d4330b82bce221 (patch)
tree275c73bc1faa3432906dbc43ab25f147e35f3d9b /palm
parent34837ec97bd6dbf2951a22c455401b8e5aac3cc6 (diff)
downloadports-607710a9e8020c62c06c22e514d4330b82bce221.tar.gz
ports-607710a9e8020c62c06c22e514d4330b82bce221.zip
- Add write permission at post-patch stage to be able to build
by non-root users. - Remove -O flag from CFLAGS due to c++'s optimization bug. Approved by: maintainer Requested by: hanai
Notes
Notes: svn path=/head/; revision=38356
Diffstat (limited to 'palm')
-rw-r--r--palm/pilot-link-devel/Makefile9
-rw-r--r--palm/pilot-link/Makefile9
2 files changed, 16 insertions, 2 deletions
diff --git a/palm/pilot-link-devel/Makefile b/palm/pilot-link-devel/Makefile
index bcb2af9d5bbc..30a65ec6abe4 100644
--- a/palm/pilot-link-devel/Makefile
+++ b/palm/pilot-link-devel/Makefile
@@ -22,13 +22,20 @@ USE_PERL5= yes
PREFIX= ${LOCALBASE}/pilot
CONFIGURE_ARGS= --with-perl5=${PERL5}
+.include <bsd.port.pre.mk>
+
+CFLAGS!= ${ECHO} "${CFLAGS}" | ${SED} -e 's/-O[0-9a-z]*//g'
+
MAN1= dlpsh.1 ietf2datebook.1 install-datebook.1 \
install-hinote.1 install-memo.1 install-user.1 \
pilot-xfer.1 read-ical.1
MAN7= pilot-link.7
+post-patch:
+ @${CHMOD} 755 ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-install:
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/pilot-link.sh > ${LOCALBASE}/etc/rc.d/pilot-link.sh
@${CHMOD} 750 ${LOCALBASE}/etc/rc.d/pilot-link.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index bcb2af9d5bbc..30a65ec6abe4 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -22,13 +22,20 @@ USE_PERL5= yes
PREFIX= ${LOCALBASE}/pilot
CONFIGURE_ARGS= --with-perl5=${PERL5}
+.include <bsd.port.pre.mk>
+
+CFLAGS!= ${ECHO} "${CFLAGS}" | ${SED} -e 's/-O[0-9a-z]*//g'
+
MAN1= dlpsh.1 ietf2datebook.1 install-datebook.1 \
install-hinote.1 install-memo.1 install-user.1 \
pilot-xfer.1 read-ical.1
MAN7= pilot-link.7
+post-patch:
+ @${CHMOD} 755 ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-install:
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/pilot-link.sh > ${LOCALBASE}/etc/rc.d/pilot-link.sh
@${CHMOD} 750 ${LOCALBASE}/etc/rc.d/pilot-link.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>