aboutsummaryrefslogtreecommitdiff
path: root/polish/gnugadu2
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-21 21:38:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-21 21:38:29 +0000
commit814fd612218795053a15066da8e8f0014e1b7a55 (patch)
tree5ce521d3afdc5386414a51443d6ceb3db02028c9 /polish/gnugadu2
parent34c3ce0753f4c03105b88815a3fbb610aa807cfa (diff)
downloadports-814fd612218795053a15066da8e8f0014e1b7a55.tar.gz
ports-814fd612218795053a15066da8e8f0014e1b7a55.zip
- Update to 2.0.3
Submitted by: Piotr Smyrak <piotr.smyrak@heron.pl> (maintainer)
Notes
Notes: svn path=/head/; revision=114369
Diffstat (limited to 'polish/gnugadu2')
-rw-r--r--polish/gnugadu2/Makefile3
-rw-r--r--polish/gnugadu2/distinfo4
-rw-r--r--polish/gnugadu2/files/patch-src::plugins::GUI::GUI_plugin.c19
-rw-r--r--polish/gnugadu2/files/patch-src::plugins::gadu_gadu::gadu_gadu_plugin.c140
-rw-r--r--polish/gnugadu2/pkg-plist1
5 files changed, 164 insertions, 3 deletions
diff --git a/polish/gnugadu2/Makefile b/polish/gnugadu2/Makefile
index b780a2213635..8e98aa3b7e15 100644
--- a/polish/gnugadu2/Makefile
+++ b/polish/gnugadu2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnugadu2
-PORTVERSION= 2.0.2
+PORTVERSION= 2.0.3
CATEGORIES= polish net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ggadu
@@ -32,6 +32,7 @@ CONFIGURE_ARGS= --with-gui \
--with-gadu \
--with-sms \
--with-external \
+ --with-external-libgadu \
--with-update
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/polish/gnugadu2/distinfo b/polish/gnugadu2/distinfo
index 9143ca3073f8..ab61b5f0f57a 100644
--- a/polish/gnugadu2/distinfo
+++ b/polish/gnugadu2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gg2-2.0.2.tar.bz2) = 60505673a9c662e071caf6d1e181f2d6
-SIZE (gg2-2.0.2.tar.bz2) = 1158392
+MD5 (gg2-2.0.3.tar.bz2) = e8795ba49b9817a1db5e8628c9c9e30a
+SIZE (gg2-2.0.3.tar.bz2) = 1182315
diff --git a/polish/gnugadu2/files/patch-src::plugins::GUI::GUI_plugin.c b/polish/gnugadu2/files/patch-src::plugins::GUI::GUI_plugin.c
new file mode 100644
index 000000000000..d1218b9d6f1a
--- /dev/null
+++ b/polish/gnugadu2/files/patch-src::plugins::GUI::GUI_plugin.c
@@ -0,0 +1,19 @@
+--- src/plugins/GUI/GUI_plugin.c.orig Fri Jun 11 03:25:33 2004
++++ src/plugins/GUI/GUI_plugin.c Wed Jul 21 22:42:19 2004
+@@ -753,6 +753,7 @@
+ GGaduMsg *msg = signal->data;
+ gui_protocol *gp = NULL;
+ gchar *soundfile = NULL;
++ GtkWidget *window;
+
+ if (!signal || !msg)
+ {
+@@ -816,7 +817,7 @@
+ if (msg->message && (soundfile = ggadu_config_var_get(gui_handler, "sound_msg_in")))
+ signal_emit_full("main-gui", "sound play file", soundfile, "sound*", NULL);
+
+- GtkWidget *window = gtk_widget_get_ancestor(session->chat, GTK_TYPE_WINDOW);
++ window = gtk_widget_get_ancestor(session->chat, GTK_TYPE_WINDOW);
+ if (!GTK_WIDGET_VISIBLE(window)) {
+ if (showwindow) {
+ /* GtkWidget *input = g_object_get_data(G_OBJECT(session->chat), "input");
diff --git a/polish/gnugadu2/files/patch-src::plugins::gadu_gadu::gadu_gadu_plugin.c b/polish/gnugadu2/files/patch-src::plugins::gadu_gadu::gadu_gadu_plugin.c
new file mode 100644
index 000000000000..c35ad40f9995
--- /dev/null
+++ b/polish/gnugadu2/files/patch-src::plugins::gadu_gadu::gadu_gadu_plugin.c
@@ -0,0 +1,140 @@
+--- src/plugins/gadu_gadu/gadu_gadu_plugin.c.orig Sat Jun 12 09:04:53 2004
++++ src/plugins/gadu_gadu/gadu_gadu_plugin.c Wed Jul 21 23:11:11 2004
+@@ -385,6 +385,10 @@
+ GGaduMsg *msg = NULL;
+ gchar *hist_line = NULL;
+ gint i, j;
++ GSList *list;
++ GSList *us;
++ gchar *line2 = NULL;
++
+
+ /* w przypadku bledu/utraty polaczenia postap tak jak w przypadku disconnect */
+ if (!(e = gg_watch_fd(session)) || (condition & G_IO_ERR) ||
+@@ -524,9 +528,8 @@
+
+ }
+
+- GSList *list = ggadu_repo_get_as_slist("gadu-gadu", REPO_VALUE_CONTACT);
+- GSList *us = list;
+- gchar *line2 = NULL;
++ list = ggadu_repo_get_as_slist("gadu-gadu", REPO_VALUE_CONTACT);
++ us = list;
+
+ while(us)
+ {
+@@ -560,6 +563,8 @@
+ gchar *strIP = NULL;
+ gchar *id = g_strdup_printf("%d", e->event.notify60[i].uin);
+ struct in_addr ip_addr;
++ gchar *status = NULL;
++ gchar *line;
+ GGaduContact *k = ggadu_repo_find_value("gadu-gadu", ggadu_repo_key_from_string(id));
+
+ if (k)
+@@ -581,7 +586,7 @@
+
+ /* Zapiszmy sobie zmiane opisu do pliku historii */
+
+- gchar *status = NULL;
++ status = NULL;
+ if((k->status == GG_STATUS_AVAIL)||(k->status == GG_STATUS_AVAIL_DESCR)) status = g_strdup_printf("avail");
+ else if((k->status == GG_STATUS_BUSY)||(k->status == GG_STATUS_BUSY_DESCR)) status = g_strdup_printf("busy");
+ else if((k->status == GG_STATUS_INVISIBLE)||(k->status == GG_STATUS_INVISIBLE_DESCR)) status = g_strdup_printf("notavail");
+@@ -592,7 +597,7 @@
+ /* Format kompatybilny z historią Kadu ;) */
+ /* Jednak pierw należy skasować [numerek].idx aby uaktualnić ;) */
+
+- gchar *line = g_strdup_printf("status,%s,%s,%s,%d,%s%s\n", k->id, k->nick,
++ line = g_strdup_printf("status,%s,%s,%s,%d,%s%s\n", k->id, k->nick,
+ ((k->ip == NULL) ? "0.0.0.0" : k->ip), (int)time(0), status,
+ ((k->status_descr == NULL) ? "" : g_strdup_printf(",%s",k->status_descr)));
+ ggadu_gg_save_history((gchar *) k->id, line);
+@@ -623,6 +628,8 @@
+
+ while (n->uin)
+ {
++ gchar *status;
++ gchar *line;
+ gchar *id = g_strdup_printf("%d", n->uin);
+ GGaduContact *k = ggadu_repo_find_value("gadu-gadu", ggadu_repo_key_from_string(id));
+ struct in_addr ip_addr;
+@@ -647,7 +654,7 @@
+
+ /* Zapiszmy sobie zmiane opisu do pliku historii */
+
+- gchar *status = NULL;
++ status = NULL;
+ if((k->status == GG_STATUS_AVAIL)||(k->status == GG_STATUS_AVAIL_DESCR)) status = g_strdup_printf("avail");
+ else if((k->status == GG_STATUS_BUSY)||(k->status == GG_STATUS_BUSY_DESCR)) status = g_strdup_printf("busy");
+ else if((k->status == GG_STATUS_INVISIBLE)||(k->status == GG_STATUS_INVISIBLE_DESCR)) status = g_strdup_printf("notavail");
+@@ -658,7 +665,7 @@
+ /* Format kompatybilny z historią Kadu ;) */
+ /* Jednak pierw należy skasować [numerek].idx aby uaktualnić ;) */
+
+- gchar *line = g_strdup_printf("status,%s,%s,%s,%d,%s%s\n", k->id, k->nick,
++ line = g_strdup_printf("status,%s,%s,%s,%d,%s%s\n", k->id, k->nick,
+ ((k->ip == NULL) ? "0.0.0.0" : k->ip), (gint)time(0), status,
+ ((k->status_descr == NULL) ? "" : g_strdup_printf(",%s",k->status_descr)));
+ ggadu_gg_save_history((gchar *) k->id, line);
+@@ -674,6 +681,8 @@
+ case GG_EVENT_STATUS60:
+ case GG_EVENT_STATUS:
+ {
++ gchar *status;
++ gchar *line;
+ gchar *id =
+ g_strdup_printf("%d",
+ (e->type ==
+@@ -698,7 +707,7 @@
+
+ /* Zapiszmy sobie zmiane opisu do pliku historii */
+
+- gchar *status = NULL;
++ status = NULL;
+ if((k->status == GG_STATUS_AVAIL)||(k->status == GG_STATUS_AVAIL_DESCR)) status = g_strdup_printf("avail");
+ else if((k->status == GG_STATUS_BUSY)||(k->status == GG_STATUS_BUSY_DESCR)) status = g_strdup_printf("busy");
+ else if((k->status == GG_STATUS_INVISIBLE)||(k->status == GG_STATUS_INVISIBLE_DESCR)) status = g_strdup_printf("notavail");
+@@ -709,7 +718,7 @@
+ /* Format kompatybilny z historią Kadu ;) */
+ /* Jednak pierw należy skasować [numerek].idx aby uaktualnić ;) */
+
+- gchar *line = g_strdup_printf("status,%s,%s,%s,%d,%s%s\n", k->id, k->nick,
++ line = g_strdup_printf("status,%s,%s,%s,%d,%s%s\n", k->id, k->nick,
+ ((k->ip == NULL) ? "0.0.0.0" : k->ip), (gint)time(0), status,
+ ((k->status_descr == NULL) ? "" : g_strdup_printf(",%s",k->status_descr)));
+ ggadu_gg_save_history((gchar *) k->id, line);
+@@ -2275,6 +2284,7 @@
+ GSList *tmp = msg->recipients;
+ while (tmp)
+ {
++ gchar *line;
+ GSList *list = ggadu_repo_get_as_slist("gadu-gadu", REPO_VALUE_CONTACT);
+ GSList *us = list;
+ gchar *line2 = NULL;
+@@ -2288,7 +2298,7 @@
+ }
+
+
+- gchar *line =
++ line =
+ g_strdup_printf("chatsend,%s,%s,%d,%s\n", msg->id, line2, (gint)time(0), msg->message);
+ ggadu_gg_save_history((gchar *) tmp->data, line);
+ g_free(line2);
+@@ -2312,6 +2322,7 @@
+ }
+ else if (ggadu_config_var_get(handler, "log"))
+ {
++ gchar *line;
+ GSList *list = ggadu_repo_get_as_slist("gadu-gadu", REPO_VALUE_CONTACT);
+ GSList *us = list;
+ gchar *line2 = NULL;
+@@ -2324,7 +2335,7 @@
+ us = us->next;
+ }
+
+- gchar *line =
++ line =
+ g_strdup_printf("chatsend,%s,%s,%d,%s\n", msg->id, line2, (gint)time(0), msg->message);
+ ggadu_gg_save_history(msg->id, line);
+
diff --git a/polish/gnugadu2/pkg-plist b/polish/gnugadu2/pkg-plist
index 9c8906fd47ef..e61ad2f3909c 100644
--- a/polish/gnugadu2/pkg-plist
+++ b/polish/gnugadu2/pkg-plist
@@ -287,6 +287,7 @@ share/gg2/themes/vred2.theme
share/gg2/themes/white2.theme
%%GNOME:%%share/gnome/apps/Internet/gg2.desktop
%%GNOME:%%share/gnome/pixmaps/gg2.png
+share/locale/nl/LC_MESSAGES/gg2.mo
share/locale/pl/LC_MESSAGES/gg2.mo
share/pixmaps/gg2.png
@dirrm share/gg2/themes