aboutsummaryrefslogtreecommitdiff
path: root/polish
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-08 18:52:28 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-08 18:52:28 +0000
commit9043fdd66a0a5ea74f9cfa2299c5869e5fd4fad4 (patch)
treeac5f6e1689d3845c47a13701927000ad5468996c /polish
parent3214a7956f98a730c8071cd9984e42a90a748ea4 (diff)
downloadports-9043fdd66a0a5ea74f9cfa2299c5869e5fd4fad4.tar.gz
ports-9043fdd66a0a5ea74f9cfa2299c5869e5fd4fad4.zip
Add libtlen 20030721, backend for interoperability with
Tlen.pl, Polish IM network. PR: 57746 Submitted by: Piotr Smyrak <smyru@heron.pl>
Notes
Notes: svn path=/head/; revision=90656
Diffstat (limited to 'polish')
-rw-r--r--polish/Makefile1
-rw-r--r--polish/libtlen/Makefile28
-rw-r--r--polish/libtlen/distinfo1
-rw-r--r--polish/libtlen/files/patch-aa38
-rw-r--r--polish/libtlen/pkg-descr4
-rw-r--r--polish/libtlen/pkg-plist23
6 files changed, 95 insertions, 0 deletions
diff --git a/polish/Makefile b/polish/Makefile
index aa09ada107d4..b7bc49b5ea3f 100644
--- a/polish/Makefile
+++ b/polish/Makefile
@@ -8,6 +8,7 @@
SUBDIR += kadu
SUBDIR += kde3-i18n
SUBDIR += koffice-i18n
+ SUBDIR += libtlen
SUBDIR += ooodict_PL
SUBDIR += openoffice
SUBDIR += sms
diff --git a/polish/libtlen/Makefile b/polish/libtlen/Makefile
new file mode 100644
index 000000000000..9191afd11e98
--- /dev/null
+++ b/polish/libtlen/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libtlen
+# Date created: 25 September 2003
+# Whom: Piotr Smyrak <smyru@heron.pl> and
+# Maciek Korzen <eaquer@ceti.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtlen
+PORTVERSION= 20030721
+CATEGORIES= polish net
+MASTER_SITES= http://www.libtlen.eu.org/snapshots/archive/
+
+MAINTAINER= smyru@heron.pl
+COMMENT= Backend for interoperability with Tlen.pl, Polish IM network
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in libtlen.html libtlen.css AUTHORS TODO
+ @${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/polish/libtlen/distinfo b/polish/libtlen/distinfo
new file mode 100644
index 000000000000..885dffb803ff
--- /dev/null
+++ b/polish/libtlen/distinfo
@@ -0,0 +1 @@
+MD5 (libtlen-20030721.tar.gz) = 019a1c5b1640aa308f979024786e0237
diff --git a/polish/libtlen/files/patch-aa b/polish/libtlen/files/patch-aa
new file mode 100644
index 000000000000..69a189e4285a
--- /dev/null
+++ b/polish/libtlen/files/patch-aa
@@ -0,0 +1,38 @@
+--- lib/Makefile.in.orig Mon Sep 26 14:46:55 2003
++++ lib/Makefile.in Mon Sep 26 14:54:07 2003
+@@ -10,7 +10,7 @@
+ # incerased with ABI changes
+ VERSION_MAJOR=1
+ # incerased with API changes
+-VERSION_MINOR=5
++#VERSION_MINOR=5
+
+ CC = @CC@
+ CFLAGS = @CFLAGS_LIBTLEN@ -I.. -fPIC -Wall -ggdb
+@@ -27,7 +27,7 @@
+
+ SHAREDMM = libtlen.so
+ SHAREDM = $(SHAREDMM).$(VERSION_MAJOR)
+-SHARED = $(SHAREDM).$(VERSION_MINOR)
++SHARED = $(SHAREDMM).$(VERSION_MAJOR)
+ STATIC = libtlen.a
+
+ HEADERS = *.h
+@@ -54,7 +54,7 @@
+
+ $(SHARED): $(OBJS)
+ $(CC) -g -O2 -shared -Wl,-soname,libtlen.so.$(VERSION_MAJOR) -o $(SHARED) $(OBJS) $(LIBS) -lc
+- $(LN_S) -f $(SHARED) $(SHAREDM)
++# $(LN_S) -f $(SHARED) $(SHAREDM)
+ $(LN_S) -f $(SHARED) $(SHAREDMM)
+
+ install: install-shared install-static install-devel
+@@ -62,7 +62,7 @@
+ install-shared:
+ $(INSTALL) -d $(DESTDIR)$(libdir)
+ $(INSTALL) -m 755 $(SHARED) $(DESTDIR)$(libdir)
+- cd $(DESTDIR)$(libdir) && $(LN_S) -f $(SHARED) $(SHAREDM)
++# cd $(DESTDIR)$(libdir) && $(LN_S) -f $(SHARED) $(SHAREDM)
+ cd $(DESTDIR)$(libdir) && $(LN_S) -f $(SHARED) $(SHAREDMM)
+
+ install-static:
diff --git a/polish/libtlen/pkg-descr b/polish/libtlen/pkg-descr
new file mode 100644
index 000000000000..70767916524b
--- /dev/null
+++ b/polish/libtlen/pkg-descr
@@ -0,0 +1,4 @@
+A libtlen is a backend library to implement interoperability
+with Poland's Jabber protocol based Tlen.pl IM network.
+
+WWW: http://www.libtlen.eu.org/
diff --git a/polish/libtlen/pkg-plist b/polish/libtlen/pkg-plist
new file mode 100644
index 000000000000..f6ffeb3f92e1
--- /dev/null
+++ b/polish/libtlen/pkg-plist
@@ -0,0 +1,23 @@
+include/libtlen/asciitab.h
+include/libtlen/hashtable.h
+include/libtlen/iasciitab.h
+include/libtlen/latin1tab.h
+include/libtlen/libtlen.h
+include/libtlen/nametab.h
+include/libtlen/pool.h
+include/libtlen/str.h
+include/libtlen/utf8tab.h
+include/libtlen/xmldef.h
+include/libtlen/xmlparse.h
+include/libtlen/xmlrole.h
+include/libtlen/xmltok.h
+include/libtlen/xmltok_impl.h
+lib/libtlen.a
+lib/libtlen.so
+lib/libtlen.so.1
+@dirrm include/libtlen
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/libtlen.css
+%%PORTDOCS%%%%DOCSDIR%%/libtlen.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%