aboutsummaryrefslogtreecommitdiff
path: root/polish
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-05-17 15:12:15 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-05-17 15:12:15 +0000
commit60b54e328f718959bc9ddcb440fbfbcfce50c0e5 (patch)
treed9195b773b2a676c7806955c4f77771a1605086e /polish
parentf9149684aedb20e25e461b9e3c24d3ccd96e1b0c (diff)
downloadports-60b54e328f718959bc9ddcb440fbfbcfce50c0e5.tar.gz
ports-60b54e328f718959bc9ddcb440fbfbcfce50c0e5.zip
- Fix SSL bug and unbreak polish/gnugadu2 too.
PR: ports/122394 Submitted by: "Aleksander Fafula" <aleksander.fafula@gmail.com> Approved by: araujo (mentor), maintainer timeout (> 2 weeks)
Notes
Notes: svn path=/head/; revision=213199
Diffstat (limited to 'polish')
-rw-r--r--polish/libgadu/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/polish/libgadu/Makefile b/polish/libgadu/Makefile
index 283b852e15da..d86d51b349b0 100644
--- a/polish/libgadu/Makefile
+++ b/polish/libgadu/Makefile
@@ -6,6 +6,7 @@
PORTNAME= libgadu
PORTVERSION= 1.8.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= polish net
MASTER_SITES= http://toxygen.net/libgadu/files/
@@ -23,16 +24,26 @@ CONFIGURE_ARGS= --enable-shared --disable-static
USE_LDCONFIG= yes
+OPTIONS= OPENSSL "Build with OPENSSL support" on
+
PLIST_FILES= include/libgadu.h \
lib/libgadu.la \
lib/libgadu.so \
lib/libgadu.so.3 \
libdata/pkgconfig/libgadu.pc
-OPTIONS= OPENSSL "Build with OPENSSL support" on
+.include <bsd.port.pre.mk>
-.if defined(WITHOUT_OPENSSL)
+.if defined(WITH_OPENSSL)
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+.else
CONFIGURE_ARGS+= --without-openssl
.endif
-.include <bsd.port.mk>
+pre-install:
+
+.if defined(WITH_OPENSSL)
+ @${REINPLACE_CMD} -e 's|openssl| |g' ${WRKSRC}/pkgconfig/libgadu.pc
+.endif
+
+.include <bsd.port.post.mk>