aboutsummaryrefslogtreecommitdiff
path: root/polish
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-12-25 20:57:19 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-12-25 20:57:19 +0000
commit68ee588f2240dbff5a2833363e603ae59642259f (patch)
treef08ce0d142901b7380e93054cbe3f9fa10f00efd /polish
parentc1a3bd12af490b3d910b059f1a921a3d7bfd67f6 (diff)
downloadports-68ee588f2240dbff5a2833363e603ae59642259f.tar.gz
ports-68ee588f2240dbff5a2833363e603ae59642259f.zip
Add pl-sms 1.8.9h, send SMS to cellular phones in Poland (Idea,
ERA, Plus). PR: 33123 Submitted by: Michal Pasternak <doc@lublin.t1.pl>
Notes
Notes: svn path=/head/; revision=52172
Diffstat (limited to 'polish')
-rw-r--r--polish/sms/Makefile28
-rw-r--r--polish/sms/distinfo1
-rw-r--r--polish/sms/files/patch-Makefile46
-rw-r--r--polish/sms/pkg-comment1
-rw-r--r--polish/sms/pkg-descr3
-rw-r--r--polish/sms/pkg-plist12
-rw-r--r--polish/sms2/Makefile28
-rw-r--r--polish/sms2/distinfo1
-rw-r--r--polish/sms2/files/patch-Makefile46
-rw-r--r--polish/sms2/pkg-comment1
-rw-r--r--polish/sms2/pkg-descr3
-rw-r--r--polish/sms2/pkg-plist12
12 files changed, 182 insertions, 0 deletions
diff --git a/polish/sms/Makefile b/polish/sms/Makefile
new file mode 100644
index 000000000000..c44e26fe9e9e
--- /dev/null
+++ b/polish/sms/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: sms
+# Date created: 23 dec 2001
+# Whom: Michal Pasternak <doc@lublin.t1.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sms
+PORTVERSION= 1.8.9h
+CATEGORIES= misc
+MASTER_SITES= http://www.ceti.pl/~miki/komputery/download/sms/
+PKGNAMEPREFIX= pl-
+
+MAINTAINER= doc@lublin.t1.pl
+
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
+
+WRKSRC= ${WRKDIR}/sms
+USE_GMAKE= yes
+MAKE_ARGS= CXX="${CXX}"
+.if defined(NOPORTDOCS)
+MAKE_ARGS+= NOPORTDOCS=1
+.endif
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/bin/sms
+
+.include <bsd.port.mk>
diff --git a/polish/sms/distinfo b/polish/sms/distinfo
new file mode 100644
index 000000000000..d41857eb6d92
--- /dev/null
+++ b/polish/sms/distinfo
@@ -0,0 +1 @@
+MD5 (sms-1.8.9h.tar.gz) = f521bd847222a89835be31881767698b
diff --git a/polish/sms/files/patch-Makefile b/polish/sms/files/patch-Makefile
new file mode 100644
index 000000000000..6fd81e0c821f
--- /dev/null
+++ b/polish/sms/files/patch-Makefile
@@ -0,0 +1,46 @@
+$FreeBSD$
+
+--- Makefile.orig Tue Nov 13 07:43:24 2001
++++ Makefile Tue Dec 25 15:45:31 2001
+@@ -17,7 +17,7 @@
+ #
+ # wszystkie ww opcje nalezy dodawac do zmiennej CFLAGS
+
+-CFLAGS+=-O2
++#CFLAGS+=-O2
+
+ # dla starszych wersji Solarisa (tam gdzie nie ma snprintf, getdomainname,
+ # itd.) odkomentuj ponizsze dwie linie:
+@@ -38,15 +38,15 @@
+
+ # nw katalogi nie sa przeszukiwane automatycznie na FreeBSD, NetBSD i OpenBSD.
+ # Odkomentuj ponizsze linie jesli kompilujesz program na tych systemach
+-# BSD_INC=-I/usr/local/include -I/usr/pkg/include
+-# BSD_LIB=-L/usr/local/lib -L/usr/pkg/lib
++BSD_INC=-I/usr/local/include -I/usr/pkg/include
++BSD_LIB=-L/usr/local/lib -L/usr/pkg/lib
+
+ # katalog pod ktorym program zostanie zainstalowany po make install - binaria
+ # ida do $DIR/$BIN, reszta do $DIR/$DOC
+-PREFIX?=/usr/local
++PREFIX?=/usr/local/
+ INSTALL_PREFIX=$(PREFIX)
+ INSTALL_BIN=$(INSTALL_PREFIX)/bin
+-INSTALL_DOC=$(INSTALL_PREFIX)/doc/sms
++INSTALL_DOC=$(INSTALL_PREFIX)/share/doc/pl-sms
+
+ # ponizej juz nic nie powinno sie zmieniac
+
+@@ -101,10 +101,12 @@
+ install: all
+ mkdir -p -m 755 $(INSTALL_BIN)
+ install -s -m 755 $(TARGET) $(SMSADDR) $(INSTALL_BIN)
++ifndef NOPORTDOCS
+ mkdir -p $(INSTALL_DOC)/contrib
+ install -m 644 README* $(INSTALL_DOC)
+ install -m 644 contrib/* $(INSTALL_DOC)/contrib
+ chmod -R a+rX $(INSTALL_DOC)
++endif
+
+ archive: clean
+ ./make_archive
diff --git a/polish/sms/pkg-comment b/polish/sms/pkg-comment
new file mode 100644
index 000000000000..4275b236888c
--- /dev/null
+++ b/polish/sms/pkg-comment
@@ -0,0 +1 @@
+Send SMS to cellular phones in Poland (Idea, ERA, Plus)
diff --git a/polish/sms/pkg-descr b/polish/sms/pkg-descr
new file mode 100644
index 000000000000..70cd32fbc223
--- /dev/null
+++ b/polish/sms/pkg-descr
@@ -0,0 +1,3 @@
+A program to send SMS to cellular phones in Poland (Idea, ERA, Plus).
+
+WWW: http://www.ceti.pl/~miki/komputery/sms.html
diff --git a/polish/sms/pkg-plist b/polish/sms/pkg-plist
new file mode 100644
index 000000000000..bf49a5d92f0c
--- /dev/null
+++ b/polish/sms/pkg-plist
@@ -0,0 +1,12 @@
+bin/sms
+bin/smsaddr
+%%PORTDOCS%%share/doc/pl-sms/contrib/mimecut
+%%PORTDOCS%%share/doc/pl-sms/contrib/procmailrc
+%%PORTDOCS%%share/doc/pl-sms/contrib/sms-conf
+%%PORTDOCS%%share/doc/pl-sms/contrib/sms.cgi
+%%PORTDOCS%%share/doc/pl-sms/contrib/sms.html
+%%PORTDOCS%%share/doc/pl-sms/README
+%%PORTDOCS%%share/doc/pl-sms/README.first
+%%PORTDOCS%%share/doc/pl-sms/README.smsrc
+%%PORTDOCS%%@dirrm share/doc/pl-sms/contrib
+%%PORTDOCS%%@dirrm share/doc/pl-sms/
diff --git a/polish/sms2/Makefile b/polish/sms2/Makefile
new file mode 100644
index 000000000000..c44e26fe9e9e
--- /dev/null
+++ b/polish/sms2/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: sms
+# Date created: 23 dec 2001
+# Whom: Michal Pasternak <doc@lublin.t1.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sms
+PORTVERSION= 1.8.9h
+CATEGORIES= misc
+MASTER_SITES= http://www.ceti.pl/~miki/komputery/download/sms/
+PKGNAMEPREFIX= pl-
+
+MAINTAINER= doc@lublin.t1.pl
+
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
+
+WRKSRC= ${WRKDIR}/sms
+USE_GMAKE= yes
+MAKE_ARGS= CXX="${CXX}"
+.if defined(NOPORTDOCS)
+MAKE_ARGS+= NOPORTDOCS=1
+.endif
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/bin/sms
+
+.include <bsd.port.mk>
diff --git a/polish/sms2/distinfo b/polish/sms2/distinfo
new file mode 100644
index 000000000000..d41857eb6d92
--- /dev/null
+++ b/polish/sms2/distinfo
@@ -0,0 +1 @@
+MD5 (sms-1.8.9h.tar.gz) = f521bd847222a89835be31881767698b
diff --git a/polish/sms2/files/patch-Makefile b/polish/sms2/files/patch-Makefile
new file mode 100644
index 000000000000..6fd81e0c821f
--- /dev/null
+++ b/polish/sms2/files/patch-Makefile
@@ -0,0 +1,46 @@
+$FreeBSD$
+
+--- Makefile.orig Tue Nov 13 07:43:24 2001
++++ Makefile Tue Dec 25 15:45:31 2001
+@@ -17,7 +17,7 @@
+ #
+ # wszystkie ww opcje nalezy dodawac do zmiennej CFLAGS
+
+-CFLAGS+=-O2
++#CFLAGS+=-O2
+
+ # dla starszych wersji Solarisa (tam gdzie nie ma snprintf, getdomainname,
+ # itd.) odkomentuj ponizsze dwie linie:
+@@ -38,15 +38,15 @@
+
+ # nw katalogi nie sa przeszukiwane automatycznie na FreeBSD, NetBSD i OpenBSD.
+ # Odkomentuj ponizsze linie jesli kompilujesz program na tych systemach
+-# BSD_INC=-I/usr/local/include -I/usr/pkg/include
+-# BSD_LIB=-L/usr/local/lib -L/usr/pkg/lib
++BSD_INC=-I/usr/local/include -I/usr/pkg/include
++BSD_LIB=-L/usr/local/lib -L/usr/pkg/lib
+
+ # katalog pod ktorym program zostanie zainstalowany po make install - binaria
+ # ida do $DIR/$BIN, reszta do $DIR/$DOC
+-PREFIX?=/usr/local
++PREFIX?=/usr/local/
+ INSTALL_PREFIX=$(PREFIX)
+ INSTALL_BIN=$(INSTALL_PREFIX)/bin
+-INSTALL_DOC=$(INSTALL_PREFIX)/doc/sms
++INSTALL_DOC=$(INSTALL_PREFIX)/share/doc/pl-sms
+
+ # ponizej juz nic nie powinno sie zmieniac
+
+@@ -101,10 +101,12 @@
+ install: all
+ mkdir -p -m 755 $(INSTALL_BIN)
+ install -s -m 755 $(TARGET) $(SMSADDR) $(INSTALL_BIN)
++ifndef NOPORTDOCS
+ mkdir -p $(INSTALL_DOC)/contrib
+ install -m 644 README* $(INSTALL_DOC)
+ install -m 644 contrib/* $(INSTALL_DOC)/contrib
+ chmod -R a+rX $(INSTALL_DOC)
++endif
+
+ archive: clean
+ ./make_archive
diff --git a/polish/sms2/pkg-comment b/polish/sms2/pkg-comment
new file mode 100644
index 000000000000..4275b236888c
--- /dev/null
+++ b/polish/sms2/pkg-comment
@@ -0,0 +1 @@
+Send SMS to cellular phones in Poland (Idea, ERA, Plus)
diff --git a/polish/sms2/pkg-descr b/polish/sms2/pkg-descr
new file mode 100644
index 000000000000..70cd32fbc223
--- /dev/null
+++ b/polish/sms2/pkg-descr
@@ -0,0 +1,3 @@
+A program to send SMS to cellular phones in Poland (Idea, ERA, Plus).
+
+WWW: http://www.ceti.pl/~miki/komputery/sms.html
diff --git a/polish/sms2/pkg-plist b/polish/sms2/pkg-plist
new file mode 100644
index 000000000000..bf49a5d92f0c
--- /dev/null
+++ b/polish/sms2/pkg-plist
@@ -0,0 +1,12 @@
+bin/sms
+bin/smsaddr
+%%PORTDOCS%%share/doc/pl-sms/contrib/mimecut
+%%PORTDOCS%%share/doc/pl-sms/contrib/procmailrc
+%%PORTDOCS%%share/doc/pl-sms/contrib/sms-conf
+%%PORTDOCS%%share/doc/pl-sms/contrib/sms.cgi
+%%PORTDOCS%%share/doc/pl-sms/contrib/sms.html
+%%PORTDOCS%%share/doc/pl-sms/README
+%%PORTDOCS%%share/doc/pl-sms/README.first
+%%PORTDOCS%%share/doc/pl-sms/README.smsrc
+%%PORTDOCS%%@dirrm share/doc/pl-sms/contrib
+%%PORTDOCS%%@dirrm share/doc/pl-sms/