aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portell/Makefile
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2003-08-11 14:50:31 +0000
committerMichael Landin <mich@FreeBSD.org>2003-08-11 14:50:31 +0000
commitb8522e61c3d7f554a2a2203ce19ff594e0401354 (patch)
treead0414680ed0b8715983ea6b6e0758c725c0b2b0 /ports-mgmt/portell/Makefile
parentc6fcd5d2971ddadb839e9054fca5a3d6cba1f1bc (diff)
downloadports-b8522e61c3d7f554a2a2203ce19ff594e0401354.tar.gz
ports-b8522e61c3d7f554a2a2203ce19ff594e0401354.zip
Project moved to sourceforge servers.
Use DOCSDIR in pkg-plist. Distfile has been rerolled, no code changes - but archive type is now .zip, and code rewritten with windows style /r/n - patch is fixing this issue. Code tested with Python 2.2.x and 2.3 (Thanks marcus@) Approved by: roberto (mentor)
Notes
Notes: svn path=/head/; revision=86764
Diffstat (limited to 'ports-mgmt/portell/Makefile')
-rw-r--r--ports-mgmt/portell/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/ports-mgmt/portell/Makefile b/ports-mgmt/portell/Makefile
index 38541170255f..c334a6acfcfd 100644
--- a/ports-mgmt/portell/Makefile
+++ b/ports-mgmt/portell/Makefile
@@ -7,28 +7,27 @@
PORTNAME= portell
PORTVERSION= 0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc
-MASTER_SITES= http://freebsdcluster.org/~mich/software/ \
- http://www.seekrut.com/rk/
-DISTNAME= ${PORTNAME}
-DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .zip
MAINTAINER= mich@FreeBSD.org
COMMENT= Quick display of FreeBSD port descriptions
-PATCH_WRKSRC= ${WRKDIR}
+USE_ZIP= YES
USE_PYTHON= YES
USE_REINPLACE= YES
do-build:
- ${REINPLACE_CMD} -e 's/portell.py/portell/' ${WRKDIR}/README
+ ${REINPLACE_CMD} -e 's/portell.py/portell/' ${WRKSRC}/README.txt
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/portell.py ${PREFIX}/bin/portell
+ ${INSTALL_SCRIPT} ${WRKSRC}/portell.py ${PREFIX}/bin/portell
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
.endif
post-install:
@@ -36,7 +35,7 @@ post-install:
@${ECHO_MSG} ""
@${ECHO_MSG} "###############################################################################"
@${ECHO_MSG} "# You must run 'portell -u' to initialize the DB"
- @${ECHO_MSG} "# ${DOCSDIR}/README for more information."
+ @${ECHO_MSG} "# ${DOCSDIR}/README.txt for more information."
@${ECHO_MSG} "###############################################################################"
@${ECHO_MSG} ""
.endif