aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/qtpkg
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-01-23 16:47:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-01-23 16:47:05 +0000
commit7cacb2c79a256e6ffad4c27d5d2b8319ecea5040 (patch)
treec439d9c2e0d9bf5943a385ce591f049af8100471 /ports-mgmt/qtpkg
parent54e0d576e0c955240e41e87254251614e889d751 (diff)
downloadports-7cacb2c79a256e6ffad4c27d5d2b8319ecea5040.tar.gz
ports-7cacb2c79a256e6ffad4c27d5d2b8319ecea5040.zip
Add qtpkg 1.0, a Qt based package removal tool.
PR: 24573 Submitted by: Trenton Schulz <twschulz@cord.edu>
Notes
Notes: svn path=/head/; revision=37499
Diffstat (limited to 'ports-mgmt/qtpkg')
-rw-r--r--ports-mgmt/qtpkg/Makefile21
-rw-r--r--ports-mgmt/qtpkg/distinfo1
-rw-r--r--ports-mgmt/qtpkg/files/patch-Makefile25
-rw-r--r--ports-mgmt/qtpkg/pkg-comment1
-rw-r--r--ports-mgmt/qtpkg/pkg-descr4
-rw-r--r--ports-mgmt/qtpkg/pkg-plist1
6 files changed, 53 insertions, 0 deletions
diff --git a/ports-mgmt/qtpkg/Makefile b/ports-mgmt/qtpkg/Makefile
new file mode 100644
index 000000000000..12ae58f6a9df
--- /dev/null
+++ b/ports-mgmt/qtpkg/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: qtpkg
+# Date created: Wed Jan 3 2001
+# Whom: Trenton Schulz <twschulz@cord.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qtpkg
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://gauss.cord.edu/homepages/twschulz/demo/
+DISTNAME= qtpkg
+
+MAINTAINER= twschulz@gloria.cord.edu
+
+USE_QT2= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qtpkg ${PREFIX}/sbin
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/qtpkg/distinfo b/ports-mgmt/qtpkg/distinfo
new file mode 100644
index 000000000000..bb5358f4442d
--- /dev/null
+++ b/ports-mgmt/qtpkg/distinfo
@@ -0,0 +1 @@
+MD5 (qtpkg.tar.gz) = 0910416a0c23240e3f71d77f825618da
diff --git a/ports-mgmt/qtpkg/files/patch-Makefile b/ports-mgmt/qtpkg/files/patch-Makefile
new file mode 100644
index 000000000000..b053c5d68c8c
--- /dev/null
+++ b/ports-mgmt/qtpkg/files/patch-Makefile
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- Makefile 2001/01/23 16:32:54 1.1
++++ Makefile 2001/01/23 16:36:12
+@@ -9,13 +9,13 @@
+
+ CC = cc
+ CXX = c++
+-CFLAGS = -pipe -Wall -W -O2 -DNO_DEBUG
+-CXXFLAGS = -pipe -Wall -W -O2 -DNO_DEBUG
+-INCPATH = -I/usr/local/include -I/usr/X11R6/include/qt2
++CFLAGS += -pipe -Wall -W -DNO_DEBUG
++CXXFLAGS += -pipe -Wall -W -DNO_DEBUG
++INCPATH = -I$(LOCALBASE)/include -I$(X11BASE)/include/qt2
+ LINK = c++
+-LIBS = $(SUBLIBS) -L/usr/local/lib -L/usr/X11R6/lib -lqt2 -lXext -lX11 -lm
+-MOC = /usr/X11R6/bin/moc2
+-UIC = /usr/X11R6/bin/uic
++LIBS = $(SUBLIBS) -L$(LOCALBASE)/lib -L$(X11BASE)/lib -lqt2 -lXext -lX11 -lm -pthread
++MOC = $(X11BASE)/bin/moc2
++UIC = $(X11BASE)/bin/uic
+
+ TAR = tar -cf
+ GZIP = gzip -9f
diff --git a/ports-mgmt/qtpkg/pkg-comment b/ports-mgmt/qtpkg/pkg-comment
new file mode 100644
index 000000000000..d32e426501d5
--- /dev/null
+++ b/ports-mgmt/qtpkg/pkg-comment
@@ -0,0 +1 @@
+A Qt based package removal tool
diff --git a/ports-mgmt/qtpkg/pkg-descr b/ports-mgmt/qtpkg/pkg-descr
new file mode 100644
index 000000000000..aa1413f5ac39
--- /dev/null
+++ b/ports-mgmt/qtpkg/pkg-descr
@@ -0,0 +1,4 @@
+qtpkg simplifies the removal of packages by simulating the add/remove
+programs dialog as seen in Windows. Handy when you can't remember the
+correct version number. It also allows you to read the description of the
+package and its packing list.
diff --git a/ports-mgmt/qtpkg/pkg-plist b/ports-mgmt/qtpkg/pkg-plist
new file mode 100644
index 000000000000..c8de90e3b80d
--- /dev/null
+++ b/ports-mgmt/qtpkg/pkg-plist
@@ -0,0 +1 @@
+sbin/qtpkg