aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-11-06 17:15:50 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-11-06 17:15:50 +0000
commita2faad3b33731c7dddecd97e951d1123873a0aac (patch)
treea517b72c2f83e4ccfcf6619c937edbd720105409 /ports-mgmt
parentf04d78fcd50f0454f3166c0a1bb3c01fa5e3020f (diff)
downloadports-a2faad3b33731c7dddecd97e951d1123873a0aac.tar.gz
ports-a2faad3b33731c7dddecd97e951d1123873a0aac.zip
For a given port determine its dependences using any combination of the
- FETCH_DEPENDS - EXTRACT_DEPENDS - PATCH_DEPENDS - LIB_DEPENDS - BUILD_DEPENDS - RUN_DEPENDS and show them as a pseudo graphical tree. Use back references for cross-connections. WWW: http://code.google.com/p/porttree/ PR: ports/160007 Submitted by: Vladimir Chukharev
Notes
Notes: svn path=/head/; revision=285177
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/porttree/Makefile44
-rw-r--r--ports-mgmt/porttree/distinfo2
-rw-r--r--ports-mgmt/porttree/pkg-descr12
4 files changed, 59 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index a772935169b4..515842ffcc2c 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -64,6 +64,7 @@
SUBDIR += portshaker-config
SUBDIR += portsopt
SUBDIR += porttools
+ SUBDIR += porttree
SUBDIR += portupdate-scan
SUBDIR += portupgrade
SUBDIR += portupgrade-devel
diff --git a/ports-mgmt/porttree/Makefile b/ports-mgmt/porttree/Makefile
new file mode 100644
index 000000000000..d66b5f5f74a7
--- /dev/null
+++ b/ports-mgmt/porttree/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: porttree
+# Date created: 18 Aug 2011
+# Whom: Vladimir Chukharev
+#
+# $FreeBSD$
+#
+
+PORTNAME= porttree
+PORTVERSION= 0.2.r${SVN_REV}
+CATEGORIES= ports-mgmt python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= Vladimir.Chukharev@gmail.com
+COMMENT= Show dependences of FreeBSD port as pseudo graphical tree
+
+LICENSE= MIT
+
+MAN1= porttree.1
+USE_BZIP2= yes
+USE_PYTHON= 2.4+
+
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}networkx>=1.5:${PORTSDIR}/math/py-networkx
+
+.if target(gen-dist)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+.endif
+
+SVNROOT?= http://porttree.googlecode.com/svn/trunk/
+SVN_REV= 20
+NO_BUILD= yes
+NO_INSTALL= yes
+PLIST_FILES= bin/porttree
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/porttree.py ${PREFIX}/bin/porttree
+ ${INSTALL_MAN} ${WRKSRC}/src/porttree.1 ${MAN8PREFIX}/man/man1
+
+gen-dist:
+ ${MKDIR} ${WRKDIR}
+ ${RM} -rf ${WRKSRC}
+ svn export -r ${SVN_REV} ${SVNROOT} ${WRKSRC}
+ ${TAR} -cvy -C ${WRKDIR} --exclude FreeBSDport -f ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/porttree/distinfo b/ports-mgmt/porttree/distinfo
new file mode 100644
index 000000000000..d5e81389e9c4
--- /dev/null
+++ b/ports-mgmt/porttree/distinfo
@@ -0,0 +1,2 @@
+SHA256 (porttree-0.2.r20.tar.bz2) = ebb32cd9283aa74683cb612b464b2b1426481e65e9264a04c82d2b92cd180503
+SIZE (porttree-0.2.r20.tar.bz2) = 8724
diff --git a/ports-mgmt/porttree/pkg-descr b/ports-mgmt/porttree/pkg-descr
new file mode 100644
index 000000000000..41b71cc0a889
--- /dev/null
+++ b/ports-mgmt/porttree/pkg-descr
@@ -0,0 +1,12 @@
+For a given port determine its dependences using any combination of the
+ - FETCH_DEPENDS
+ - EXTRACT_DEPENDS
+ - PATCH_DEPENDS
+ - LIB_DEPENDS
+ - BUILD_DEPENDS
+ - RUN_DEPENDS
+
+and show them as a pseudo graphical tree.
+Use back references for cross-connections.
+
+WWW: http://code.google.com/p/porttree/