aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-02-22 18:21:46 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2017-02-22 18:21:46 +0000
commitdf4e2f3a7178c29e717b3d324f340daa6701d47d (patch)
tree43c96d8d485cd00f86535727323fed7d0f47e338 /ports-mgmt
parent1f9f34c36522ec193ea3f48264397a3e54198d23 (diff)
downloadports-df4e2f3a7178c29e717b3d324f340daa6701d47d.tar.gz
ports-df4e2f3a7178c29e717b3d324f340daa6701d47d.zip
Update to 3.0-1822-ge8f0d3e
- Manpage updates - Remove pkg_install support. - Remove NO_STAGE support. - Remove use of umount -f where possible. - Use relative paths where possible to avoid namecache contention. - USE_CACHED reworked to use POSIX mq (will soon change again) - PRIORITY_BOOST is fixed to boost dependencies as well now with USE_PTSORT enabled (default yes). - Load linux64 when needed - Improved ports_env support (less executions during ports interations) - Show resource limits in build log - Limit filedescriptors to 1024 by default with MAX_FILES - Shutdown/unmount build jails in parallel - Don't leak mount path in build log from ident(1) - sh: Add some builtins to avoid fork/execs (mostly poudriere C helpers): cachec, clock_monotonic, date +%s, dirempty, locked_mkdir, realpath, sleep - BUILD_AS_NON_ROOT: Remove redundant chown -R. - Add HTML_JSON_UPDATE_INTERVAL (def: 2) to allow overriding JSON update interval. - Add support for USE_TMPFS=no - jail: install the kernel requested with -K when using src method - jail -c -m src: Add support for building the src tree with -b. - jail -u -m src: Update the version for the jail as well. - jail -c: Allow @rev for releng/X.Y branch - jail: Switch to http protocol for ftp-archive. - ports: Do not create a FS when '-m none' - ports -d: Do not delete a ports tree created with method=none or -. - ports -d: Confirm if in a TTY - ports -d: Really delete the zfs dataset when TMPFS_ALL is used - ports: Add git+http support - ports/jail: Auto pass PROXY env vars from parent environment - image: only isos have a restriction in the image name - image: If the images dir does not exist, attempt to create it - image: Handle a relative path with -o - image: Various fixes. - image: usb|*firmware|rawdisk now require a kernel and image size. - testport: Fix fdescfs/procfs/linprocfs not being mounted. - testport: Fix limits not being applied - testport+SIGINFO: Fix very old deadlock with update_stats. - pkgclean: Add hook: pkgclean done <DELETED_FILES: 0|1> <BUILT_REPO: 0|1> - pkgclean: Cleanup corrupt packages - pkgclean: Act on .latest directory for ATOMIC_PACKAGE_REPOSITORY - poudriere.conf: Don't suggest changing svn.FreeBSD.org to a mirror anymore. - QEMU+Arm64: Coppy the latest aarch64-binutils ld into the jail at startup. - QEMU+Arm64: Link /usr/bin/ld to /nxb-bin/usr/bin/ld. - QEMU+Arm64: Tell about copying ld * QEMU+Arm64: Note that this is not working properly yet due to the aarch64-binutils port not providing a static ld. - options: Properly setup ARCH/MACHINE in make.conf for cross-builds
Notes
Notes: svn path=/head/; revision=434625
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/poudriere-devel/Makefile6
-rw-r--r--ports-mgmt/poudriere-devel/distinfo6
-rw-r--r--ports-mgmt/poudriere-devel/files/patch-arm64-binutils29
-rw-r--r--ports-mgmt/poudriere-devel/files/patch-mkdir-vp19
-rw-r--r--ports-mgmt/poudriere-devel/files/patch-src__libexec__poudriere__cached__cached.c12
-rw-r--r--ports-mgmt/poudriere-devel/pkg-plist4
6 files changed, 21 insertions, 55 deletions
diff --git a/ports-mgmt/poudriere-devel/Makefile b/ports-mgmt/poudriere-devel/Makefile
index 0c2031ebe274..f19f2ba1b417 100644
--- a/ports-mgmt/poudriere-devel/Makefile
+++ b/ports-mgmt/poudriere-devel/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= poudriere
-DISTVERSION= 3.1.99.20160624
-PORTREVISION= 3
+DISTVERSION= 3.1.99.20170221
+PORTREVISION= 0
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/bdrewery/${PORTNAME}/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
@@ -18,7 +18,7 @@ CONFLICTS_INSTALL= poudriere-[0-9]*
USE_GITHUB= yes
GH_ACCOUNT= freebsd
-GH_TAGNAME= 3.0-1677-g146fc3f
+GH_TAGNAME= 3.0-1822-ge8f0d3e
#DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${GH_TAGNAME}
GNU_CONFIGURE= yes
diff --git a/ports-mgmt/poudriere-devel/distinfo b/ports-mgmt/poudriere-devel/distinfo
index 35c457ed57d4..00ae0073366a 100644
--- a/ports-mgmt/poudriere-devel/distinfo
+++ b/ports-mgmt/poudriere-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1466783382
-SHA256 (freebsd-poudriere-3.1.99.20160624-3.0-1677-g146fc3f_GH0.tar.gz) = 7f8071d836dd8770d098514059604eca898d06ce99f71bff082d168aa6fa6906
-SIZE (freebsd-poudriere-3.1.99.20160624-3.0-1677-g146fc3f_GH0.tar.gz) = 2939889
+TIMESTAMP = 1487697127
+SHA256 (freebsd-poudriere-3.1.99.20170221-3.0-1822-ge8f0d3e_GH0.tar.gz) = 6f2702bd7f4f753c40a43df6599a46657766d39deda83a2e2df746d1525fb68a
+SIZE (freebsd-poudriere-3.1.99.20170221-3.0-1822-ge8f0d3e_GH0.tar.gz) = 2952866
diff --git a/ports-mgmt/poudriere-devel/files/patch-arm64-binutils b/ports-mgmt/poudriere-devel/files/patch-arm64-binutils
deleted file mode 100644
index c6aefa27c523..000000000000
--- a/ports-mgmt/poudriere-devel/files/patch-arm64-binutils
+++ /dev/null
@@ -1,29 +0,0 @@
-commit 58b0c214d76525e53745133cd3de56eda5379934
-Author: Bryan Drewery <bryan@shatow.net>
-Date: Fri Aug 26 14:23:39 2016 -0700
-
- For arm64 copy the latest aarch64-binutils ld into the jail at startup.
-
- This will work like the qemu installation done at startup, and not require
- messing with the jail creation/update or snapshots.
-
-diff --git src/share/poudriere/common.sh src/share/poudriere/common.sh
-index 4261243..8e0c8cf 100755
---- src/share/poudriere/common.sh
-+++ src/share/poudriere/common.sh
-@@ -1795,6 +1795,15 @@ jail_start() {
- mkdir -p "${tomnt}${EMULATOR%/*}"
- cp -f "${EMULATOR}" "${tomnt}${EMULATOR}"
- fi
-+ # Handle special ARM64 needs
-+ if [ "${arch#*.}" = "aarch64" ] && ! [ -f "${tomnt}/usr/bin/ld" ]; then
-+ if [ -f /usr/local/aarch64-freebsd/bin/ld ]; then
-+ cp -f /usr/local/aarch64-freebsd/bin/ld \
-+ "${tomnt}/usr/bin/ld"
-+ else
-+ err 1 "Arm64 requires aarch64-binutils to be installed."
-+ fi
-+ fi
-
- if [ -d "${CCACHE_DIR:-/nonexistent}" ]; then
- cat >> "${tomnt}/etc/make.conf" <<-EOF
diff --git a/ports-mgmt/poudriere-devel/files/patch-mkdir-vp b/ports-mgmt/poudriere-devel/files/patch-mkdir-vp
deleted file mode 100644
index 986595e127fa..000000000000
--- a/ports-mgmt/poudriere-devel/files/patch-mkdir-vp
+++ /dev/null
@@ -1,19 +0,0 @@
-commit e7a21685d30fc183b46cd7c5e0f134ce3a6126fc
-Author: Bryan Drewery <bryan@shatow.net>
-Date: Fri Jun 24 08:52:08 2016 -0700
-
- Don't use -v for mkdir
-
-diff --git src/share/poudriere/common.sh src/share/poudriere/common.sh
-index 00eecca..75c02b7 100755
---- src/share/poudriere/common.sh
-+++ src/share/poudriere/common.sh
-@@ -1179,7 +1179,7 @@ do_jail_mounts() {
-
- fi
- echo ${nullpaths} | tr ' ' '\n' | sed -e "s,^/,${mnt}/," | \
-- xargs mkdir -vp
-+ xargs mkdir -p
- for nullpath in ${nullpaths}; do
- [ -d "${from}${nullpath}" -a "${from}" != "${mnt}" ] && \
- ${NULLMOUNT} -o ro "${from}${nullpath}" "${mnt}${nullpath}"
diff --git a/ports-mgmt/poudriere-devel/files/patch-src__libexec__poudriere__cached__cached.c b/ports-mgmt/poudriere-devel/files/patch-src__libexec__poudriere__cached__cached.c
new file mode 100644
index 000000000000..ab14e5f02c78
--- /dev/null
+++ b/ports-mgmt/poudriere-devel/files/patch-src__libexec__poudriere__cached__cached.c
@@ -0,0 +1,12 @@
+diff --git src/libexec/poudriere/cached/cached.c src/libexec/poudriere/cached/cached.c
+index 68ba6e6..ce266cd 100644
+--- src/libexec/poudriere/cached/cached.c
++++ src/libexec/poudriere/cached/cached.c
+@@ -26,6 +26,7 @@
+
+ #include <sys/types.h>
+
++#include <inttypes.h>
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <string.h>
diff --git a/ports-mgmt/poudriere-devel/pkg-plist b/ports-mgmt/poudriere-devel/pkg-plist
index 16b9356375e5..b88fcc6ddab7 100644
--- a/ports-mgmt/poudriere-devel/pkg-plist
+++ b/ports-mgmt/poudriere-devel/pkg-plist
@@ -4,8 +4,9 @@ bin/poudriere
%%ETCDIR%%/hooks/pkgbuild.sh.sample
@sample etc/poudriered.conf.sample
etc/rc.d/poudriered
+libexec/poudriere/cachec
libexec/poudriere/cached
-libexec/poudriere/clock_monotonic
+libexec/poudriere/clock
libexec/poudriere/cpdup
libexec/poudriere/dirempty
libexec/poudriere/dirwatch
@@ -13,6 +14,7 @@ libexec/poudriere/jexecd
libexec/poudriere/locked_mkdir
libexec/poudriere/nc
libexec/poudriere/poudriered
+libexec/poudriere/ptsort
libexec/poudriere/rename
libexec/poudriere/rexec
libexec/poudriere/sh