aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-07 06:42:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-07 06:42:55 +0000
commit0038a8163354d18c9135abcf0e6239c10807e6fa (patch)
tree0bec15049eeff4c713396223433c3d29a1cbab65 /ports-mgmt
parent7df08c14991f8dd971207af02a318617313c27fd (diff)
downloadports-0038a8163354d18c9135abcf0e6239c10807e6fa.tar.gz
ports-0038a8163354d18c9135abcf0e6239c10807e6fa.zip
Update to 2.5.6.
* Check to make sure RCS tags begin with capital letters [1] * Do not look direct command use in .for loops [2] PR: 60947 [1] Submitted by: leeym [1] petef [2]
Notes
Notes: svn path=/head/; revision=97545
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl9
2 files changed, 7 insertions, 4 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 36c774cf8935..f08f192ce902 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.5.5
+PORTVERSION= 2.5.6
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 5d78ead03240..588960969082 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $Id: portlint.pl,v 1.35 2004/01/02 02:14:06 marcus Exp $
+# $Id: portlint.pl,v 1.36 2004/01/07 06:41:26 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_c $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -40,7 +40,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 5;
-my $micro = 5;
+my $micro = 6;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -894,7 +894,7 @@ sub checkpatch {
while (<IN>) {
$whole .= $_;
}
- if ($committer && $whole =~ /\$([A-Za-z0-9]+)[:\$]/) {
+ if ($committer && $whole =~ /\$([A-Z][A-Za-z0-9]+)(:[^\n]+)?\$/) {
my $lineno = &linenumber($`);
&perror("WARN: $file [$lineno]: includes possible RCS tag \"\$$1\$\". ".
"use binary mode (-ko) on commit/import.") unless
@@ -1137,6 +1137,9 @@ ldconfig ln md5 mkdir mv patch perl rm rmdir ruby sed sh touch tr which xargs xm
# use of echo itself.
$j = $whole;
$j =~ s/([ \t][\@\-]{0,2})(echo|\$[\{\(]ECHO[\}\)]|\$[\{\(]ECHO_MSG[\}\)])[ \t]+("(\\'|\\"|[^"])*"|'(\\'|\\"|[^'])*')[ \t]*;?(\n?)/$1$2;$3/g; #"
+ # ignore variables names in .for loops, but not what's at the end
+ # of the for loop
+ $j =~ s/(\.for +)([^ ]*)( .*)/$1$3/;
foreach my $i (keys %cmdnames) {
# XXX This is a hack. Really, we should break $j up into individual
# lines, and go through each one.