aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-15 18:52:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-15 18:52:43 +0000
commit211310fbace297b5af18fdad44c887b3b673f543 (patch)
treeaeb6160b3a94846383d61ab37c43b75a12375b52 /ports-mgmt
parentca21d1c9b6f416f7e2f3d15d12e7fe46b8b15184 (diff)
downloadports-211310fbace297b5af18fdad44c887b3b673f543.tar.gz
ports-211310fbace297b5af18fdad44c887b3b673f543.zip
- Fix finding original directory name for py- and ruby- ports
PR: ports/70156 Submitted by: clsung - Add detection of leftover empty directories to leftover checking code PR: ports/71363 Submitted by: leeym
Notes
Notes: svn path=/head/; revision=139298
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/porttools/Makefile4
-rw-r--r--ports-mgmt/porttools/files/patch-util_diff.in18
2 files changed, 20 insertions, 2 deletions
diff --git a/ports-mgmt/porttools/Makefile b/ports-mgmt/porttools/Makefile
index e88e07730939..56e5285654bb 100644
--- a/ports-mgmt/porttools/Makefile
+++ b/ports-mgmt/porttools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= porttools
PORTVERSION= 0.63
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,7 +29,7 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/newfile:${PORTSDIR}/devel/newfile
INSTALL_TARGET= install install-docs
.endif
-MAKE_ENV= PREFIX="${PREFIX}" DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
+MAKE_ENV= DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
MAN1= port.1
MAN5= porttools.5
diff --git a/ports-mgmt/porttools/files/patch-util_diff.in b/ports-mgmt/porttools/files/patch-util_diff.in
new file mode 100644
index 000000000000..bfa8d3650480
--- /dev/null
+++ b/ports-mgmt/porttools/files/patch-util_diff.in
@@ -0,0 +1,18 @@
+--- util_diff.in.orig Sat Aug 7 06:10:14 2004
++++ util_diff.in Sun Aug 8 16:26:26 2004
+@@ -70,10 +70,12 @@
+ # -d <dir> have been specified
+ # it should be Ports tree location
+ CATEGORY="`make -V CATEGORIES | sed -E 's/^([^ ]+).*$/\1/'`"
+- PKGNAMEPREFIX="`make -V PKGNAMEPREFIX`"
++ PYTHON_SUFFIX="`make -V PYTHON_SUFFIX`"
++ RUBY_SUFFIX="`make -V RUBY_SUFFIX`"
++ PKGNAMEPREFIX="`make -V PKGNAMEPREFIX | sed -E "s,py${PYTHON_SUFFIX}-,py-," | sed -E "s,ruby${RUBY_SUFFIX}-,ruby-,"`"
+ PKGNAMESUFFIX="`make -V PKGNAMESUFFIX`"
+- PORTNAME="`make -V PORTNAME`"
+- ORIG_DIR="${DIFF_MODE}/${CATEGORY}/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}"
++ PORTNAME="${PKGNAMEPREFIX}`make -V PORTNAME`${PKGNAMESUFFIX}"
++ ORIG_DIR="${DIFF_MODE}/${CATEGORY}/${PORTNAME}"
+ else
+ # -d <pattern> have been specified
+ # <pattern> is used to determine original port location