aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-10-08 19:50:49 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-10-08 19:50:49 +0000
commita659a8b6e92bf4a04a25104bfee4727b47e20dd9 (patch)
tree2b3b69865a8a77f47812a2f9dc7a83c9dd3c3254 /ports-mgmt
parent1340bed938a430c15c1e2a41631159fa94a7ca8d (diff)
downloadports-a659a8b6e92bf4a04a25104bfee4727b47e20dd9.tar.gz
ports-a659a8b6e92bf4a04a25104bfee4727b47e20dd9.zip
Update to 2.13.13.
* Reduce false alarms when checking for MAN* and MAN*PREFIX. [1] * Don't over-warn when using PORT_OPTIONS:MDOCS with ${PREFIX}/share/doc/${PORTNAME}. [2] * Remove spurious warnings about CPPFLAGS and LDFLAGS. [3] * Make sure we do not throw a warning if USE_GCC=any is used. [4] PR: 169745 [1] 171535 [2] 172335 [3] Submitted by: sunpoet [1] Hung-te Liang <lhd@cs.nctu.edu.tw> [2] glarkin [3] Suggested by: eadler [4]
Notes
Notes: svn path=/head/; revision=305554
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile6
-rw-r--r--ports-mgmt/portlint/src/portlint.pl23
2 files changed, 13 insertions, 16 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 4e7f3fd4a1b2..e77851d1ff04 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -1,6 +1,4 @@
-# New ports collection makefile for: portlint
-# Date created: 13 Jun 1997
-# Whom: Jun-ichiro itojun Hagino <itojun@itojun.org>
+# Created by: Jun-ichiro itojun Hagino <itojun@itojun.org>
#
# $FreeBSD$
#
@@ -8,7 +6,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.13.12
+PORTVERSION= 2.13.13
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 3552f035cee3..147a4dfd1980 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.252 2012/08/05 22:18:57 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.257 2012/10/08 19:52:14 marcus Exp $
#
use strict;
@@ -52,7 +52,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 13;
-my $micro = 12;
+my $micro = 13;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -1762,9 +1762,8 @@ sub checkmakefile {
"mean NOPORTDOCS?");
}
if ($sharedocused && $whole !~ /defined\s*\(?NOPORTDOCS\)?/
- && $whole !~ /def\s*\(?NOPORTDOCS\)?/
- && $whole !~ m#(\$[\{\(]PREFIX[\}\)]|$localbase)/share/doc#) {
- if ($docsused == 0) {
+ && $whole !~ /def\s*\(?NOPORTDOCS\)?/) {
+ if ($docsused == 0 && $whole !~ m#(\$[\{\(]PREFIX[\}\)]|$localbase)/share/doc#) {
&perror("WARN", $file, -1, "use \".if !defined(NOPORTDOCS)\" to wrap ".
"installation of files into $localbase/share/doc.");
}
@@ -2044,7 +2043,7 @@ ruby sed sh sort sysctl touch tr which xargs xmkmf
&perror("WARN", $file, $lineno, "USE_GCC=4.2+ is recommended ".
"over USE_GCC=4.1+ since the former is the system compiler ".
"for FreeBSD 7.X.");
- } elsif ($gcc_val !~ /\+/) {
+ } elsif ($gcc_val !~ /\+/ && $gcc_val ne 'any') {
&perror("WARN", $file, $lineno, "Setting a specific version for ".
"USE_GCC should only be done as a last resort. Unless you ".
"have confirmed this port does not build with later ".
@@ -2186,14 +2185,14 @@ ruby sed sh sort sysctl touch tr which xargs xmkmf
"instead with $1=...");
}
- if ($configure_env =~ /(CPPFLAGS)=/) {
+ if ($configure_env =~ /(\bCPPFLAGS)=/) {
&perror("FATAL", $file, -1, "$1 is already ".
"passed in CONFIGURE_ENV via bsd.port.mk. If you need to ".
"override the default value, alter $1 in the Makefile ".
"instead with $1+=...");
}
- if ($configure_env =~ /(LDFLAGS)=/) {
+ if ($configure_env =~ /(\bLDFLAGS)=/) {
&perror("FATAL", $file, -1, "$1 is already passed in ".
"CONFIGURE_ENV via bsd.port.mk. If you need to ".
"override the default value, alter $1 in the Makefile ".
@@ -3027,25 +3026,25 @@ TEST_DEPENDS FETCH_DEPENDS DEPENDS_TARGET
print "OK: pkg-plist MAN$i=$plistmanall{$i}\n" if ($verbose);
}
if ($tmp =~ /PERL_CONFIGURE=\s*/
- && $tmp =~ /MAN3PREFIX=\s*\${PREFIX}\/lib\/perl5\/\${PERL_VERSION}/) {
+ && $tmp =~ /^MAN3PREFIX=\s*\${PREFIX}\/lib\/perl5\/\${PERL_VERSION}/) {
&perror("WARN", $file, -1, "MAN3PREFIX is ".
"\"\${PREFIX}/lib/perl5/\${PERL_VERSION}\" ".
"when PERL_CONFIGURE is set. You do not need to specify it.");
}
foreach my $i (split(//, $manchapters)) {
- if ($tmp =~ /MAN\U$i\E=\s*([^\n]*)\n/) {
+ if ($tmp =~ /^MAN\U$i\E=\s*([^\n]*)\n/) {
print "OK: Makefile MAN\U$i\E=$1\n" if ($verbose);
}
}
foreach my $i (split(//, $manchapters)) {
next if ($i eq '');
- my @mansecs = grep(/MAN\U$i\E=\s*(.*)/, split(/\n/, $tmp));
+ my @mansecs = grep(/^MAN\U$i\E=\s*(.*)/, split(/\n/, $tmp));
if (scalar @mansecs > 1) {
&perror("FATAL", $file, -1, "duplicate MAN$i macro. ".
"Only the last MAN$i macro will be processed. Use ".
"MAN$i+=... instead to append man pages.");
}
- if ($tmp =~ /MAN\U$i\E=\s*([^\n]*)\n/) {
+ if ($tmp =~ /^MAN\U$i\E=\s*([^\n]*)\n/) {
@mman = grep($_ !~ /^\s*$/, split(/\s+/, $1));
@pman = grep($_ !~ /^\s*$/,
split(/\s+/, $plistmanall{$i} // ''));