aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2009-04-10 21:55:37 +0000
committerMark Linimon <linimon@FreeBSD.org>2009-04-10 21:55:37 +0000
commitd129998c8605e75b86b8c8c4cdf6617ee461b037 (patch)
tree7b5040251891174a6d916273d3326e8fb9acec82 /ports-mgmt
parent6f9c095b3ddbe5eae6f7354f3cad502501b3796a (diff)
downloadports-d129998c8605e75b86b8c8c4cdf6617ee461b037.tar.gz
ports-d129998c8605e75b86b8c8c4cdf6617ee461b037.zip
Catch up with master 1.617.
Notes
Notes: svn path=/head/; revision=232038
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk14
1 files changed, 5 insertions, 9 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index 1ba180468e5e..9525c897c6df 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -1469,7 +1469,9 @@ PERL_LEVEL=0
PERL_ARCH?= mach
-.if ${PERL_LEVEL} >= 500800
+.if ${PERL_LEVEL} >= 501000
+PERL_PORT?= perl5.10
+.elif ${PERL_LEVEL} >= 500800
PERL_PORT?= perl5.8
.else
PERL_PORT?= perl5.6
@@ -2605,14 +2607,6 @@ PKG_INFO?= /usr/sbin/pkg_info
PKG_VERSION?= /usr/sbin/pkg_version
.endif
-# Does the pkg_create tool support conflict checking?
-# XXX Slow?
-.if !defined(PKGINSTALLVER)
-PKGINSTALLVER!= ${PKG_INFO} -P 2>/dev/null | ${SED} -e 's/.*: //'
-.endif
-.if ${PKGINSTALLVER} < 20030417
-DISABLE_CONFLICTS= YES
-.endif
.if !defined(PKG_ARGS)
PKG_ARGS= -v -c -${COMMENT:Q} -d ${DESCR} -f ${TMPPLIST} -p ${PREFIX} -P "`cd ${.CURDIR} && ${MAKE} actual-package-depends | ${GREP} -v -E ${PKG_IGNORE_DEPENDS} | ${SORT} -u -t : -k 2`" ${EXTRA_PKG_ARGS} $${_LATE_PKG_ARGS}
.if !defined(NO_MTREE)
@@ -3923,6 +3917,7 @@ do-build:
${ECHO_MSG} "===> Compilation failed unexpectedly."; \
(${ECHO_CMD} ${BUILD_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
fi; \
+ ${FALSE}; \
fi)
.else
@(cd ${BUILD_WRKSRC}; if ! ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET}; then \
@@ -3930,6 +3925,7 @@ do-build:
${ECHO_MSG} "===> Compilation failed unexpectedly."; \
(${ECHO_CMD} ${BUILD_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
fi; \
+ ${FALSE}; \
fi)
.endif
.endif