aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-12-29 23:19:06 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-12-29 23:19:06 +0000
commitfc1ea63b9d2c9a3aefb502404ae11c258f57b92e (patch)
treeaa738970ecdd5867b0fbb40c16a4b29511e5b85f /ports-mgmt
parent541cf0967efcc73552bbc7c0fb22b705131684b1 (diff)
downloadports-fc1ea63b9d2c9a3aefb502404ae11c258f57b92e.tar.gz
ports-fc1ea63b9d2c9a3aefb502404ae11c258f57b92e.zip
Update to 2.14.1.
Remove the check for empty header comments. I think this is too restrictive. There are a number of ports that do this for various reasons.
Notes
Notes: svn path=/head/; revision=309644
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl8
2 files changed, 5 insertions, 5 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 02bbe621b6d4..048f6fa2bd12 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.14.0
+PORTVERSION= 2.14.1
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index f933810f6dde..eaab8d8ab661 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.264 2012/12/27 23:29:04 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.266 2012/12/29 23:23:32 marcus Exp $
#
use strict;
@@ -52,7 +52,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 14;
-my $micro = 0;
+my $micro = 1;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -1336,8 +1336,8 @@ sub checkmakefile {
&perror("FATAL", $file, 2, "header should be ".
"followed by \$$rcsidstr\$.");
} elsif ($lines[3] !~ /^$/) {
- &perror("FATAL", $file, 3, "do not add extra ".
- "empty comments after header.");
+ #&perror("FATAL", $file, 3, "do not add extra ".
+ # "empty comments after header.");
}
} elsif ($lines[1] !~ /^# \$$rcsidstr[:\$]/ or $lines[2] !~ /^$/) {
&perror("FATAL", $file, 1, "incorrect header; ".