aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-27 14:14:05 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-27 14:14:05 +0000
commit7261add75116a7175f3e95cd361654f794d68089 (patch)
treee624c9980f51db861456e6d7e102815e10a4c7cb /ports-mgmt
parent86130d5d5306370a88d98a8352eda6d82dfa0e61 (diff)
downloadports-7261add75116a7175f3e95cd361654f794d68089.tar.gz
ports-7261add75116a7175f3e95cd361654f794d68089.zip
- Update to 1.3
PR: ports/152222 Submitted by: Marin Atanasov Nikolov <dnaeon@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=265279
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg_add_it/Makefile28
-rw-r--r--ports-mgmt/pkg_add_it/distinfo5
-rw-r--r--ports-mgmt/pkg_add_it/pkg-descr26
-rw-r--r--ports-mgmt/pkg_add_it/pkg-message13
4 files changed, 52 insertions, 20 deletions
diff --git a/ports-mgmt/pkg_add_it/Makefile b/ports-mgmt/pkg_add_it/Makefile
index f9b1c3a6a05d..24227217f6f9 100644
--- a/ports-mgmt/pkg_add_it/Makefile
+++ b/ports-mgmt/pkg_add_it/Makefile
@@ -6,18 +6,34 @@
#
PORTNAME= pkg_add_it
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= ports-mgmt
MASTER_SITES= http://www.unix-heaven.org/ports-mgmt/
MAINTAINER= dnaeon@gmail.com
-COMMENT= Interactive interface for the pkg_add(1) command
+COMMENT= Interactive tool for package installation
MAN1= pkg_add_it.1
-PLIST_FILES= sbin/pkg_add_it
+MAN5= pkg_add_it.conf.5
+PLIST_FILES= etc/pkg_add_it.conf sbin/pkg_add_it
+
+.include <bsd.port.pre.mk>
+
+PKG_RELEASE!= ${UNAME} -r | ${CUT} -d '-' -f 1,2 | ${SED} -e 's|\.[0-9]*-STABLE|-STABLE|'
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|@PKG_ARCH@|${ARCH}|' \
+ -e 's|@PKG_RELEASE@|${PKG_RELEASE:L}|' ${WRKSRC}/pkg_add_it.conf
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pkg_add_it ${PREFIX}/sbin/pkg_add_it
- ${INSTALL_MAN} ${WRKSRC}/pkg_add_it.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/pkg_add_it.conf ${PREFIX}/etc/
+ ${INSTALL_PROGRAM} ${WRKSRC}/pkg_add_it ${PREFIX}/sbin/
+ ${INSTALL_MAN} ${WRKSRC}/pkg_add_it.1 ${MAN1PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/pkg_add_it.conf.5 ${MAN5PREFIX}/man/man5/
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ports-mgmt/pkg_add_it/distinfo b/ports-mgmt/pkg_add_it/distinfo
index d5cd50a890bd..b797867375df 100644
--- a/ports-mgmt/pkg_add_it/distinfo
+++ b/ports-mgmt/pkg_add_it/distinfo
@@ -1,3 +1,2 @@
-MD5 (pkg_add_it-1.2.tar.gz) = af83709d750adfe9e6509c6f31f4a16d
-SHA256 (pkg_add_it-1.2.tar.gz) = a760cba3b309d7b9b3b01113882b2747a7c54483ecfd3678b78643e0244938d2
-SIZE (pkg_add_it-1.2.tar.gz) = 9434
+SHA256 (pkg_add_it-1.3.tar.gz) = 8728a32d5c1cc0d5224bcb62f274ae4c95f939fd7bafa1900cc1382d2accc81b
+SIZE (pkg_add_it-1.3.tar.gz) = 24071
diff --git a/ports-mgmt/pkg_add_it/pkg-descr b/ports-mgmt/pkg_add_it/pkg-descr
index cd11ea2f8224..4c72a73d26b4 100644
--- a/ports-mgmt/pkg_add_it/pkg-descr
+++ b/ports-mgmt/pkg_add_it/pkg-descr
@@ -1,18 +1,22 @@
-This program provides an interactive interface for the pkg_add(1) tool.
+pkg_add_it(1) is a tool for interactive installation of packages.
-It's purpose is to search for a package pattern, making easier for the user
-to find a package and install it. This is not a clone of the pkg_add(1) tool.
-It uses pkg_add(1) to install packages while providing an interactive
-interface, so the user could easily choose and install a given package.
+It's goal is to make easier the process of finding and installing
+new packages, and is useful for both - novice users,
+and system administrators as well.
-The pkg_add_it(1) tool supports local and remote pattern search:
+pkg_add_it can be used as well as a "browser" to the INDEX file,
+allowing you to get the information you need about a package.
- * Local pattern search - recursively scanning a directory for
- a given package pattern
- * Remote pattern search - accomplished by scannig the INDEX file
- for every package that matches the pattern
+An example output of package dependencies list created by pkg_add_it(1):
-To learn more about the pkg_add_it(1) tool read the manual page.
+[ NOT INSTALLED ] devel/glib-2.20.5
+[ NOT INSTALLED ] |\___ devel/gettext-0.17_1
+[ NOT INSTALLED ] | \___ converters/libiconv-1.13.1
+[ PRESELECTED ] |\___ converters/libiconv-1.13.1
+[ NOT INSTALLED ] |\___ devel/pcre-7.9
+[ NOT INSTALLED ] |\___ lang/perl-5.8.9_3
+[ INSTALLED ] |\___ devel/pkg-config-0.23_1
+[ NOT INSTALLED ] \___ lang/python26-2.6.2_3
Author: Marin Atanasov Nikolov <dnaeon@gmail.com>
WWW: http://www.unix-heaven.org/index.php?page=pkg_add_it
diff --git a/ports-mgmt/pkg_add_it/pkg-message b/ports-mgmt/pkg_add_it/pkg-message
new file mode 100644
index 000000000000..0318afd160f0
--- /dev/null
+++ b/ports-mgmt/pkg_add_it/pkg-message
@@ -0,0 +1,13 @@
+NOTICE: pkg_add_it(1) has been installed
+
+Please check the pkg_add_it(1) and pkg_add_it.conf(5)
+manual pages for more information about pkg_add_it(1).
+
+Please refer to the above manual pages in order
+to configure how you want pkg_add_it(1) to work.
+
+You might want to change some of the default options
+from the configuration file that were set.
+
+Please check and verify that PKG_RELEASE option is
+set properly right after installation of the program.