aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-23 00:25:30 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-23 00:25:30 +0000
commit2c9e10e2c591ddf564138abb17ebfaef21e3fb2b (patch)
tree5537deb1ae766f97e8008504d736cbfc4fe043c0 /ports-mgmt
parent9487732bd16c184b9b6bb82187790c77b9e464e0 (diff)
downloadports-2c9e10e2c591ddf564138abb17ebfaef21e3fb2b.tar.gz
ports-2c9e10e2c591ddf564138abb17ebfaef21e3fb2b.zip
Update to 2.9.8.
* Use the actual Makefile when checking for pre-defined sites. This allows us to catch things that rely on port variables. [1] * USE_GETOPT_LONG is now obsolete, and should not be suggested. [2] * Check for cases where X_DEPENDS = ${Y_DEPENDS} which can result in adding unwanted dependencies. PR: 121664 [1] Suggested by: pav [2]
Notes
Notes: svn path=/head/; revision=209601
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl35
2 files changed, 19 insertions, 18 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 8fd499017e3c..df8456035cd2 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.9.7
+PORTVERSION= 2.9.8
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index cac04c4f44c1..5ae57a8d8238 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.150 2007/12/15 17:46:44 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.154 2008/03/23 00:24:48 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_C $opt_c $opt_g $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -46,7 +46,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 9;
-my $micro = 7;
+my $micro = 8;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -236,19 +236,12 @@ open(MK, $sites_mk) || die "$sites_mk: $!";
my @site_groups = grep($_ = /^MASTER_SITE_(\w+)/ && $1, <MK>);
close(MK);
-$cmd = join(' -V MASTER_SITE_', "make $makeenv -f - all", @site_groups);
+$cmd = join(' -V MASTER_SITE_', "make $makeenv ", @site_groups);
$i = 0;
open2(\*IN, \*OUT, $cmd);
-print OUT <<EOF;
-all:
- # do nothing
-
-.include "$sites_mk"
-EOF
-
close(OUT);
while (<IN>) {
@@ -1356,6 +1349,16 @@ sub checkmakefile {
}
#
+ # whole file: USE_GETOPT_LONG
+ #
+ print "OK: checking for USE_GETOPT_LONG.\n" if ($verbose);
+ if ($whole =~ /\nUSE_GETOPT_LONG.?=/) {
+ my $lineno = &linenumber($`);
+ &perror("WARN", $file, $lineno, "USE_GETOPT_LONG is now obsolete. ".
+ "You can safely remove this macro from your Makefile.");
+ }
+
+ #
# whole file: EXPIRATION_DATE
#
print "OK: checking for valid EXPIRATION_DATE.\n" if ($verbose);
@@ -2333,6 +2336,11 @@ FETCH_DEPENDS DEPENDS_TARGET
print "OK: checking dependency value for $j.\n"
if ($verbose);
+ if ($k =~ /\${((PATCH_|EXTRACT_|LIB_|BUILD_|RUN_|FETCH_)*DEPENDS)}/) {
+ &perror("WARN", $file, -1, "do not set $j to $k. ".
+ "Instead, explicity list out required $j dependencies.");
+ }
+
if (($j ne 'DEPENDS'
&& scalar(@l) != 2 && scalar(@l) != 3)) {
&perror("WARN", $file, -1, "wrong dependency value ".
@@ -2384,13 +2392,6 @@ FETCH_DEPENDS DEPENDS_TARGET
"USE_QT.");
}
- # check USE_GETOPT_LONG
- if ($m{'dep'} =~ /^(gnugetopt\.\d)+$/) {
- &perror("WARN", $file, -1, "dependency to $1 ".
- "listed in $j. consider using ".
- "USE_GETOPT_LONG.");
- }
-
# check LIBLTDL
if ($m{'dep'} =~ /^(ltdl\.\d)+$/) {
&perror("WARN", $file, -1, "dependency to $1 ".