aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2016-05-15 18:43:43 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2016-05-15 18:43:43 +0000
commitf34d0177612f94ed7ff283c46808222a35fc6c52 (patch)
tree31ef92d208a33611b1355e3c792777bd671ab02e /ports-mgmt
parent2ec321c6fb03a00ce2ae6b3685c21f15c40ba3c0 (diff)
downloadports-f34d0177612f94ed7ff283c46808222a35fc6c52.tar.gz
ports-f34d0177612f94ed7ff283c46808222a35fc6c52.zip
Update to 2.17.2.
* Properly check for TIMESTAMP in distinfo
Notes
Notes: svn path=/head/; revision=415278
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile3
-rw-r--r--ports-mgmt/portlint/src/portlint.pl15
2 files changed, 10 insertions, 8 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index b2c4ae98c718..2bdad5407928 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.17.1
-PORTREVISION= 1
+PORTVERSION= 2.17.2
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index bf42557989e3..67ed295aeb11 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.386 2016/05/15 18:21:04 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.388 2016/05/15 18:42:34 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 17;
-my $micro = 1;
+my $micro = 2;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -391,14 +391,17 @@ sub checkdistinfo {
while (<IN>) {
if (/^\s*$/) {
&perror("FATAL", $file, $., "found blank line.");
+ next;
}
- m/(\S+)\s+\((\S+)\)\s+=\s+(\S+)/;
-
- if ($1 ne "" && $2 ne "" && $3 ne "") {
+ if (/^TIMESTAMP\s+=\s+\d+$/) {
+ # TIMESTAMP is a valid distinfo option
+ next;
+ }
+ if (/(\S+)\s+\((\S+)\)\s+=\s+(\S+)/) {
my ($tag, $path, $value) = ($1, $2, $3);
$records{$path}{$tag} = $value;
- if (!$algorithms{$tag} && $tag ne "SIZE" && $tag ne "TIMESTAMP") {
+ if (!$algorithms{$tag} && $tag ne "SIZE") {
&perror("FATAL", $file, $., "unsupported checksum algorithm ".
"found: $tag.");
}