aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-06-09 21:21:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-06-09 21:21:03 +0000
commitf8a8451d63c3d0d9bfdef1b123975da54279a593 (patch)
tree7f8da63b352453ccd946ad8d56e01bc7a06e50b5 /ports-mgmt
parenta834131ac86ee335d8a9450e96cc67eb515f029d (diff)
downloadports-f8a8451d63c3d0d9bfdef1b123975da54279a593.tar.gz
ports-f8a8451d63c3d0d9bfdef1b123975da54279a593.zip
Release 1.8.5
Changes: - Fix mirror_type: http with https servers - Fix regression in the solver that tries to reinstall reverse deps sometime
Notes
Notes: svn path=/head/; revision=416634
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg/Makefile3
-rw-r--r--ports-mgmt/pkg/distinfo6
-rw-r--r--ports-mgmt/pkg/files/patch-https-mirrors19
3 files changed, 4 insertions, 24 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 15e8ad91ac36..8f27ba5a181f 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.8.4
-PORTREVISION= 1
+DISTVERSION= 1.8.5
_PKG_VERSION= ${DISTVERSION}
CATEGORIES= ports-mgmt
MASTER_SITES= \
diff --git a/ports-mgmt/pkg/distinfo b/ports-mgmt/pkg/distinfo
index 51a384853ead..e0cb70185e1e 100644
--- a/ports-mgmt/pkg/distinfo
+++ b/ports-mgmt/pkg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1465117435
-SHA256 (pkg-1.8.4.tar.xz) = e5b9defd18f477958df540e9760b32bdf28ae20ab819893f93da77cc14c795a3
-SIZE (pkg-1.8.4.tar.xz) = 1912652
+TIMESTAMP = 1465507093
+SHA256 (pkg-1.8.5.tar.xz) = 594debd677e11e3bf85cad73bbf0f88e3a757f485aee3497405bc444ac1da935
+SIZE (pkg-1.8.5.tar.xz) = 1944516
diff --git a/ports-mgmt/pkg/files/patch-https-mirrors b/ports-mgmt/pkg/files/patch-https-mirrors
deleted file mode 100644
index bf3f01c9f1af..000000000000
--- a/ports-mgmt/pkg/files/patch-https-mirrors
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git libpkg/fetch.c libpkg/fetch.c
-index 4804ad0..16ab9c7 100644
---- libpkg/fetch.c
-+++ libpkg/fetch.c
-@@ -549,8 +549,12 @@ pkg_fetch_file_to_fd(struct pkg_repo *repo, const char *url, int dest,
- srv_current = repo->srv;
- } else if (repo != NULL && repo->mirror_type == HTTP &&
- strncmp(u->scheme, "http", 4) == 0) {
-- if (u->port == 0)
-- u->port = 80;
-+ if (u->port == 0) {
-+ if (strcmp(u->scheme, "https") == 0)
-+ u->port = 443;
-+ else
-+ u->port = 80;
-+ }
- snprintf(zone, sizeof(zone),
- "%s://%s:%d", u->scheme, u->host, u->port);
- if (repo->http == NULL)