aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-07 14:01:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-07 14:01:57 +0000
commit0a64548c940fe79a1e3cd23b2c13ef79900495ec (patch)
tree8e6011a61df496d7481b383472fefa8afddbc576 /ports-mgmt
parent4769525ea7809590045e204bbf6973133413f8fb (diff)
downloadports-0a64548c940fe79a1e3cd23b2c13ef79900495ec.tar.gz
ports-0a64548c940fe79a1e3cd23b2c13ef79900495ec.zip
- Update to 2.0.1
PR: 125265 Submitted by: Andy Kosela <andy.kosela@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=216461
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/bpkg/Makefile2
-rw-r--r--ports-mgmt/bpkg/files/bpkg.812
-rw-r--r--ports-mgmt/bpkg/files/bpkg.sh.in11
3 files changed, 15 insertions, 10 deletions
diff --git a/ports-mgmt/bpkg/Makefile b/ports-mgmt/bpkg/Makefile
index 55fa74639932..ba5c1a578d89 100644
--- a/ports-mgmt/bpkg/Makefile
+++ b/ports-mgmt/bpkg/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= bpkg
-PORTVERSION= 2.0
+PORTVERSION= 2.0.1
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/bpkg/files/bpkg.8 b/ports-mgmt/bpkg/files/bpkg.8
index 21fe65026cc9..a45de5201e10 100644
--- a/ports-mgmt/bpkg/files/bpkg.8
+++ b/ports-mgmt/bpkg/files/bpkg.8
@@ -23,7 +23,7 @@
.\" SUCH DAMAGE.
.\"
.\"
-.Dd June 19, 2008
+.Dd July 4, 2008
.Dt BPKG 8
.Os
.Sh NAME
@@ -45,7 +45,7 @@ installed ports and the whole ports tree.
The following command line arguments are supported:
.Bl -tag -width F1
.It Fl b
-create backup package file in /usr/obj/ from a locally installed port.
+create backup package in /var/tmp/ from a locally installed port.
.It Fl c
clean all distfiles in /usr/ports/distfiles/* [no arguments]
.It Fl C
@@ -95,11 +95,11 @@ show the total size occupied by files installed within the port.
.It Fl S
search the ports tree and display info about the port.
.It Fl t
-list all installed ports and dates of their installation. [no arguments]
+list all installed ports with dates of their installation. [no arguments]
.It Fl w
which installed port owns the specified file.
.It Fl v
-list all installed ports and possible upgrades. [no arguments]
+list all installed ports and possible updates. [no arguments]
.It Fl z
display dynamic object dependencies for the specified port.
.It Fl Z
@@ -124,6 +124,10 @@ Display all ports matching the regular expression.
.Dl Ar "> bpkg -t | head"
.Pp
Display 10 most recently installed ports.
+.Pp
+.Dl Ar "> bpkg -b 'foo bar'"
+.Pp
+Create backup packages of foo and bar in /var/tmp/ directory.
.Sh SEE ALSO
.Xr pkg_add 1 ,
.Xr pkg_create 1 ,
diff --git a/ports-mgmt/bpkg/files/bpkg.sh.in b/ports-mgmt/bpkg/files/bpkg.sh.in
index 48d64277cb06..3e02ebbac8da 100644
--- a/ports-mgmt/bpkg/files/bpkg.sh.in
+++ b/ports-mgmt/bpkg/files/bpkg.sh.in
@@ -365,15 +365,16 @@ pkg_backup() {
fi
pkg_install=`pkg_info -xoQ $pkg | cut -d: -f1 | awk '{ORS=" " ; print}'`
- echo "Creating backup package(s) "$pkg_install"in /usr/obj/"
- e=`pkg_info -xoQ $pkg | cut -d: -f1`
- cd /usr/obj/ && pkg_create -xb $e 1>/dev/null 2>&1
+ echo "Creating backup package(s) "$pkg_install"in /var/tmp/"
+ for e in $pkg; do
+ i=`pkg_info -xoQ $e | cut -d: -f1'`
+ cd /var/tmp/ && pkg_create -xb $i 1>/dev/null 2>&1
+ done
echo "Done."
exit 0
}
-pkg_time() {
- echo "Packages (date of installation):"
+pkg_time() {
/bin/ls -lUTt /var/db/pkg/ | awk -F' ' '{ print $6,$7,$8,$9,$10 }' | cut -d/ -f1,5
echo "***`pkg_info | wc -l` ports installed ***"
exit 0