aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2008-07-30 09:46:17 +0000
committerMark Linimon <linimon@FreeBSD.org>2008-07-30 09:46:17 +0000
commit98526b66e6ec99469b2e1e95fbdb8524c86defa5 (patch)
treeca41e088d8f7e2fcd6bfcbd00b8a022bd942aca1 /ports-mgmt
parent39881d3bfe04a4d54f29e29caa540ff7e10b09eb (diff)
downloadports-98526b66e6ec99469b2e1e95fbdb8524c86defa5.tar.gz
ports-98526b66e6ec99469b2e1e95fbdb8524c86defa5.zip
Catch up with master 1.600. This also obsoletes a portmk-only patch
that has been around for a while.
Notes
Notes: svn path=/head/; revision=217842
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk12
1 files changed, 7 insertions, 5 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index 0a6a0c310efc..9b6b4be2d5b2 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -1693,6 +1693,10 @@ PLIST_REINPLACE_DIRRMTRY=s!^@dirrmtry \(.*\)!@unexec rmdir %D/\1 2>/dev/null ||
PLIST_REINPLACE_RMTRY=s!^@rmtry \(.*\)!@unexec rm -f %D/\1 2>/dev/null || true!
PLIST_REINPLACE_STOPDAEMON=s!^@stopdaemon \(.*\)!@unexec %D/etc/rc.d/\1${RC_SUBR_SUFFIX} forcestop 2>/dev/null || true!
+# kludge to strip trailing whitespace from CFLAGS;
+# sub-configure will not # survive double space
+CFLAGS:= ${CFLAGS:C/ $//}
+
.if defined(WITHOUT_CPU_CFLAGS)
.if defined(_CPUCFLAGS)
.if !empty(_CPUCFLAGS)
@@ -1790,9 +1794,6 @@ EXTRACT_DEPENDS+= unmakeself:${PORTSDIR}/archivers/unmakeself
.if defined(USE_GMAKE)
BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake
CONFIGURE_ENV+= MAKE=${GMAKE}
-# note: the next line is from 86106 which says: "It needs more investigation.
-# We will keep it in ports-mgmt/portmk for further tests."
-MAKE_ENV+= CC="${CC}" CXX="${CXX}"
.endif
.if defined(USE_GCC) || defined(USE_FORTRAN)
@@ -2299,8 +2300,9 @@ MAKE_FLAGS?= -f
MAKEFILE?= Makefile
MAKE_ENV+= PREFIX=${PREFIX} \
LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
- MOTIFLIB="${MOTIFLIB}" LIBDIR="${LIBDIR}" CFLAGS="${CFLAGS}" \
- CXXFLAGS="${CXXFLAGS}" MANPREFIX="${MANPREFIX}"
+ MOTIFLIB="${MOTIFLIB}" LIBDIR="${LIBDIR}" \
+ CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
+ MANPREFIX="${MANPREFIX}"
# Add -fno-strict-aliasing to CFLAGS with optimization level -O2 or higher.
# gcc 4.x enable strict aliasing optimization with -O2 which is known to break