aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-07-05 06:02:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-07-05 06:02:28 +0000
commite965ccfa5271200d497be0383f911483635df136 (patch)
treecaeb4c984034dd66a0d374715c3c518b6d327416 /ports-mgmt
parent6b73686ec3e567c7570f3c6e3be029c667f5c94c (diff)
downloadports-e965ccfa5271200d497be0383f911483635df136.tar.gz
ports-e965ccfa5271200d497be0383f911483635df136.zip
Update to 2.9.9.
Check for misuse of the %%XXXDIR%% constructs in order to help with the QA Tinderbox build reports. PR: 125037 Submitted by: leeym
Notes
Notes: svn path=/head/; revision=216360
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl10
2 files changed, 9 insertions, 3 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index df8456035cd2..60f514bb3ecf 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.9.8
+PORTVERSION= 2.9.9
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 5ae57a8d8238..d76e45e4e75b 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.154 2008/03/23 00:24:48 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.155 2008/07/05 06:01:38 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_C $opt_c $opt_g $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -46,7 +46,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 9;
-my $micro = 8;
+my $micro = 9;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -858,6 +858,12 @@ sub checkplist {
}
}
+ if ($_ =~ m{^%%PORT(\w+)%%(.*?)%%(\w+)DIR%%(.*)$} and $1 ne $3) {
+ &perror("WARN", $file, $., "Do not mix %%PORT$1%% with %%$3DIR%%. ".
+ "Use '%%PORT$3%%$2%%$3DIR%%$4' instead and update Makefile ".
+ "accordingly.");
+ }
+
if ($_ =~ m#man/([^/]+/)?man([$manchapters])/([^\.]+\.[$manchapters])(\.gz)?$#) {
if ($4 eq '') {
$plistman{$2} .= ' ' . $3;