aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2010-06-16 03:53:15 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2010-06-16 03:53:15 +0000
commit84ce50b415043501df9311b7b38c0adf9959a77b (patch)
tree951cca52dafde0b2f8ad45cde4b18bd8d171fd43 /ports-mgmt
parent32c5be79dc4012e3689d2a49b4fa64cac4fc591d (diff)
downloadports-84ce50b415043501df9311b7b38c0adf9959a77b.tar.gz
ports-84ce50b415043501df9311b7b38c0adf9959a77b.zip
Update to 2.13.1.
* USE_APACHE=yes is now fatal * Clean up WITH_APACHEX=X variants. WITH_APACHE=yes is now the only allowed one PR: 146988 Submitted by: pgollucci
Notes
Notes: svn path=/head/; revision=256583
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl15
2 files changed, 8 insertions, 9 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 03e3db8f66a6..b64c95b3d1a5 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.13.0
+PORTVERSION= 2.13.1
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 0fdcbe449ab7..fa880bf2c3ae 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.196 2010/04/04 18:11:09 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.197 2010/05/30 17:12:48 marcus Exp $
#
use strict;
@@ -52,7 +52,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 13;
-my $micro = 0;
+my $micro = 1;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -2028,18 +2028,17 @@ ruby sed sh sort sysctl touch tr which xargs xmkmf
# whole file: check for USE_APACHE=yes
#
if ($whole =~ /^USE_APACHE[?:]?=\s*(yes)$/m) {
- &perror("WARN", $file, -1, "Use USE_APACHE=VERSION ".
+ &perror("FATAL", $file, -1, "Use USE_APACHE=VERSION ".
"(where version can be found in \${PORTSDIR}/Mk/bsd.apache.mk) ".
"instead of yes");
}
#
- # whole file: check for WITH_APACHE2
+ # whole file: check for WITH_APACHE\d+
#
- if ($whole =~ /^WITH_APACHE2[?:]?=/m) {
- &perror("WARN", $file, -1, "Use WITH_APACHE=VERSION (where VERSION ".
- "can be found in \${PORTSDIR}/Mk/bsd.apache.mk) instead to pull ".
- "in APACHE_PORT");
+ if ($whole =~ /WITH_APACHE\d+/) {
+ &perror("FATAL", $file, -1, "Use WITH_APACHE=yes and .if ".
+ "\${APACHE_VERSION} [==|<|>] 13|20|22|24");
}
#