aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-11-08 10:51:07 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-11-08 10:51:07 +0000
commit8bcd8f8426c8831eff2efdc4127ceabc48c8dca4 (patch)
treeba22fc64ab76514f2ebae6ee862caf695057480b /ports-mgmt
parent9f1da127e614b5e73777ae6ad866215307b36e53 (diff)
downloadports-8bcd8f8426c8831eff2efdc4127ceabc48c8dca4.tar.gz
ports-8bcd8f8426c8831eff2efdc4127ceabc48c8dca4.zip
Apply a hot-fix against a bug where portupgrade(1)/pkgdb(1) leave
temporary files ($TMPDIR/+CONTENTS*). Bump PORTREVISION for that. Modify the IGNORE message that is shown when pkg_create(1) is found to be too old.
Notes
Notes: svn path=/head/; revision=69723
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile6
-rw-r--r--ports-mgmt/portupgrade/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 500008d293b7..aececc5e6132 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20021106
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}
@@ -62,9 +63,12 @@ INSTALL_TARGET+= install-doc
# XXX: PKG_CMD is not defined yet..
PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
.if empty(PKG_CREATE_OK)
-IGNORE= pkg_create does not support -b. Please update pkg_* tools or stick with portupgrade-20020920 + pkg_tarup-1.2_3, which work just fine
+IGNORE= pkg_create does not support -b. Please update /usr/sbin/pkg_* to those of the latest RELENG_4
.endif
+post-patch:
+ ${RUBY} -i -pe "gsub(/('\/bin\/)cp(', '-f', tmpfile, file)/, '\1mv\2')" ${WRKSRC}/lib/pkgtools.rb
+
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 500008d293b7..aececc5e6132 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20021106
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}
@@ -62,9 +63,12 @@ INSTALL_TARGET+= install-doc
# XXX: PKG_CMD is not defined yet..
PKG_CREATE_OK!= /usr/sbin/pkg_create 2>&1 | ${GREP} ' -b ' || ${TRUE}
.if empty(PKG_CREATE_OK)
-IGNORE= pkg_create does not support -b. Please update pkg_* tools or stick with portupgrade-20020920 + pkg_tarup-1.2_3, which work just fine
+IGNORE= pkg_create does not support -b. Please update /usr/sbin/pkg_* to those of the latest RELENG_4
.endif
+post-patch:
+ ${RUBY} -i -pe "gsub(/('\/bin\/)cp(', '-f', tmpfile, file)/, '\1mv\2')" ${WRKSRC}/lib/pkgtools.rb
+
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \