aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2010-06-02 07:18:07 +0000
committerAlberto Villa <avilla@FreeBSD.org>2010-06-02 07:18:07 +0000
commitcf32a115f97c87ecd946e2818bef2465326f79ce (patch)
treee3962afc08a3975b5283467365128e5d666977bd /ports-mgmt
parentada0f6214995a549319926144f245bb2a645aef7 (diff)
downloadports-cf32a115f97c87ecd946e2818bef2465326f79ce.tar.gz
ports-cf32a115f97c87ecd946e2818bef2465326f79ce.zip
KPackageKit is the KDE interface for PackageKit. It features
everything Gnome PackageKit does except: - install catalog; - service pack; - a D-Bus session interface. These items are not mandatory since they are more features of the GUI itself than a feature in PackageKit. WWW: http://kde-apps.org/content/show.php/KPackageKit?content=84745 Approved by: tabthorpe, miwi (mentors)
Notes
Notes: svn path=/head/; revision=255504
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/kpackagekit/Makefile39
-rw-r--r--ports-mgmt/kpackagekit/distinfo3
-rw-r--r--ports-mgmt/kpackagekit/pkg-descr9
-rw-r--r--ports-mgmt/kpackagekit/pkg-plist92
5 files changed, 144 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index 4ea6c98253f4..1eeb150ad39e 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -11,6 +11,7 @@
SUBDIR += gnome-packagekit
SUBDIR += hs-porte
SUBDIR += jailaudit
+ SUBDIR += kpackagekit
SUBDIR += kports
SUBDIR += kports-qt4
SUBDIR += lsknobs
diff --git a/ports-mgmt/kpackagekit/Makefile b/ports-mgmt/kpackagekit/Makefile
new file mode 100644
index 000000000000..fef718ee74a1
--- /dev/null
+++ b/ports-mgmt/kpackagekit/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: kpackagekit
+# Date created: 11 May 2010
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= KPackageKit
+PORTVERSION= 0.6.0
+CATEGORIES= ports-mgmt sysutils kde
+MASTER_SITES= http://kde-apps.org/CONTENT/content-files/
+DISTNAME= 84745-${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .7z
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE interface for PackageKit
+
+EXTRACT_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
+LIB_DEPENDS= packagekit-qt.14:${PORTSDIR}/ports-mgmt/packagekit-qt4
+
+EXTRACT_CMD= 7z x
+EXTRACT_BEFORE_ARGS= # none
+EXTRACT_AFTER_ARGS= > /dev/null
+USE_GETTEXT= yes
+USE_GNOME= pkgconfig
+USE_KDE4= automoc4 kdehier kdelibs kdeprefix
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
+USE_CMAKE= yes
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+pre-install:
+ ${REINPLACE_CMD} -e 's/$${_install_dir}/$${DBUS_SERVICES_INSTALL_DIR}/' \
+ ${WRKSRC}/cmake/modules/PkgConfigGetVar.cmake
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/kpackagekit/distinfo b/ports-mgmt/kpackagekit/distinfo
new file mode 100644
index 000000000000..88b9a877a17f
--- /dev/null
+++ b/ports-mgmt/kpackagekit/distinfo
@@ -0,0 +1,3 @@
+MD5 (84745-KPackageKit-0.6.0.7z) = 77678e6171f1551a934e439262a73e71
+SHA256 (84745-KPackageKit-0.6.0.7z) = eb6d9193d8c79d39dd10778a2169859b376f508fb20b8adf463c657aae2efd67
+SIZE (84745-KPackageKit-0.6.0.7z) = 647261
diff --git a/ports-mgmt/kpackagekit/pkg-descr b/ports-mgmt/kpackagekit/pkg-descr
new file mode 100644
index 000000000000..6cc31e2b619d
--- /dev/null
+++ b/ports-mgmt/kpackagekit/pkg-descr
@@ -0,0 +1,9 @@
+KPackageKit is the KDE interface for PackageKit. It features
+everything Gnome PackageKit does except:
+- install catalog;
+- service pack;
+- a D-Bus session interface.
+These items are not mandatory since they are more features of the GUI
+itself than a feature in PackageKit.
+
+WWW: http://kde-apps.org/content/show.php/KPackageKit?content=84745
diff --git a/ports-mgmt/kpackagekit/pkg-plist b/ports-mgmt/kpackagekit/pkg-plist
new file mode 100644
index 000000000000..01db8b6fe550
--- /dev/null
+++ b/ports-mgmt/kpackagekit/pkg-plist
@@ -0,0 +1,92 @@
+bin/kpackagekit
+lib/kde4/kcm_kpk_addrm.so
+lib/kde4/kcm_kpk_settings.so
+lib/kde4/kcm_kpk_update.so
+lib/kde4/kded_kpackagekitd.so
+lib/kde4/libexec/kpackagekitsmarticon
+lib/libkpackagekitlib.so
+share/applications/kde4/kpackagekit.desktop
+share/apps/KPackageKitSmartIcon/KPackageKitSmartIcon.notifyrc
+share/apps/kpackagekit/icons/hicolor/22x22/actions/package-wait.png
+share/apps/kpackagekit/icons/hicolor/24x24/actions/pk-cleaning-up.mng
+share/apps/kpackagekit/icons/hicolor/24x24/actions/pk-installing.mng
+share/apps/kpackagekit/icons/hicolor/24x24/actions/pk-refresh-cache.mng
+share/apps/kpackagekit/icons/hicolor/24x24/actions/pk-searching.mng
+share/apps/kpackagekit/icons/hicolor/24x24/actions/pk-testing.mng
+share/apps/kpackagekit/icons/hicolor/24x24/actions/pk-waiting.mng
+share/apps/kpackagekit/icons/hicolor/48x48/actions/distro-upgrade.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/kpk-clean-up.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/kpk-important.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/kpk-package-add.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/kpk-refresh-cache.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/package-download.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/package-info.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/package-orign.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/package-rollback.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/package-search.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/package-setup.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/package-update.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/package-wait.png
+share/apps/kpackagekit/icons/hicolor/48x48/actions/pk-cleaning-up.mng
+share/apps/kpackagekit/icons/hicolor/48x48/actions/pk-downloading.mng
+share/apps/kpackagekit/icons/hicolor/48x48/actions/pk-installing.mng
+share/apps/kpackagekit/icons/hicolor/48x48/actions/pk-refresh-cache.mng
+share/apps/kpackagekit/icons/hicolor/48x48/actions/pk-searching.mng
+share/apps/kpackagekit/icons/hicolor/48x48/actions/pk-testing.mng
+share/apps/kpackagekit/icons/hicolor/48x48/actions/pk-waiting.mng
+share/apps/kpackagekit/icons/hicolor/48x48/categories/kpk-desktop-gnome.png
+share/apps/kpackagekit/icons/hicolor/48x48/categories/kpk-desktop-xfce.png
+share/apps/kpackagekit/icons/hicolor/64x64/actions/package-installed.png
+share/apps/kpackagekit/icons/hicolor/64x64/actions/package-removed.png
+share/apps/kpackagekit/icons/hicolor/64x64/actions/package.png
+share/dbus-1/services/org.freedesktop.PackageKit.service
+share/dbus-1/services/org.kde.KPackageKitSmartIcon.service
+share/kde4/services/kded/kpackagekitd.desktop
+share/kde4/services/kpk_addrm.desktop
+share/kde4/services/kpk_settings.desktop
+share/kde4/services/kpk_update.desktop
+share/kde4/services/settings-add-and-remove-software.desktop
+share/locale/bg/LC_MESSAGES/kpackagekit.mo
+share/locale/ca/LC_MESSAGES/kpackagekit.mo
+share/locale/ca@valencia/LC_MESSAGES/kpackagekit.mo
+share/locale/cs/LC_MESSAGES/kpackagekit.mo
+share/locale/da/LC_MESSAGES/kpackagekit.mo
+share/locale/de/LC_MESSAGES/kpackagekit.mo
+share/locale/el/LC_MESSAGES/kpackagekit.mo
+share/locale/en_GB/LC_MESSAGES/kpackagekit.mo
+share/locale/eo/LC_MESSAGES/kpackagekit.mo
+share/locale/es/LC_MESSAGES/kpackagekit.mo
+share/locale/et/LC_MESSAGES/kpackagekit.mo
+share/locale/fr/LC_MESSAGES/kpackagekit.mo
+share/locale/ga/LC_MESSAGES/kpackagekit.mo
+share/locale/gl/LC_MESSAGES/kpackagekit.mo
+share/locale/lt/LC_MESSAGES/kpackagekit.mo
+share/locale/nb/LC_MESSAGES/kpackagekit.mo
+share/locale/nds/LC_MESSAGES/kpackagekit.mo
+share/locale/nl/LC_MESSAGES/kpackagekit.mo
+share/locale/nn/LC_MESSAGES/kpackagekit.mo
+share/locale/pa/LC_MESSAGES/kpackagekit.mo
+share/locale/pl/LC_MESSAGES/kpackagekit.mo
+share/locale/pt/LC_MESSAGES/kpackagekit.mo
+share/locale/pt_BR/LC_MESSAGES/kpackagekit.mo
+share/locale/ro/LC_MESSAGES/kpackagekit.mo
+share/locale/ru/LC_MESSAGES/kpackagekit.mo
+share/locale/sk/LC_MESSAGES/kpackagekit.mo
+share/locale/sv/LC_MESSAGES/kpackagekit.mo
+share/locale/tr/LC_MESSAGES/kpackagekit.mo
+share/locale/uk/LC_MESSAGES/kpackagekit.mo
+share/locale/zh_CN/LC_MESSAGES/kpackagekit.mo
+share/locale/zh_TW/LC_MESSAGES/kpackagekit.mo
+@dirrm share/apps/kpackagekit/icons/hicolor/64x64/actions
+@dirrm share/apps/kpackagekit/icons/hicolor/64x64
+@dirrm share/apps/kpackagekit/icons/hicolor/48x48/categories
+@dirrm share/apps/kpackagekit/icons/hicolor/48x48/actions
+@dirrm share/apps/kpackagekit/icons/hicolor/48x48
+@dirrm share/apps/kpackagekit/icons/hicolor/24x24/actions
+@dirrm share/apps/kpackagekit/icons/hicolor/24x24
+@dirrm share/apps/kpackagekit/icons/hicolor/22x22/actions
+@dirrm share/apps/kpackagekit/icons/hicolor/22x22
+@dirrm share/apps/kpackagekit/icons/hicolor
+@dirrm share/apps/kpackagekit/icons
+@dirrm share/apps/kpackagekit
+@dirrm share/apps/KPackageKitSmartIcon