aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-07-26 19:28:42 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-07-26 19:28:42 +0000
commit2ee75b5cf1b7ba214ee1fd46017f74dbdc0bbcca (patch)
tree9124a00d8d7218c2aebb2f5fc45dbe4c19700549 /ports-mgmt
parent7145af16635db2964d5ee2dda0e9babc1102a4bc (diff)
downloadports-2ee75b5cf1b7ba214ee1fd46017f74dbdc0bbcca.tar.gz
ports-2ee75b5cf1b7ba214ee1fd46017f74dbdc0bbcca.zip
Update to 20010727 with a couple of new commands added. (No changes
have been made to the existing utilities) pkg_deinstall: This is a package deinstaller with wildcards and dependency recursion support. pkg_glob: This is a package glob expander with wildcards and dependency recursion support.
Notes
Notes: svn path=/head/; revision=45516
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile6
-rw-r--r--ports-mgmt/portupgrade-devel/distinfo2
-rw-r--r--ports-mgmt/portupgrade-devel/pkg-descr20
-rw-r--r--ports-mgmt/portupgrade-devel/pkg-plist6
-rw-r--r--ports-mgmt/portupgrade/Makefile6
-rw-r--r--ports-mgmt/portupgrade/distinfo2
-rw-r--r--ports-mgmt/portupgrade/pkg-descr20
-rw-r--r--ports-mgmt/portupgrade/pkg-plist6
8 files changed, 40 insertions, 28 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 4d17452b32de..b958d4edd444 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portupgrade
-PORTVERSION= 20010714
+PORTVERSION= 20010727
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.iDaemons.org/distfiles/
@@ -23,7 +23,9 @@ USE_RUBY= yes
NO_BUILD= yes
-MAN1= pkgdepfix.1 \
+MAN1= pkg_deinstall.1 \
+ pkg_glob.1 \
+ pkgdepfix.1 \
portsdb.1 \
portupgrade.1 \
portversion.1
diff --git a/ports-mgmt/portupgrade-devel/distinfo b/ports-mgmt/portupgrade-devel/distinfo
index 82763b154e47..a02ec02a56e3 100644
--- a/ports-mgmt/portupgrade-devel/distinfo
+++ b/ports-mgmt/portupgrade-devel/distinfo
@@ -1 +1 @@
-MD5 (pkgtools-20010714.tar.gz) = 1dbed0adb0c700d776e3b00e8f6bed94
+MD5 (pkgtools-20010727.tar.gz) = 378d4abfd6a01dd85b8373fa5a072f16
diff --git a/ports-mgmt/portupgrade-devel/pkg-descr b/ports-mgmt/portupgrade-devel/pkg-descr
index 843cafcd902f..bc3cddc48786 100644
--- a/ports-mgmt/portupgrade-devel/pkg-descr
+++ b/ports-mgmt/portupgrade-devel/pkg-descr
@@ -1,21 +1,21 @@
Portupgrade is a tool to upgrade installed packages via ports or
-packages. Also, it allows you to install new ports/packages in a
-handy way.
-
-It upgrades installed packages without reinstalling depending or
-dependent packages by directly updating the package registry database
-located under /var/db/pkg. Moreover, it can trace dependency chains
-up and down and upgrade packages recursively.
+packages. It upgrades installed packages without reinstalling
+depending or dependent packages by directly updating the package
+registry database located under /var/db/pkg. It can also trace
+dependency chains up and down and upgrade packages recursively.
This package also includes the following utilities:
-portinstall: This is an equivalent to `portupgrade -N', which means
- it by default tries to install a new one when a
- specified package is not installed.
+portinstall: This helps you install new ports in a handy way.
+ Equivalent to `portupgrade -N'.
portversion: This is a replacement of pkg_version(8), which runs
faster than pkg_version and is cooperative with
portupgrade.
portsdb: This is a tool to create, update or look up ports
database, which is made from the ports index file.
+pkg_deinstall: This is a package deinstaller with wildcards and
+ dependency recursion support.
+pkg_glob: This is a package glob expander with wildcards and
+ dependency recursion support.
pkgdepfix: This is an interactive tool to fix /var/db/pkg's
@pkgdep vs. +REQUIRED_BY discrepancies, and stale or
missing origins, optionally.
diff --git a/ports-mgmt/portupgrade-devel/pkg-plist b/ports-mgmt/portupgrade-devel/pkg-plist
index 01837c4f208a..f82a42b2c161 100644
--- a/ports-mgmt/portupgrade-devel/pkg-plist
+++ b/ports-mgmt/portupgrade-devel/pkg-plist
@@ -1,3 +1,5 @@
+sbin/pkg_deinstall
+sbin/pkg_glob
sbin/pkgdepfix
sbin/portsdb
sbin/portinstall
@@ -12,9 +14,11 @@ sbin/portversion
%%RUBY_SITELIBDIR%%/ports.rb
%%RUBY_SITELIBDIR%%/portsdb.rb
%%RUBY_SITELIBDIR%%/tsort.rb
+share/zsh/site-functions/_pkg_deinstall
+share/zsh/site-functions/_pkg_glob
+share/zsh/site-functions/_pkgdepfix
share/zsh/site-functions/_portupgrade
share/zsh/site-functions/_portversion
-share/zsh/site-functions/_pkgdepfix
@unexec rmdir %D/share/zsh/site-functions 2>/dev/null || true
@unexec rmdir %D/share/zsh 2>/dev/null || true
%%PORTDOCS%%share/doc/portupgrade/README
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 4d17452b32de..b958d4edd444 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portupgrade
-PORTVERSION= 20010714
+PORTVERSION= 20010727
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.iDaemons.org/distfiles/
@@ -23,7 +23,9 @@ USE_RUBY= yes
NO_BUILD= yes
-MAN1= pkgdepfix.1 \
+MAN1= pkg_deinstall.1 \
+ pkg_glob.1 \
+ pkgdepfix.1 \
portsdb.1 \
portupgrade.1 \
portversion.1
diff --git a/ports-mgmt/portupgrade/distinfo b/ports-mgmt/portupgrade/distinfo
index 82763b154e47..a02ec02a56e3 100644
--- a/ports-mgmt/portupgrade/distinfo
+++ b/ports-mgmt/portupgrade/distinfo
@@ -1 +1 @@
-MD5 (pkgtools-20010714.tar.gz) = 1dbed0adb0c700d776e3b00e8f6bed94
+MD5 (pkgtools-20010727.tar.gz) = 378d4abfd6a01dd85b8373fa5a072f16
diff --git a/ports-mgmt/portupgrade/pkg-descr b/ports-mgmt/portupgrade/pkg-descr
index 843cafcd902f..bc3cddc48786 100644
--- a/ports-mgmt/portupgrade/pkg-descr
+++ b/ports-mgmt/portupgrade/pkg-descr
@@ -1,21 +1,21 @@
Portupgrade is a tool to upgrade installed packages via ports or
-packages. Also, it allows you to install new ports/packages in a
-handy way.
-
-It upgrades installed packages without reinstalling depending or
-dependent packages by directly updating the package registry database
-located under /var/db/pkg. Moreover, it can trace dependency chains
-up and down and upgrade packages recursively.
+packages. It upgrades installed packages without reinstalling
+depending or dependent packages by directly updating the package
+registry database located under /var/db/pkg. It can also trace
+dependency chains up and down and upgrade packages recursively.
This package also includes the following utilities:
-portinstall: This is an equivalent to `portupgrade -N', which means
- it by default tries to install a new one when a
- specified package is not installed.
+portinstall: This helps you install new ports in a handy way.
+ Equivalent to `portupgrade -N'.
portversion: This is a replacement of pkg_version(8), which runs
faster than pkg_version and is cooperative with
portupgrade.
portsdb: This is a tool to create, update or look up ports
database, which is made from the ports index file.
+pkg_deinstall: This is a package deinstaller with wildcards and
+ dependency recursion support.
+pkg_glob: This is a package glob expander with wildcards and
+ dependency recursion support.
pkgdepfix: This is an interactive tool to fix /var/db/pkg's
@pkgdep vs. +REQUIRED_BY discrepancies, and stale or
missing origins, optionally.
diff --git a/ports-mgmt/portupgrade/pkg-plist b/ports-mgmt/portupgrade/pkg-plist
index 01837c4f208a..f82a42b2c161 100644
--- a/ports-mgmt/portupgrade/pkg-plist
+++ b/ports-mgmt/portupgrade/pkg-plist
@@ -1,3 +1,5 @@
+sbin/pkg_deinstall
+sbin/pkg_glob
sbin/pkgdepfix
sbin/portsdb
sbin/portinstall
@@ -12,9 +14,11 @@ sbin/portversion
%%RUBY_SITELIBDIR%%/ports.rb
%%RUBY_SITELIBDIR%%/portsdb.rb
%%RUBY_SITELIBDIR%%/tsort.rb
+share/zsh/site-functions/_pkg_deinstall
+share/zsh/site-functions/_pkg_glob
+share/zsh/site-functions/_pkgdepfix
share/zsh/site-functions/_portupgrade
share/zsh/site-functions/_portversion
-share/zsh/site-functions/_pkgdepfix
@unexec rmdir %D/share/zsh/site-functions 2>/dev/null || true
@unexec rmdir %D/share/zsh 2>/dev/null || true
%%PORTDOCS%%share/doc/portupgrade/README