aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /ports-mgmt
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/gnome-packagekit/Makefile4
-rw-r--r--ports-mgmt/kpackagekit/Makefile2
-rw-r--r--ports-mgmt/packagekit/Makefile6
-rw-r--r--ports-mgmt/portdowngrade/Makefile4
4 files changed, 7 insertions, 9 deletions
diff --git a/ports-mgmt/gnome-packagekit/Makefile b/ports-mgmt/gnome-packagekit/Makefile
index c50afa0ccbde..8fe98ebb7cf1 100644
--- a/ports-mgmt/gnome-packagekit/Makefile
+++ b/ports-mgmt/gnome-packagekit/Makefile
@@ -33,8 +33,8 @@ GCONF_SCHEMAS= gnome-packagekit.schemas
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gpk-application.1 gpk-backend-status.1 gpk-install-local-file.1 \
gpk-install-mime-type.1 gpk-install-package-name.1 \
diff --git a/ports-mgmt/kpackagekit/Makefile b/ports-mgmt/kpackagekit/Makefile
index 3502723cfe51..5c6bd661e234 100644
--- a/ports-mgmt/kpackagekit/Makefile
+++ b/ports-mgmt/kpackagekit/Makefile
@@ -26,7 +26,7 @@ USE_QT_VER= 4
QT_COMPONENTS= moc_build qmake_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME:L}-${PORTVERSION}
diff --git a/ports-mgmt/packagekit/Makefile b/ports-mgmt/packagekit/Makefile
index 54a8d60c6528..c0d07923c21f 100644
--- a/ports-mgmt/packagekit/Makefile
+++ b/ports-mgmt/packagekit/Makefile
@@ -32,10 +32,8 @@ USE_ICONV= yes
USE_LDCONFIG= yes
USE_PYTHON_BUILD= 2.5+
GNU_CONFIGURE= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -lexecinfo
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
CONFIGURE_ARGS+=--with-security-framework=polkit \
--localstatedir=/var \
--disable-gtk-doc \
diff --git a/ports-mgmt/portdowngrade/Makefile b/ports-mgmt/portdowngrade/Makefile
index 59fda3bc7b8c..bda285aab145 100644
--- a/ports-mgmt/portdowngrade/Makefile
+++ b/ports-mgmt/portdowngrade/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
POPT_INCLUDE= `pkg_info -xL ^popt | ${GREP} popt.h | ${SED} -e 's?/popt.h??'`
POPT_LIB= `pkg_info -xL ^popt | ${GREP} libpopt.a | ${SED} -e 's?/libpopt.a??'`
-CONFIGURE_ENV= CPPFLAGS="-I${POPT_INCLUDE}" \
- LIBS="-lpopt -L${POPT_LIB}"
+CONFIGURE_ENV= LIBS="-lpopt -L${POPT_LIB}"
+CPPFLAGS+= -I${POPT_INCLUDE}
.if defined(DEFAULT_CVS_SERVER)
CONFIGURE_ARGS+= --enable-default-server=${DEFAULT_CVS_SERVER}
.endif