aboutsummaryrefslogtreecommitdiff
path: root/print/cups-samba/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-27 13:37:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-27 13:37:49 +0000
commit71d7cb8789dd4ceebecce56f44a9c98bb3af1e8e (patch)
tree31e53e467ef1a13746ea5bef7242e647ed2cb728 /print/cups-samba/Makefile
parenta7a77595854cd4a5f56f1a41d316b1f4770ee210 (diff)
downloadports-71d7cb8789dd4ceebecce56f44a9c98bb3af1e8e.tar.gz
ports-71d7cb8789dd4ceebecce56f44a9c98bb3af1e8e.zip
Add cups-samba, a client-side drivers for CUPS/Samba FreeBSD server
with Windows clients. PR: ports/62680 Submitted by: John Merryweather Cooper <coop9211@uidaho.edu>
Notes
Notes: svn path=/head/; revision=112361
Diffstat (limited to 'print/cups-samba/Makefile')
-rw-r--r--print/cups-samba/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/print/cups-samba/Makefile b/print/cups-samba/Makefile
new file mode 100644
index 000000000000..305e7d471a6a
--- /dev/null
+++ b/print/cups-samba/Makefile
@@ -0,0 +1,48 @@
+# ex:ts=8 -*-mode: makefile-*-
+#
+# New ports collection makefile for: cups-samba
+# Date created: 2004-02-10
+# Whom: John Merryweather Cooper <coop9211@uidaho.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cups-samba
+PORTVERSION= 5.0.r3
+CATEGORIES= print net
+MASTER_SITES= ftp://ftp.easysw.com/pub/cups/windows/ \
+ ftp://ftp2.easysw.com/pub/cups/windows/ \
+ ftp://ftp3.easysw.com/pub/cups/windows/
+DISTNAME= ${PORTNAME}-5.0rc3
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= The Common UNIX Printing System: MS Windows client drivers
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ tardy:${PORTSDIR}/archivers/tardy \
+ ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base \
+ smbspool:${PORTSDIR}/net/samba
+RUN_DEPENDS= smbspool:${PORTSDIR}/net/samba \
+ ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base \
+ ${LOCALBASE}/sbin/cupsaddsmb:${PORTSDIR}/print/cups-lpr \
+ espgs:${PORTSDIR}/print/cups-pstoraster
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+SH= ${LOCALBASE}/bin/bash
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%TARDY%%|${LOCALBASE}/bin/tardy|g' \
+ ${WRKSRC}/cups-samba.install \
+ ${WRKSRC}/cups-samba.remove
+
+do-install:
+ cd ${WRKSRC} && ${SH} ${WRKSRC}/cups-samba.install now
+
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} 's|%%PREFIX%%|${PREFIX}|g'
+
+.include <bsd.port.mk>