aboutsummaryrefslogtreecommitdiff
path: root/print/gl2ps
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-31 13:40:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-31 13:40:44 +0000
commit202e6783c12e15876d432fbe8beb1efb8448c8ee (patch)
tree13f61dc34921222d14bd95ec77eae6e9bd59c864 /print/gl2ps
parentfc64c4179a16201c1a88909590675915f5013939 (diff)
downloadports-202e6783c12e15876d432fbe8beb1efb8448c8ee.tar.gz
ports-202e6783c12e15876d432fbe8beb1efb8448c8ee.zip
Add gl2ps 1.1.2,
GL2PS is a C library providing high quality vector output for any OpenGL application. The main difference between GL2PS and other similar libraries is the use of sorting algorithms capable of handling intersecting and stretched polygons, as well as non manifold objects. GL2PS provides advanced smooth shading and text rendering, culling of invisible primitives, mixed vector/bitmap output, and much more... GL2PS can currently create PostScript (PS), Encapsulated PostScript (EPS) and Portable Document Format (PDF) files, as well as LATEX files for the text fragments. PR: ports/62150 Submitted by: Igor Pokrovsky <tiamat@comset.net>
Notes
Notes: svn path=/head/; revision=99605
Diffstat (limited to 'print/gl2ps')
-rw-r--r--print/gl2ps/Makefile41
-rw-r--r--print/gl2ps/distinfo1
-rw-r--r--print/gl2ps/files/Makefile.ex16
-rw-r--r--print/gl2ps/files/Makefile.lib13
-rw-r--r--print/gl2ps/pkg-descr15
-rw-r--r--print/gl2ps/pkg-plist8
6 files changed, 94 insertions, 0 deletions
diff --git a/print/gl2ps/Makefile b/print/gl2ps/Makefile
new file mode 100644
index 000000000000..05eeca06b93c
--- /dev/null
+++ b/print/gl2ps/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gl2ps
+# Date created: 31 Jan 2004
+# Whom: Igor Pokrovsky <tiamat@comset.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gl2ps
+PORTVERSION= 1.1.2
+CATEGORIES= print graphics
+MASTER_SITES= http://www.geuz.org/gl2ps/src/
+
+MAINTAINER= tiamat@comset.net
+COMMENT= A C library providing vector output for OpenGL application
+
+USE_GL= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+
+pre-build:
+ @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/libgl2ps.so ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libgl2ps.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/gl2ps.h ${PREFIX}/include
+
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/gl2psTest.c ${EXAMPLESDIR}
+ @${PERL} -pi -e 's|%%CC%%|${CC}|g; \
+ s|%%RM%%|${RM}|g; \
+ s|%%CFLAGS%%|${CFLAGS}|g; \
+ s|%%X11BASE%%|${X11BASE}|g' \
+ <${FILESDIR}/Makefile.ex >${EXAMPLESDIR}/Makefile
+
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/gl2ps.ps ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/gl2ps/distinfo b/print/gl2ps/distinfo
new file mode 100644
index 000000000000..47b543d8ed15
--- /dev/null
+++ b/print/gl2ps/distinfo
@@ -0,0 +1 @@
+MD5 (gl2ps-1.1.2.tar.gz) = bf7dbfc8ec1cebe60a2c2c3074010c2b
diff --git a/print/gl2ps/files/Makefile.ex b/print/gl2ps/files/Makefile.ex
new file mode 100644
index 000000000000..8e1cf9bf20dd
--- /dev/null
+++ b/print/gl2ps/files/Makefile.ex
@@ -0,0 +1,16 @@
+# You'll need graphics/libglut in order to build example program
+
+CC=%%CC%%
+RM=%%RM%%
+
+CFLAGS= %%CFLAGS%% -DHAVE_ZLIB -O3 -I%%X11BASE%%/include
+LDFLAGS= -lgl2ps -lGL -lGLU -lglut -L%%X11BASE%%/lib -lX11 -lXi -lXmu -lm -lz
+
+gl2psTest: gl2psTest.o
+ ${CC} ${LDFLAGS} $> -o $@
+
+.c.o:
+ ${CC} -c ${CFLAGS} $*.c
+
+clean:
+ ${RM} -f gl2psTest gl2psTest.o
diff --git a/print/gl2ps/files/Makefile.lib b/print/gl2ps/files/Makefile.lib
new file mode 100644
index 000000000000..6d6b2830422e
--- /dev/null
+++ b/print/gl2ps/files/Makefile.lib
@@ -0,0 +1,13 @@
+CFLAGS+= -DHAVE_ZLIB -O3 -fPIC -I${X11BASE}/include
+LDFLAGS= -shared -E -lGL -L${X11BASE}/lib -lX11 -lXi -lXmu -lm -lz
+
+all: libgl2ps.so libgl2ps.a
+
+libgl2ps.a: gl2ps.o
+ ${AR} qc $@ $>
+
+libgl2ps.so: gl2ps.o
+ ${LD} ${LDFLAGS} $> -o $@
+
+.c.o:
+ ${CC} -c ${CFLAGS} $*.c
diff --git a/print/gl2ps/pkg-descr b/print/gl2ps/pkg-descr
new file mode 100644
index 000000000000..0e9c5c37dd0f
--- /dev/null
+++ b/print/gl2ps/pkg-descr
@@ -0,0 +1,15 @@
+GL2PS is a C library providing high quality vector output for any OpenGL
+application. The main difference between GL2PS and other similar libraries
+is the use of sorting algorithms capable of handling intersecting and
+stretched polygons, as well as non manifold objects. GL2PS provides advanced
+smooth shading and text rendering, culling of invisible primitives, mixed
+vector/bitmap output, and much more...
+
+GL2PS can currently create PostScript (PS), Encapsulated PostScript (EPS)
+and Portable Document Format (PDF) files, as well as LATEX files for the
+text fragments.
+
+WWW: http://www.geuz.org/gl2ps/
+
+- Igor Pokrovsky
+tiamat@comset.net
diff --git a/print/gl2ps/pkg-plist b/print/gl2ps/pkg-plist
new file mode 100644
index 000000000000..bd14a9da6dfb
--- /dev/null
+++ b/print/gl2ps/pkg-plist
@@ -0,0 +1,8 @@
+include/gl2ps.h
+lib/libgl2ps.a
+lib/libgl2ps.so
+%%EXAMPLESDIR%%/gl2psTest.c
+%%EXAMPLESDIR%%/Makefile
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/gl2ps.ps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%