aboutsummaryrefslogtreecommitdiff
path: root/print/gutenprint-base
diff options
context:
space:
mode:
authorDaniel Harris <dannyboy@FreeBSD.org>2002-10-16 01:34:01 +0000
committerDaniel Harris <dannyboy@FreeBSD.org>2002-10-16 01:34:01 +0000
commit7aacf7a37eb682bf2d63ff618f3e26b799bd7ba6 (patch)
tree248e9eadfdefa0b3e3606c2b46460b3219aba2a6 /print/gutenprint-base
parent531dce7b0fa6c4b5c6061ea7cb36a434bc9b7d84 (diff)
downloadports-7aacf7a37eb682bf2d63ff618f3e26b799bd7ba6.tar.gz
ports-7aacf7a37eb682bf2d63ff618f3e26b799bd7ba6.zip
Actually add patchfile for rastertoprinter.c this time.
While I'm here, fix BUILD_DEPENDS to look for an executable, it is not LIB_DEPENDS. Submitted in part by: Jeremy Prior <jez@netcraft.com>
Notes
Notes: svn path=/head/; revision=68130
Diffstat (limited to 'print/gutenprint-base')
-rw-r--r--print/gutenprint-base/Makefile2
-rw-r--r--print/gutenprint-base/files/patch-rastertoprinter10
2 files changed, 11 insertions, 1 deletions
diff --git a/print/gutenprint-base/Makefile b/print/gutenprint-base/Makefile
index c8f750dcde1c..d9e15be905c9 100644
--- a/print/gutenprint-base/Makefile
+++ b/print/gutenprint-base/Makefile
@@ -30,7 +30,7 @@ MAN8= cups-calibrate.8
PLIST_SUB+= CUPS="@comment "
.else
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
-BUILD_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+BUILD_DEPENDS+= cups-config:${PORTSDIR}/print/cups-base
CONFIGURE_ARGS+= --with-cups=${PREFIX}
PLIST_SUB+= CUPS=""
.endif
diff --git a/print/gutenprint-base/files/patch-rastertoprinter b/print/gutenprint-base/files/patch-rastertoprinter
new file mode 100644
index 000000000000..d30be1b52c00
--- /dev/null
+++ b/print/gutenprint-base/files/patch-rastertoprinter
@@ -0,0 +1,10 @@
+--- src/cups/rastertoprinter.c- Tue Oct 15 12:32:23 2002
++++ src/cups/rastertoprinter.c Tue Oct 15 12:32:40 2002
+@@ -57,6 +57,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <fcntl.h>
++#include <limits.h>
+ #ifdef INCLUDE_GIMP_PRINT_H
+ #include INCLUDE_GIMP_PRINT_H
+ #else