aboutsummaryrefslogtreecommitdiff
path: root/print/hplip3/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-01-25 14:26:46 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-01-25 14:26:46 +0000
commit9a885c614bacb1567aba6144e29667d045d6dcf6 (patch)
tree9f67ab795532193068b438fe7237500346e3c4c8 /print/hplip3/Makefile
parent47801ba9da28eaa4eceb8e4cd978a8a94f73ac93 (diff)
downloadports-9a885c614bacb1567aba6144e29667d045d6dcf6.tar.gz
ports-9a885c614bacb1567aba6144e29667d045d6dcf6.zip
- Added files/ patch-api_model.c, patch-prnt_hpijs_configure
- Fixed OPTIONS usage (ports/108103) and PREFIX problem - Removed files/ patch-backend_hp_hp.c, patch-scan_sane_hpaio.c, patch-scan_sane.c - Updated to 1.6.12 PR: ports/108278 Submitted by: Anish Minstry <aminstry at am-productions.biz> (maintainer) Approved by: alexbl (mentor, implicit)
Notes
Notes: svn path=/head/; revision=183258
Diffstat (limited to 'print/hplip3/Makefile')
-rw-r--r--print/hplip3/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/print/hplip3/Makefile b/print/hplip3/Makefile
index 523ff9f3f575..01d2684b0d11 100644
--- a/print/hplip3/Makefile
+++ b/print/hplip3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hplip
-PORTVERSION= 1.6.7
+PORTVERSION= 1.6.12
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= hplip
@@ -40,7 +40,7 @@ PKGDEINSTALL= ${PKGINSTALL}
OPTIONS= GUI "build with Python QT" on
-PLIST_SUB+= PORTVERSION=${PORTVERSION} IJSVER=2.6.7
+PLIST_SUB+= PORTVERSION=${PORTVERSION} IJSVER=2.6.12
.include <bsd.port.pre.mk>
@@ -48,12 +48,9 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} IJSVER=2.6.7
USE_AUTOTOOLS= automake:19:env autoconf:259:env aclocal:19:env
.endif
-.if exists(${LOCALBASE}/bin/pylupdate)
-WITH_GUI= yes
-.endif
-
-.if defined(WITH_GUI)
+.if !defined(WITHOUT_GUI) || exists(${LOCALBASE}/bin/pylupdate)
RUN_DEPENDS+= pylupdate:${PORTSDIR}/x11-toolkits/py-qt
+CONFIGURE_ARGS+= --enable-gui-build
.endif
post-extract:
@@ -61,6 +58,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/share/cups|${LOCALBASE}/share/cups|g ; \
+ s|/usr/lib/cups/backend|${LOCALBASE}/libexec/cups/backend|g ; \
s|/usr/lib/cups/filter|${LOCALBASE}/libexec/cups/filter|g' \
${WRKSRC}/configure ${WRKSRC}/prnt/hpijs/configure
@${REINPLACE_CMD} -e 's|/usr/share|${LOCALBASE}/share|g ; \
@@ -70,13 +68,16 @@ post-patch:
s|/etc/hp|${LOCALBASE}/etc/hp|g' \
${WRKSRC}/Makefile.in \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/bin|${LOCALBASE}/bin|g ; \
+ s|/usr/lib|${LOCALBASE}/lib|g' \
+ ${WRKSRC}/prnt/hpijs/foomatic-rip
@${REINPLACE_CMD} -e 's|/etc/hp/|${LOCALBASE}/etc/hp/|g ; \
s|/usr/lib/cups/filter|${LOCALBASE}/libexec/cups/filter|g' \
${WRKSRC}/base/g.py \
${WRKSRC}/fax/backend/hpfax.py \
${WRKSRC}/hpssd.py \
${WRKSRC}/io/hpiod/hpiod.h \
- ${WRKSRC}/prnt/hpijs/hplip_api.h \
+ ${WRKSRC}/api/hplip_api.h \
${WRKSRC}/prnt/hpijs/configure.in
@${REINPLACE_CMD} -e 's|#!/usr/bin/env python|#!${LOCALBASE}/bin/python|g' \
${WRKSRC}/*.py \