aboutsummaryrefslogtreecommitdiff
path: root/print/html2ps-a4
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1998-05-17 20:14:41 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1998-05-17 20:14:41 +0000
commit2cf6c2c3c7dd45abbae9c8984b296e5af47071f3 (patch)
treec0e41414fa7e47d266a47b775f40792d490ab032 /print/html2ps-a4
parent773b6e4e583ee0c022bc1fbc8b7c7c87c7fd0bca (diff)
downloadports-2cf6c2c3c7dd45abbae9c8984b296e5af47071f3.tar.gz
ports-2cf6c2c3c7dd45abbae9c8984b296e5af47071f3.zip
Import of html2ps 0.1 a HTML to PostScript converter with lot's of features.
Notes
Notes: svn path=/head/; revision=11024
Diffstat (limited to 'print/html2ps-a4')
-rw-r--r--print/html2ps-a4/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/print/html2ps-a4/Makefile b/print/html2ps-a4/Makefile
new file mode 100644
index 000000000000..6d178920337b
--- /dev/null
+++ b/print/html2ps-a4/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: html2ps
+# Version required: 1.0b1
+# Date created: Sat Nov 22 12:54:50 CET 1997
+# Whom: andreas
+#
+# $Id: Makefile,v 1.8 1997/11/17 16:18:35 rse Exp $
+#
+
+DISTNAME= html2ps-1.0b1
+PKGNAME= html2ps-1.0
+CATEGORIES= lang www perl5
+MASTER_SITES= http://www.tdb.uu.se/~jan/
+
+MAINTAINER= andreas@FreeBSD.ORG
+
+BUILD_DEPENDS= mogrify:${PORTSDIR}/graphics/ImageMagick \
+ djpeg:${PORTSDIR}/graphics/jpeg \
+ giftopnm:${PORTSDIR}/graphics/netpbm \
+ ${site_perl}/Image/Magick.pm:${PORTSDIR}/graphics/p5-PerlMagick \
+ gs:${PORTSDIR}/print/ghostscript5 \
+ tex:${PORTSDIR}/print/teTeX \
+ ${site_perl}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ weblint:${PORTSDIR}/www/weblint
+
+site_perl= ${PREFIX}/lib/perl5/site_perl
+USE_PERL5= YES
+NO_BUILD= YES
+IS_INTERACTIVE= YES
+
+MAN1= html2ps.1
+MAN5= html2psrc.5
+
+do-install:
+ @cd ${WRKSRC}; ${PREFIX}/bin/perl5 install
+
+.include <bsd.port.mk>