aboutsummaryrefslogtreecommitdiff
path: root/print/lyx-devel/Makefile
diff options
context:
space:
mode:
authorDaniel Harris <dannyboy@FreeBSD.org>2003-02-18 19:22:06 +0000
committerDaniel Harris <dannyboy@FreeBSD.org>2003-02-18 19:22:06 +0000
commit3eeb47cbcf2de3d76289d322996d8f1e40d5713e (patch)
tree3d4a97466bc9b6c12a49e59d0ad7fdd7c8c5b416 /print/lyx-devel/Makefile
parentec037f46564ed6d289aa1a256d910c30a3ef7dbd (diff)
downloadports-3eeb47cbcf2de3d76289d322996d8f1e40d5713e.tar.gz
ports-3eeb47cbcf2de3d76289d322996d8f1e40d5713e.zip
Upgrade to 1.3.0.
PR: 48112 Submitted by: Ports Fury Approved by: maintainer
Notes
Notes: svn path=/head/; revision=75814
Diffstat (limited to 'print/lyx-devel/Makefile')
-rw-r--r--print/lyx-devel/Makefile44
1 files changed, 28 insertions, 16 deletions
diff --git a/print/lyx-devel/Makefile b/print/lyx-devel/Makefile
index 60a0ded4973a..f4b4e3a4e1ec 100644
--- a/print/lyx-devel/Makefile
+++ b/print/lyx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lyx
-PORTVERSION= 1.2.3
+PORTVERSION= 1.3.0
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://ftp.sdsc.edu/pub/other/lyx/stable/ \
@@ -16,16 +16,13 @@ MAINTAINER= flynn@energyhq.homeip.net
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
latex:${PORTSDIR}/print/teTeX
-LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
- forms.1:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
latex:${PORTSDIR}/print/teTeX
-USE_XPM= yes
-USE_REINPLACE= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_AUTOMAKE_VER= 15
+GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
--with-extra-inc="${LOCALBASE}/include"
@@ -33,6 +30,14 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 reLyX.1
+.if defined(WITH_QT)
+USE_QT_VER= 3
+CONFIGURE_ARGS+= --with-frontend=qt
+.else
+LIB_DEPENDS+= forms.1:${PORTSDIR}/x11-toolkits/xforms
+USE_XPM= yes
+.endif
+
.if defined(WITH_ASPELL)
LIB_DEPENDS+= aspell.15:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
@@ -44,7 +49,23 @@ CONFIGURE_ARGS+= --with-pspell \
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+USE_GCC= 3.1
+.if defined(WITH_QT)
+BROKEN= Does not build
+.endif
+.endif
+
pre-everything::
+.if ( ${OSVERSION} >= 500035 ) && !defined(WITH_QT)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to build with the Qt3 frontend,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_QT=yes\""
+ @${ECHO_MSG}
+.endif
+
.if !defined(WITH_ASPELL)
@${ECHO_MSG}
@${ECHO_MSG} "If you want to compile with Aspell/Pspell support,"
@@ -59,13 +80,4 @@ pre-everything::
@${ECHO_MSG}
.endif
-post-patch:
-.for file in src/Makefile.am src/frontends/Makefile.am
- @${REINPLACE_CMD} -e 's|LIBS +=|LDFLAGS = @LDFLAGS@|g' ${WRKSRC}/${file}
-.endfor
-.for file in configure.in lib/reLyX/configure.in
- @${REINPLACE_CMD} -e 's|AC_CHECK_LIB(c,|AC_CHECK_FUNC(|g ; \
- s|^INSTALL_SCRIPT=|#INSTALL_SCRIPT=|g' ${WRKSRC}/${file}
-.endfor
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>