aboutsummaryrefslogtreecommitdiff
path: root/print/pdfcube/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-20 15:23:04 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-20 15:23:04 +0000
commit8a23e1166f8206bc7da200b085b6c811adcfa56c (patch)
tree118cf05f7264f52f0fdbf32dd99289f14fecc1d2 /print/pdfcube/Makefile
parentc83c9d3a2f0314e4bbf1febe4a6c4723b70637e1 (diff)
downloadports-8a23e1166f8206bc7da200b085b6c811adcfa56c.tar.gz
ports-8a23e1166f8206bc7da200b085b6c811adcfa56c.zip
Add pdfcube 0.0.2, an OpenGL presentation viewer on a spinning cube.
Approved by: clsung (mentor)
Notes
Notes: svn path=/head/; revision=190447
Diffstat (limited to 'print/pdfcube/Makefile')
-rw-r--r--print/pdfcube/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/print/pdfcube/Makefile b/print/pdfcube/Makefile
new file mode 100644
index 000000000000..6163c59f3be4
--- /dev/null
+++ b/print/pdfcube/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: pdfcube
+# Date created: Apr. 20, 2007
+# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdfcube
+PORTVERSION= 0.0.2
+CATEGORIES= print
+MASTER_SITES= # http://code.100allora.it/pdfcube/attachment/wiki/WikiStart/${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= An OpenGL presentation viewer on a spinning cube
+
+LIB_DEPENDS= glut:${PORTSDIR}/graphics/libglut \
+ gtkglext:${PORTSDIR}/x11-toolkits/gtkglext \
+ poppler-glib:${PORTSDIR}/graphics/poppler-gtk
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/pdfcube
+
+.include <bsd.port.pre.mk>
+
+do-fetch:
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+ ${FETCH_CMD} -o "${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}" "http://code.100allora.it/pdfcube/attachment/wiki/WikiStart/${DISTNAME}${EXTRACT_SUFX}?format=raw"
+.endif
+
+.include <bsd.port.post.mk>