aboutsummaryrefslogtreecommitdiff
path: root/print/perlftlib
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-17 13:52:12 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-17 13:52:12 +0000
commitdfb35d8f89dc40f80a1b1cc869d2f986756e9a85 (patch)
treeb77e78ab421fa452d860c4aa515cf0da3247670e /print/perlftlib
parent1388438a59662cfe96da891e84a727044edf58fd (diff)
downloadports-dfb35d8f89dc40f80a1b1cc869d2f986756e9a85.tar.gz
ports-dfb35d8f89dc40f80a1b1cc869d2f986756e9a85.zip
Fix installation on PREFIX != /usr/local
Reported by: krismail
Notes
Notes: svn path=/head/; revision=145658
Diffstat (limited to 'print/perlftlib')
-rw-r--r--print/perlftlib/Makefile10
-rw-r--r--print/perlftlib/files/patch-FreeType_Makefile.PL17
2 files changed, 17 insertions, 10 deletions
diff --git a/print/perlftlib/Makefile b/print/perlftlib/Makefile
index 1c301b8119cb..120d9147da93 100644
--- a/print/perlftlib/Makefile
+++ b/print/perlftlib/Makefile
@@ -27,12 +27,16 @@ MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAKE_ENV= PERL_VER=${PERL_VER} PERL5=${PERL5}
-pre-patch:
- @${PERL} -pi -e 's!/usr/local/X11R6.3!${PREFIX}!' ${WRKSRC}/FreeType/Makefile.PL
+post-patch:
+.for VAR in LOCALBASE PREFIX
+ @${PERL} -pi -e 's!%%${VAR}%%!${${VAR}}!g' \
+ ${WRKSRC}/FreeType/Makefile.PL
+.endfor
post-build:
.for DIST in ftinfo mkttfdir
- @${PERL} -pi -e 's;^#! */usr/local/bin/perl *;#!${PERL5};' ${WRKSRC}/${DIST}
+ @${PERL} -pi -e 's;^#! */usr/local/bin/perl *;#!${PERL5};' \
+ ${WRKSRC}/${DIST}
.endfor
.include <bsd.port.mk>
diff --git a/print/perlftlib/files/patch-FreeType_Makefile.PL b/print/perlftlib/files/patch-FreeType_Makefile.PL
index 9ff7ad62040c..7ac7131e6017 100644
--- a/print/perlftlib/files/patch-FreeType_Makefile.PL
+++ b/print/perlftlib/files/patch-FreeType_Makefile.PL
@@ -1,10 +1,13 @@
---- FreeType/Makefile.PL.orig Wed Jan 10 14:50:46 2001
-+++ FreeType/Makefile.PL Wed Jan 10 14:51:19 2001
-@@ -6,5 +6,5 @@
+--- FreeType/Makefile.PL.orig Mon Dec 14 02:13:26 1998
++++ FreeType/Makefile.PL Mon Oct 17 11:47:15 2005
+@@ -4,7 +4,8 @@
+ WriteMakefile(
+ 'NAME' => 'FreeType',
'VERSION_FROM' => 'FreeType.pm', # finds $VERSION
- 'LIBS' => ['-L/usr/local/lib -lttf'], # e.g., '-lm'
+- 'LIBS' => ['-L/usr/local/X11R6.3/lib -lttf'], # e.g., '-lm'
++ 'LIBS' => ['-L%%LOCALBASE%%/lib -lttf'], # e.g., '-lm'
++ 'PREFIX' => '%%PREFIX%%',
'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
-- 'INC' => '-I/usr/local/include', # e.g., '-I/usr/include/other'
-+ 'INC' => '-I/usr/local/include/freetype1/freetype', # e.g., '-I/usr/include/other'
+- 'INC' => '-I/usr/local/X11R6.3/include', # e.g., '-I/usr/include/other'
++ 'INC' => '-I%%LOCALBASE%%/include/freetype1/freetype', # e.g., '-I/usr/include/other'
);
-