aboutsummaryrefslogtreecommitdiff
path: root/print/pips800/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2001-01-09 01:49:29 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2001-01-09 01:49:29 +0000
commit5099a7222b67024fdac482eabdf42867df78a24d (patch)
tree12f7f72b09bd292ac4e0e449562e4037f93fdef4 /print/pips800/Makefile
parent1c7756ae4e87337eb131806b819e1223d96081fd (diff)
downloadports-5099a7222b67024fdac482eabdf42867df78a24d.tar.gz
ports-5099a7222b67024fdac482eabdf42867df78a24d.zip
pips800 is a master port for pips-sc680_777, pips780 and pips880 which are
going to be imported by me. Then for these new ports I must modify pips800.
Notes
Notes: svn path=/head/; revision=36972
Diffstat (limited to 'print/pips800/Makefile')
-rw-r--r--print/pips800/Makefile27
1 files changed, 23 insertions, 4 deletions
diff --git a/print/pips800/Makefile b/print/pips800/Makefile
index e7439b4e1c57..ef7afed70354 100644
--- a/print/pips800/Makefile
+++ b/print/pips800/Makefile
@@ -21,16 +21,26 @@ RUN_DEPENDS+= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base \
ONLY_FOR_ARCHS= i386
NO_WRKSUBDIR= yes
-PLIST_SUB= BASE_NAME=${BASE_NAME} PRTYPE=${PRTYPE} LIB_DIR_FILE=usr/lib/${LIB_FILE} LIB_README=${LIB_NAME}
+PLIST_SUB= BASE_NAME=${BASE_NAME} PRTYPE=${PRTYPE} LIB_DIR_FILE=usr/lib/${LIB_FILE} LIB_README=${LIB_README}
MD5_FILE= ${.CURDIR}/distinfo
.if (${PORTVERSION} == 1.2)
LIB_FILE= libPrt${PRTYPE}.so
-LIB_NAME= "@comment Readme of the Lib for only 1.3 or later"
+LIB_README= "@comment Readme of the Lib for only 1.3 or later"
FILTER= ${FILESDIR}/filter.rev_1.2
.else
RUN_DEPENDS+= /compat/linux/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png
+.if defined(INTERNATIONAL_PRODUCTS)
+LIB_FILE= lib${PRTYPE:S/^-//}.so
+LIB_README= share/doc/${BASE_NAME}/lib${PRTYPE:S/^-//}.readme
+PLIST= ${PKGDIR}/pkg-plist.ip
+RUN_DEPENDS+= /compat/linux/usr/share/locale/ja_JP/LC_COLLATE:${PORTSDIR}/japanese/linux_locale \
+ /compat/linux/usr/share/locale/ko/LC_COLLATE:${PORTSDIR}/korean/linux_locale
+#PKGINSTALL= ${PKGDIR}/pkg-install.ip
+#PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.ip
+.else
LIB_FILE= libpm${PRTYPE}c.so
-LIB_NAME= share/doc/${BASE_NAME}/libpm${PRTYPE}c.readme
+LIB_README= share/doc/${BASE_NAME}/libpm${PRTYPE}c.readme
+.endif
FILTER= ${FILESDIR}/filter.rev
.endif
BASE_NAME= pips${PRTYPE}
@@ -68,9 +78,18 @@ do-install:
${MKDIR} ${PREFIX}/share/doc/${BASE_NAME}
${INSTALL_DATA} ${WRKSRC}/readme${PRTYPE} ${PREFIX}/share/doc/${BASE_NAME}
.if (${PORTVERSION} != 1.2)
- ${INSTALL_DATA} ${WRKSRC}/libpm${PRTYPE}c.readme ${PREFIX}/share/doc/${BASE_NAME}
+ ${INSTALL_DATA} ${WRKSRC}/${LIB_README:T} ${PREFIX}/${LIB_README}
.endif
.endif
+.if defined(INTERNATIONAL_PRODUCTS)
+ ${MKDIR} ${PREFIX}/share/doc/${BASE_NAME}/pips_mo
+ ${INSTALL_DATA} ${WRKSRC}/pips_mo/* ${PREFIX}/share/doc/${BASE_NAME}/pips_mo
+# zh zh_TW are not supported. en.gmo is not necessary.
+.for lc in de es fr it ko nl pt
+ ${INSTALL_DATA} ${WRKSRC}/pips_mo/${lc}.gmo /compat/linux/usr/share/locale/${lc}/LC_MESSAGES/pips.mo
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/pips_mo/ja.gmo /compat/linux/usr/share/locale/ja_JP/LC_MESSAGES/pips.mo
+.endif
# a target for the maintainer
_MAKE_COMMENT_DESCR: