aboutsummaryrefslogtreecommitdiff
path: root/print/pslib
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-05 14:18:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-05 14:18:26 +0000
commit4be8cb03ee3a425da5bdc4ec37ec2d6d6e3a9aba (patch)
tree5a2143d50de1b52c238358ac7626e22221ca6c06 /print/pslib
parent9a7ead539b3469a3ca928af76cba527ae8633ae4 (diff)
downloadports-4be8cb03ee3a425da5bdc4ec37ec2d6d6e3a9aba.tar.gz
ports-4be8cb03ee3a425da5bdc4ec37ec2d6d6e3a9aba.zip
- Update to 0.2.4
PR: ports/73472 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=120879
Diffstat (limited to 'print/pslib')
-rw-r--r--print/pslib/Makefile13
-rw-r--r--print/pslib/distinfo4
-rw-r--r--print/pslib/files/patch-ltmain.sh15
-rw-r--r--print/pslib/files/patch-src::pslib.c22
-rw-r--r--print/pslib/pkg-plist2
5 files changed, 31 insertions, 25 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 2010660ad31b..7f91bcee7687 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= pslib
-PORTVERSION= 0.2.2
+PORTVERSION= 0.2.4
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,14 +15,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A C-library for generating multi page PostScript documents
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
-USE_PERL5_BUILD= yes
+USE_GNOME= gnomehack gnometarget intlhack pkgconfig
USE_GETTEXT= yes
-USE_GNOME= gnomehack
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
diff --git a/print/pslib/distinfo b/print/pslib/distinfo
index 8debacefb7a9..d63407ca3d38 100644
--- a/print/pslib/distinfo
+++ b/print/pslib/distinfo
@@ -1,2 +1,2 @@
-MD5 (pslib-0.2.2.tar.gz) = 76c50030acd9297604477e8b216453f8
-SIZE (pslib-0.2.2.tar.gz) = 463045
+MD5 (pslib-0.2.4.tar.gz) = 556d7f1b47bedc7c0d7743e45579265d
+SIZE (pslib-0.2.4.tar.gz) = 473706
diff --git a/print/pslib/files/patch-ltmain.sh b/print/pslib/files/patch-ltmain.sh
deleted file mode 100644
index fff33dcc4295..000000000000
--- a/print/pslib/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Wed Apr 7 00:45:05 2004
-+++ ltmain.sh Tue Jul 13 10:37:40 2004
-@@ -5550,10 +5550,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/print/pslib/files/patch-src::pslib.c b/print/pslib/files/patch-src::pslib.c
new file mode 100644
index 000000000000..35c92f767133
--- /dev/null
+++ b/print/pslib/files/patch-src::pslib.c
@@ -0,0 +1,22 @@
+--- src/pslib.c.orig Tue Jul 20 20:54:56 2004
++++ src/pslib.c Mon Nov 1 22:38:48 2004
+@@ -4557,8 +4557,8 @@
+ PS_begin_template(PSDoc *psdoc, float width, float height) {
+ PSImage *pstemplate;
+ char buffer[20];
+- buffer[0] = '\0';
+ int templateid;
++ buffer[0] = '\0';
+
+ if(NULL == psdoc) {
+ ps_error(psdoc, PS_RuntimeError, _("PSDoc is null."));
+@@ -4729,8 +4729,8 @@
+ PSPattern *pspattern;
+ char buffer[20];
+ int patternid;
+- buffer[0] = '\0';
+ PSShading *psshading;
++ buffer[0] = '\0';
+
+ if(NULL == psdoc) {
+ ps_error(psdoc, PS_RuntimeError, _("PSDoc is null."));
diff --git a/print/pslib/pkg-plist b/print/pslib/pkg-plist
index 414311c6bcd7..4d9584fcb130 100644
--- a/print/pslib/pkg-plist
+++ b/print/pslib/pkg-plist
@@ -1,7 +1,6 @@
include/libps/pslib-mp.h
include/libps/pslib.h
include/libps/psversion.h
-@dirrm include/libps
lib/libps.a
lib/libps.so
lib/libps.so.2
@@ -11,3 +10,4 @@ share/locale/de/LC_MESSAGES/pslib.mo
%%DATADIR%%/exectime.ps
%%DATADIR%%/grid.ps
@dirrm %%DATADIR%%
+@dirrm include/libps