aboutsummaryrefslogtreecommitdiff
path: root/print/scribus/Makefile
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-04-28 20:36:45 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-04-28 20:36:45 +0000
commitff0aa724b39c11cf67056cd75f9b7f612db96628 (patch)
tree2a2781caa376b725aacbe390e4d1575b599fcd87 /print/scribus/Makefile
parentef82cd63afceb8d8f0b0de3c653ee399ff3cde06 (diff)
downloadports-ff0aa724b39c11cf67056cd75f9b7f612db96628.tar.gz
ports-ff0aa724b39c11cf67056cd75f9b7f612db96628.zip
- Update to 1.1.6
- respect CFLAGS
Notes
Notes: svn path=/head/; revision=107875
Diffstat (limited to 'print/scribus/Makefile')
-rw-r--r--print/scribus/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 53bdbd36a232..16754339e541 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -7,23 +7,32 @@
#
PORTNAME= scribus
-PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTVERSION= 1.1.6
CATEGORIES= print editors
MASTER_SITES= http://web2.altmuehlnet.de/fschmid/ \
- http://scribus.planetmirror.com/
+ http://scribus.planetmirror.com/ \
+ http://mirrors.ntua.gr/Scribus/ \
+ http://ftp.ntua.gr/pub/gnu/scribus/ \
+ ftp://ftp.ntua.gr/pub/gnu/scribus/
MAINTAINER= ports@FreeBSD.org
COMMENT= A comprehensive desktop publishing program
-USE_GHOSTSCRIPT_RUN= yes
+LIB_DEPENDS= art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl2 \
+ lcms:${PORTSDIR}/graphics/lcms \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ cups.2:${PORTSDIR}/print/cups-base \
+ freetype.9:${PORTSDIR}/print/freetype2
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
+USE_GHOSTSCRIPT_RUN= yes
USE_QT_VER= 3
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_PYTHON= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/scribus/libs \
@@ -40,6 +49,7 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g; \
+ s|-O2||g' ${WRKSRC}/configure
.include <bsd.port.mk>