aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-10-06 22:52:50 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-10-06 22:52:50 +0000
commitef37ca4764b9b9c493ef7c2b4766c47548a84a98 (patch)
treec04affd22f3257090250f0703f984e0000b0a8a1 /print
parentd87fc2747a273cce66002381ce06af0db9503d24 (diff)
downloadports-ef37ca4764b9b9c493ef7c2b4766c47548a84a98.tar.gz
ports-ef37ca4764b9b9c493ef7c2b4766c47548a84a98.zip
Convert to OptionsNG
Notes
Notes: svn path=/head/; revision=305418
Diffstat (limited to 'print')
-rw-r--r--print/xfce4-print/Makefile23
1 files changed, 9 insertions, 14 deletions
diff --git a/print/xfce4-print/Makefile b/print/xfce4-print/Makefile
index fe69142b109e..4e5ae59808dc 100644
--- a/print/xfce4-print/Makefile
+++ b/print/xfce4-print/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xfprint
-# Date created: 7 June 2003
-# Whom: James Earl <jdearl@telus.net>
-#
+# Created by: James Earl <jdearl@telus.net>
# $FreeBSD$
-#
PORTNAME= xfce4-print
PORTVERSION= 4.6.1
@@ -26,13 +22,15 @@ USE_GNOME= glib20 gnomehack gtk20 intltool intlhack pkgconfig
USE_LDCONFIG= yes
USE_XFCE= configenv libgui libutil xfconf
-OPTIONS= LPR "Use lpr as printing system" on \
- CUPS "Use cups as printing system" off \
- LETTER "Use letter paper format instead of A4" off
+OPTIONS_DEFINE= LETTER
+OPTIONS_SINGLE= PRINTMETHOD
+OPTIONS_SINGLE_PRINTMETHOD= LPR CUPS
+LETTER_DESC= Use letter paper format instead of A4
+LPR_DESC= Use lpr as printing system
.include <bsd.port.pre.mk>
-.if defined(WITH_CUPS)
+.if ${PORT_OPTIONS:MCUPS}
CONFIGURE_ARGS+=--enable-cups
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
PLIST_SUB+= CUPS=""
@@ -41,7 +39,7 @@ CONFIGURE_ARGS+=--disable-cups
PLIST_SUB+= CUPS="@comment "
.endif
-.if defined(WITHOUT_LPR)
+.if ${PORT_OPTIONS:MLPR}
CONFIGURE_ARGS+=--disable-bsdlpr
PLIST_SUB+= LPR="@comment "
.else
@@ -49,11 +47,8 @@ CONFIGURE_ARGS+=--enable-bsdlpr --with-printcap=/etc/printcap
PLIST_SUB+= LPR=""
.endif
-.if defined(WITHOUT_LPR) && !defined(WITH_CUPS)
-IGNORE= define WITH_CUPS or undefine WITHOUT_LPR to install this port
-.endif
-.if defined(WITH_LETTER)
+.if ${PORT_OPTIONS:MLETTER}
CONFIGURE_ARGS+=--enable-letter
BUILD_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letter
RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letter