aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-03-02 18:18:19 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-03-02 18:18:19 +0000
commit52b9f5fb3cd5e4750ee68ca16fcd4a84087c319c (patch)
tree32f4214abe40b277d7459d39e1b8eb1bf4e9e710 /print
parentec308f87c756bb60ade569ece93feeaa4b925660 (diff)
downloadports-52b9f5fb3cd5e4750ee68ca16fcd4a84087c319c.tar.gz
ports-52b9f5fb3cd5e4750ee68ca16fcd4a84087c319c.zip
- Fix iconv dependency [*]
- Add STAGEDIR support. - Fix old syntax in LIB_DEPENDS. Submitted by: tijl [*] PR: ports/186705 [*]
Notes
Notes: svn path=/head/; revision=346786
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript9-agpl-nox11/Makefile1
-rw-r--r--print/ghostscript9-agpl/Makefile76
-rw-r--r--print/ghostscript9-agpl/files/Makefile.dmprt2
-rw-r--r--print/ghostscript9-agpl/files/Makefile.drivers_post3
-rw-r--r--print/ghostscript9-agpl/files/Makefile.epag2
-rw-r--r--print/ghostscript9-agpl/files/Makefile.pcl310
-rw-r--r--print/ghostscript9-agpl/pkg-plist27
-rw-r--r--print/ghostscript9-nox11/Makefile1
-rw-r--r--print/ghostscript9/Makefile76
-rw-r--r--print/ghostscript9/files/Makefile.dmprt2
-rw-r--r--print/ghostscript9/files/Makefile.drivers_post3
-rw-r--r--print/ghostscript9/files/Makefile.epag2
-rw-r--r--print/ghostscript9/files/Makefile.pcl310
-rw-r--r--print/ghostscript9/pkg-plist27
14 files changed, 112 insertions, 130 deletions
diff --git a/print/ghostscript9-agpl-nox11/Makefile b/print/ghostscript9-agpl-nox11/Makefile
index 0a22416ade5b..2a5d7b6fe65e 100644
--- a/print/ghostscript9-agpl-nox11/Makefile
+++ b/print/ghostscript9-agpl-nox11/Makefile
@@ -4,5 +4,4 @@ OPTIONS_UNSET= X11
MASTERDIR= ${.CURDIR}/../ghostscript9-agpl
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/print/ghostscript9-agpl/Makefile b/print/ghostscript9-agpl/Makefile
index 494bb389e394..a78a0bbd3c57 100644
--- a/print/ghostscript9-agpl/Makefile
+++ b/print/ghostscript9-agpl/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ghostscript
PORTVERSION= 9.07
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -20,14 +20,14 @@ COMMENT= Ghostscript 9.x PostScript interpreter
LICENSE= AGPLv3
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
- idn:${PORTSDIR}/dns/libidn \
- jbig2dec:${PORTSDIR}/graphics/jbig2dec \
- jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- lcms2:${PORTSDIR}/graphics/lcms2 \
- paper:${PORTSDIR}/print/libpaper
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libidn.so:${PORTSDIR}/dns/libidn \
+ libjbig2dec.so:${PORTSDIR}/graphics/jbig2dec \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libpaper.so:${PORTSDIR}/print/libpaper
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
CONFLICTS_INSTALL= \
@@ -44,7 +44,6 @@ GNU_CONFIGURE= yes
MAKE_ENV= CFLAGS_STANDARD="${CFLAGS}" \
XCFLAGS="${XCFLAGS}" XLDFLAGS="${XLDFLAGS}" \
- EXTRALIBS="${EXTRALIBS}" \
SOC_LOADER="dxmainc.c"
CONFIGURE_ENV= ${MAKE_ENV}
CONFIGURE_ARGS= --disable-compile-inits \
@@ -75,51 +74,23 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS_DEFINE= X11 DOCS CUPS FONTCONFIG ICONV GTK2
OPTIONS_DEFAULT=X11 DOCS CUPS FONTCONFIG ICONV
+OPTIONS_SUB= yes
FONTCONFIG_DESC=Enable fontconfig support
NO_OPTIONS_SORT=yes
-MAN1= dvipdf.1 font2c.1 gs.1 gslp.1 gsnd.1 \
- pdf2dsc.1 pdf2ps.1 pdfopt.1 pf2afm.1 pfbtopfa.1 printafm.1 \
- ps2ascii.1 ps2epsi.1 ps2pdf.1 ps2pdfwr.1 ps2ps.1 \
- wftopfa.1
-MLINKS= gslp.1 gsbj.1 \
- gslp.1 gsdj.1 \
- gslp.1 gsdj500.1 \
- gslp.1 gslj.1 \
- ps2pdf.1 ps2pdf12.1 \
- ps2pdf.1 ps2pdf13.1 \
- ps2pdf.1 ps2pdf14.1 \
- ps2ps.1 eps2eps.1
-
EXCLUDE_DIRS= freetype jbig2dec jpeg expat jasper lcms libpng tiff zlib
-NO_STAGE= yes
.include "Makefile.drivers"
.include <bsd.port.options.mk>
MASTERDIR?= ${.CURDIR}
.include "${MASTERDIR}/files/Makefile.drivers_post"
-.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//} \
- ${OPTIONS_MULTI_X11:MGS_*:S/^GS_//} \
- ${OPTIONS_GROUP_ICONV:MGS_*:S/^GS_//} \
- ${OPTIONS_GROUP_SVGALIB:MGS_*:S/^GS_//}
-.if ${PORT_OPTIONS:MGS_${D}}
-PLIST_SUB+= GS_${D}=""
-.else
-PLIST_SUB+= GS_${D}="@comment "
-.endif
-.endfor
-
-.if ${PORT_OPTIONS:MFONTCONFIG}
-LIB_DEPENDS+= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
-CONFIGURE_ARGS+= --enable-fontconfig
-.else
-CONFIGURE_ARGS+= --disable-fontconfig
-.endif
+FONTCONFIG_LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
+FONTCONFIG_CONFIGURE_ENABLE= fontconfig
# FT_BRIDGE=1 by default
-LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
MAKE_ENV+= FT_BRIDGE=1
ALL_TARGET= so
@@ -144,8 +115,8 @@ PORTDOC_FILES= japanese/Gdevlips.htm japanese/README.gs550j \
post-patch:
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g ; \
- s|%%GS_VERSION%%|${PORTVERSION}|g' \
- ${WRKSRC}/contrib/japanese/dmp_site.ps
+ s|%%GS_VERSION%%|${PORTVERSION}|g' \
+ ${WRKSRC}/contrib/japanese/dmp_site.ps
pre-build-drivers.mak:
@${ECHO_CMD} '# automatically generated' > ${WRKSRC}/base/drivers.mak
@@ -177,25 +148,22 @@ pre-install:
gs_statd.ps.orig gs_ttf.ps.orig pdf_font.ps.orig
pre-su-install:
- ${MKDIR} ${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
post-install-docs:
${MKDIR} ${WRKSRC}/contrib/japanese
${INSTALL_DATA} ${WRKSRC}/contrib/japanese/doc/* ${WRKSRC}/contrib/japanese
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/contrib && \
${TAR} -cf - ${PORTDOC_FILES} | \
- ( cd ${DOCSDIR} && ${TAR} -xof - )
+ ( cd ${STAGEDIR}${DOCSDIR} && ${TAR} -xof - )
post-install:
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}/${PORTVERSION}
- ${STRIP_CMD} ${PREFIX}/bin/gsc ${PREFIX}/bin/gsx
- ${LN} -sf gsc ${PREFIX}/bin/gs
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}/${PORTVERSION}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gsc ${STAGEDIR}${PREFIX}/bin/gsx
+ ${LN} -sf gsc ${STAGEDIR}${PREFIX}/bin/gs
${LN} -s -f ${LOCALBASE}/share/fonts/CIDFont \
- ${DATADIR}/${PORTVERSION}/Resource/CIDFont/fonts
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
+ ${STAGEDIR}${DATADIR}/${PORTVERSION}/Resource/CIDFont/fonts
.if ${PORT_OPTIONS:MDOCS}
post-install: post-install-docs
diff --git a/print/ghostscript9-agpl/files/Makefile.dmprt b/print/ghostscript9-agpl/files/Makefile.dmprt
index 5166a6cd6fc6..cdc04a23af07 100644
--- a/print/ghostscript9-agpl/files/Makefile.dmprt
+++ b/print/ghostscript9-agpl/files/Makefile.dmprt
@@ -3,6 +3,6 @@
post-install-dmprt:
cd ${FILESDIR} && \
${INSTALL_DATA} lqx70ch.upp lqx70cl.upp lqx70cm.upp \
- ${DATADIR}/${PORTVERSION}/lib
+ ${STAGEDIR}${DATADIR}/${PORTVERSION}/lib
post-install: post-install-dmprt
diff --git a/print/ghostscript9-agpl/files/Makefile.drivers_post b/print/ghostscript9-agpl/files/Makefile.drivers_post
index 76e71f71df0e..f3c0c2e7e6f8 100644
--- a/print/ghostscript9-agpl/files/Makefile.drivers_post
+++ b/print/ghostscript9-agpl/files/Makefile.drivers_post
@@ -111,8 +111,7 @@ PORT_OPTIONS:= ${PORT_OPTIONS:NGS_${D}}
.if defined(_ICONV_DEVS)
USES+= iconv
-CONFIGURE_ARGS+=--with-libiconv=gnu
-EXTRALIBS+= -liconv
+CONFIGURE_ARGS+=--with-libiconv=maybe
.else
CONFIGURE_ARGS+=--with-libiconv=no
.endif
diff --git a/print/ghostscript9-agpl/files/Makefile.epag b/print/ghostscript9-agpl/files/Makefile.epag
index 283b4886a461..cb3324d16109 100644
--- a/print/ghostscript9-agpl/files/Makefile.epag
+++ b/print/ghostscript9-agpl/files/Makefile.epag
@@ -17,7 +17,7 @@ post-build-epag:
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} Makefile
post-install-epag:
- ${INSTALL_PROGRAM} ${WRKSRC}/${EPAG_NAME}/ert ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${EPAG_NAME}/ert ${STAGEDIR}${PREFIX}/bin
pre-build: pre-build-epag
post-build: post-build-epag
diff --git a/print/ghostscript9-agpl/files/Makefile.pcl3 b/print/ghostscript9-agpl/files/Makefile.pcl3
index ad19ffdc8017..3227ef6138ea 100644
--- a/print/ghostscript9-agpl/files/Makefile.pcl3
+++ b/print/ghostscript9-agpl/files/Makefile.pcl3
@@ -4,8 +4,6 @@ PORTDOCS+= pcl3
PORTDOC_FILES+= pcl3/NEWS pcl3/BUGS pcl3/README pcl3/gs-pcl3.html \
pcl3/how-to-report.txt pcl3/pcl3opts.html
-MAN1+= gs-pcl3.1 pcl3opts.1
-
post-build-pcl3:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -I./obj -I./soobj -I./base \
@@ -14,8 +12,8 @@ post-build-pcl3:
contrib/pcl3/eprn/mediasize.c contrib/pcl3/src/pclsize.c
post-install-pcl3:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/pcl3opts ${PREFIX}/bin
- ${MKDIR} ${DATADIR}/${PORTVERSION}/pcl3
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/pcl3opts ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}/${PORTVERSION}/pcl3
cd ${WRKSRC}/contrib/pcl3 && \
${INSTALL_DATA} lib/example.mcf lib/if-pcl3 \
ps/calign.ps ps/dumppdd.ps ps/levels-test.ps \
@@ -24,9 +22,9 @@ post-install-pcl3:
ps/margins-EnvDLRotated.ps \
ps/margins-Letter.ps \
ps/margins-LetterRotated.ps \
- ${DATADIR}/${PORTVERSION}/pcl3
+ ${STAGEDIR}${DATADIR}/${PORTVERSION}/pcl3
cd ${WRKSRC}/contrib/pcl3/doc && \
- ${INSTALL_MAN} gs-pcl3.1 pcl3opts.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} gs-pcl3.1 pcl3opts.1 ${STAGEDIR}${MANPREFIX}/man/man1
post-install-docs-pcl3:
${MKDIR} ${WRKSRC}/contrib/pcl3
diff --git a/print/ghostscript9-agpl/pkg-plist b/print/ghostscript9-agpl/pkg-plist
index 173fa07f0963..0d7fcf6f87d9 100644
--- a/print/ghostscript9-agpl/pkg-plist
+++ b/print/ghostscript9-agpl/pkg-plist
@@ -40,6 +40,33 @@ lib/libgs.so.%%GS_VERSION%%
%%X11BITS%%lib/ghostscript/%%GS_VERSION%%/X11.so
%%X11BITS%%@dirrm lib/ghostscript/%%GS_VERSION%%
%%X11BITS%%@dirrmtry lib/ghostscript
+man/man1/dvipdf.1.gz
+man/man1/eps2eps.1.gz
+man/man1/font2c.1.gz
+%%GS_pcl3%%man/man1/gs-pcl3.1.gz
+man/man1/gs.1.gz
+man/man1/gsbj.1.gz
+man/man1/gsdj.1.gz
+man/man1/gsdj500.1.gz
+man/man1/gslj.1.gz
+man/man1/gslp.1.gz
+man/man1/gsnd.1.gz
+%%GS_pcl3%%man/man1/pcl3opts.1.gz
+man/man1/pdf2dsc.1.gz
+man/man1/pdf2ps.1.gz
+man/man1/pdfopt.1.gz
+man/man1/pf2afm.1.gz
+man/man1/pfbtopfa.1.gz
+man/man1/printafm.1.gz
+man/man1/ps2ascii.1.gz
+man/man1/ps2epsi.1.gz
+man/man1/ps2pdf.1.gz
+man/man1/ps2pdf12.1.gz
+man/man1/ps2pdf13.1.gz
+man/man1/ps2pdf14.1.gz
+man/man1/ps2pdfwr.1.gz
+man/man1/ps2ps.1.gz
+man/man1/wftopfa.1.gz
%%DATADIR%%/%%GS_VERSION%%/Resource/CMap/78-EUC-H
%%DATADIR%%/%%GS_VERSION%%/Resource/CMap/78-EUC-V
%%DATADIR%%/%%GS_VERSION%%/Resource/CMap/78-H
diff --git a/print/ghostscript9-nox11/Makefile b/print/ghostscript9-nox11/Makefile
index 5fa2e97ada04..9aa91cda0c9f 100644
--- a/print/ghostscript9-nox11/Makefile
+++ b/print/ghostscript9-nox11/Makefile
@@ -4,5 +4,4 @@ OPTIONS_UNSET= X11
MASTERDIR= ${.CURDIR}/../ghostscript9
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/print/ghostscript9/Makefile b/print/ghostscript9/Makefile
index 519a4501b690..8a7feb2f013d 100644
--- a/print/ghostscript9/Makefile
+++ b/print/ghostscript9/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ghostscript
PORTVERSION= 9.06
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -20,14 +20,14 @@ COMMENT= Ghostscript 9.x PostScript interpreter
LICENSE= GPLv3
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
- idn:${PORTSDIR}/dns/libidn \
- jbig2dec:${PORTSDIR}/graphics/jbig2dec \
- jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- lcms2:${PORTSDIR}/graphics/lcms2 \
- paper:${PORTSDIR}/print/libpaper
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libidn.so:${PORTSDIR}/dns/libidn \
+ libjbig2dec.so:${PORTSDIR}/graphics/jbig2dec \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libpaper.so:${PORTSDIR}/print/libpaper
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
CONFLICTS_INSTALL= \
@@ -47,7 +47,6 @@ GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
MAKE_ENV= CFLAGS_STANDARD="${CFLAGS}" \
XCFLAGS="${XCFLAGS}" XLDFLAGS="${XLDFLAGS}" \
- EXTRALIBS="${EXTRALIBS}" \
SOC_LOADER="dxmainc.c"
CONFIGURE_ENV= ${MAKE_ENV}
CONFIGURE_ARGS= --disable-compile-inits \
@@ -78,51 +77,23 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS_DEFINE= X11 DOCS CUPS FONTCONFIG ICONV GTK2
OPTIONS_DEFAULT=X11 DOCS CUPS FONTCONFIG ICONV
+OPTIONS_SUB= yes
FONTCONFIG_DESC=Enable fontconfig support
NO_OPTIONS_SORT=yes
-MAN1= dvipdf.1 font2c.1 gs.1 gslp.1 gsnd.1 \
- pdf2dsc.1 pdf2ps.1 pdfopt.1 pf2afm.1 pfbtopfa.1 printafm.1 \
- ps2ascii.1 ps2epsi.1 ps2pdf.1 ps2pdfwr.1 ps2ps.1 \
- wftopfa.1
-MLINKS= gslp.1 gsbj.1 \
- gslp.1 gsdj.1 \
- gslp.1 gsdj500.1 \
- gslp.1 gslj.1 \
- ps2pdf.1 ps2pdf12.1 \
- ps2pdf.1 ps2pdf13.1 \
- ps2pdf.1 ps2pdf14.1 \
- ps2ps.1 eps2eps.1
-
EXCLUDE_DIRS= freetype jbig2dec jpeg expat jasper lcms lcms2 libpng tiff zlib
-NO_STAGE= yes
.include "Makefile.drivers"
.include <bsd.port.options.mk>
MASTERDIR?= ${.CURDIR}
.include "${MASTERDIR}/files/Makefile.drivers_post"
-.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//} \
- ${OPTIONS_MULTI_X11:MGS_*:S/^GS_//} \
- ${OPTIONS_GROUP_ICONV:MGS_*:S/^GS_//} \
- ${OPTIONS_GROUP_SVGALIB:MGS_*:S/^GS_//}
-.if ${PORT_OPTIONS:MGS_${D}}
-PLIST_SUB+= GS_${D}=""
-.else
-PLIST_SUB+= GS_${D}="@comment "
-.endif
-.endfor
-
-.if ${PORT_OPTIONS:MFONTCONFIG}
-LIB_DEPENDS+= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
-CONFIGURE_ARGS+= --enable-fontconfig
-.else
-CONFIGURE_ARGS+= --disable-fontconfig
-.endif
+FONTCONFIG_LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
+FONTCONFIG_CONFIGURE_ENABLE= fontconfig
# FT_BRIDGE=1 by default
-LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
MAKE_ENV+= FT_BRIDGE=1
ALL_TARGET= so
@@ -147,8 +118,8 @@ PORTDOC_FILES= japanese/Gdevlips.htm japanese/README.gs550j \
post-patch:
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g ; \
- s|%%GS_VERSION%%|${PORTVERSION}|g' \
- ${WRKSRC}/contrib/japanese/dmp_site.ps
+ s|%%GS_VERSION%%|${PORTVERSION}|g' \
+ ${WRKSRC}/contrib/japanese/dmp_site.ps
pre-build-drivers.mak:
@${ECHO_CMD} '# automatically generated' > ${WRKSRC}/base/drivers.mak
@@ -180,25 +151,22 @@ pre-install:
gs_statd.ps.orig gs_ttf.ps.orig pdf_font.ps.orig
pre-su-install:
- ${MKDIR} ${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
post-install-docs:
${MKDIR} ${WRKSRC}/contrib/japanese
${INSTALL_DATA} ${WRKSRC}/contrib/japanese/doc/* ${WRKSRC}/contrib/japanese
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/contrib && \
${TAR} -cf - ${PORTDOC_FILES} | \
- ( cd ${DOCSDIR} && ${TAR} -xof - )
+ ( cd ${STAGEDIR}${DOCSDIR} && ${TAR} -xof - )
post-install:
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}/${PORTVERSION}
- ${STRIP_CMD} ${PREFIX}/bin/gsc ${PREFIX}/bin/gsx
- ${LN} -sf gsc ${PREFIX}/bin/gs
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}/${PORTVERSION}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gsc ${STAGEDIR}${PREFIX}/bin/gsx
+ ${LN} -sf gsc ${STAGEDIR}${PREFIX}/bin/gs
${LN} -s -f ${LOCALBASE}/share/fonts/CIDFont \
- ${DATADIR}/${PORTVERSION}/Resource/CIDFont/fonts
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
+ ${STAGEDIR}${DATADIR}/${PORTVERSION}/Resource/CIDFont/fonts
.if ${PORT_OPTIONS:MDOCS}
post-install: post-install-docs
diff --git a/print/ghostscript9/files/Makefile.dmprt b/print/ghostscript9/files/Makefile.dmprt
index 5166a6cd6fc6..cdc04a23af07 100644
--- a/print/ghostscript9/files/Makefile.dmprt
+++ b/print/ghostscript9/files/Makefile.dmprt
@@ -3,6 +3,6 @@
post-install-dmprt:
cd ${FILESDIR} && \
${INSTALL_DATA} lqx70ch.upp lqx70cl.upp lqx70cm.upp \
- ${DATADIR}/${PORTVERSION}/lib
+ ${STAGEDIR}${DATADIR}/${PORTVERSION}/lib
post-install: post-install-dmprt
diff --git a/print/ghostscript9/files/Makefile.drivers_post b/print/ghostscript9/files/Makefile.drivers_post
index 76e71f71df0e..f3c0c2e7e6f8 100644
--- a/print/ghostscript9/files/Makefile.drivers_post
+++ b/print/ghostscript9/files/Makefile.drivers_post
@@ -111,8 +111,7 @@ PORT_OPTIONS:= ${PORT_OPTIONS:NGS_${D}}
.if defined(_ICONV_DEVS)
USES+= iconv
-CONFIGURE_ARGS+=--with-libiconv=gnu
-EXTRALIBS+= -liconv
+CONFIGURE_ARGS+=--with-libiconv=maybe
.else
CONFIGURE_ARGS+=--with-libiconv=no
.endif
diff --git a/print/ghostscript9/files/Makefile.epag b/print/ghostscript9/files/Makefile.epag
index 283b4886a461..cb3324d16109 100644
--- a/print/ghostscript9/files/Makefile.epag
+++ b/print/ghostscript9/files/Makefile.epag
@@ -17,7 +17,7 @@ post-build-epag:
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} Makefile
post-install-epag:
- ${INSTALL_PROGRAM} ${WRKSRC}/${EPAG_NAME}/ert ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${EPAG_NAME}/ert ${STAGEDIR}${PREFIX}/bin
pre-build: pre-build-epag
post-build: post-build-epag
diff --git a/print/ghostscript9/files/Makefile.pcl3 b/print/ghostscript9/files/Makefile.pcl3
index ad19ffdc8017..5e8698644d4a 100644
--- a/print/ghostscript9/files/Makefile.pcl3
+++ b/print/ghostscript9/files/Makefile.pcl3
@@ -4,8 +4,6 @@ PORTDOCS+= pcl3
PORTDOC_FILES+= pcl3/NEWS pcl3/BUGS pcl3/README pcl3/gs-pcl3.html \
pcl3/how-to-report.txt pcl3/pcl3opts.html
-MAN1+= gs-pcl3.1 pcl3opts.1
-
post-build-pcl3:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -I./obj -I./soobj -I./base \
@@ -14,8 +12,8 @@ post-build-pcl3:
contrib/pcl3/eprn/mediasize.c contrib/pcl3/src/pclsize.c
post-install-pcl3:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/pcl3opts ${PREFIX}/bin
- ${MKDIR} ${DATADIR}/${PORTVERSION}/pcl3
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/pcl3opts ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}/${PORTVERSION}/pcl3
cd ${WRKSRC}/contrib/pcl3 && \
${INSTALL_DATA} lib/example.mcf lib/if-pcl3 \
ps/calign.ps ps/dumppdd.ps ps/levels-test.ps \
@@ -24,9 +22,9 @@ post-install-pcl3:
ps/margins-EnvDLRotated.ps \
ps/margins-Letter.ps \
ps/margins-LetterRotated.ps \
- ${DATADIR}/${PORTVERSION}/pcl3
+ ${STAGEDIR}${DATADIR}/${PORTVERSION}/pcl3
cd ${WRKSRC}/contrib/pcl3/doc && \
- ${INSTALL_MAN} gs-pcl3.1 pcl3opts.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} gs-pcl3.1 pcl3opts.1 ${STAGEDIR}${MANPREFIX}/man/man1
post-install-docs-pcl3:
${MKDIR} ${WRKSRC}/contrib/pcl3
diff --git a/print/ghostscript9/pkg-plist b/print/ghostscript9/pkg-plist
index 1ff902bfd976..16d3f8f14f20 100644
--- a/print/ghostscript9/pkg-plist
+++ b/print/ghostscript9/pkg-plist
@@ -41,6 +41,33 @@ lib/libgs.so.%%GS_VERSION%%
%%X11BITS%%lib/ghostscript/%%GS_VERSION%%/X11.so
%%X11BITS%%@dirrm lib/ghostscript/%%GS_VERSION%%
%%X11BITS%%@dirrmtry lib/ghostscript
+man/man1/dvipdf.1.gz
+man/man1/eps2eps.1.gz
+man/man1/font2c.1.gz
+%%GS_pcl3%%man/man1/gs-pcl3.1.gz
+man/man1/gs.1.gz
+man/man1/gsbj.1.gz
+man/man1/gsdj.1.gz
+man/man1/gsdj500.1.gz
+man/man1/gslj.1.gz
+man/man1/gslp.1.gz
+man/man1/gsnd.1.gz
+%%GS_pcl3%%man/man1/pcl3opts.1.gz
+man/man1/pdf2dsc.1.gz
+man/man1/pdf2ps.1.gz
+man/man1/pdfopt.1.gz
+man/man1/pf2afm.1.gz
+man/man1/pfbtopfa.1.gz
+man/man1/printafm.1.gz
+man/man1/ps2ascii.1.gz
+man/man1/ps2epsi.1.gz
+man/man1/ps2pdf.1.gz
+man/man1/ps2pdf12.1.gz
+man/man1/ps2pdf13.1.gz
+man/man1/ps2pdf14.1.gz
+man/man1/ps2pdfwr.1.gz
+man/man1/ps2ps.1.gz
+man/man1/wftopfa.1.gz
%%DATADIR%%/%%GS_VERSION%%/Resource/CMap/78-EUC-H
%%DATADIR%%/%%GS_VERSION%%/Resource/CMap/78-EUC-V
%%DATADIR%%/%%GS_VERSION%%/Resource/CMap/78-H