aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-08-03 13:44:00 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-08-03 13:44:00 +0000
commit62a41b423ba42c0a1ab0c0ada5d33752e965f615 (patch)
tree5fff787fcf509ed53762690c395516c337412423 /print
parent3d7ef3e463a5e930be63835c21dd2d345f88ea2d (diff)
downloadports-62a41b423ba42c0a1ab0c0ada5d33752e965f615.tar.gz
ports-62a41b423ba42c0a1ab0c0ada5d33752e965f615.zip
- Convert to new perl framework
- Remove MAKE_JOBS_SAFE=yes, it's the default.
Notes
Notes: svn path=/head/; revision=324191
Diffstat (limited to 'print')
-rw-r--r--print/kover/Makefile5
-rw-r--r--print/latexmk/Makefile3
-rw-r--r--print/muttprint/Makefile2
3 files changed, 5 insertions, 5 deletions
diff --git a/print/kover/Makefile b/print/kover/Makefile
index ea460c5042fb..068b8e5a3f45 100644
--- a/print/kover/Makefile
+++ b/print/kover/Makefile
@@ -18,9 +18,8 @@ USE_BZIP2= yes
USE_KDE4= automoc4 kdehier kdeprefix kdelibs sharedmime
USE_QT4= corelib dbus gui network svg xml \
qmake_build uic_build rcc_build
-USE_PERL5_BUILD=yes
-USES= cmake gettext
-MAKE_JOBS_SAFE= yes
+USE_PERL5= build
+USES= cmake gettext perl5
MAN1= kover.1
diff --git a/print/latexmk/Makefile b/print/latexmk/Makefile
index eeca6447e5fe..5e43eab3d7e3 100644
--- a/print/latexmk/Makefile
+++ b/print/latexmk/Makefile
@@ -16,8 +16,9 @@ OPTIONS_DEFINE= DOCS EXAMPLES
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USES= perl5
USE_ZIP= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_TEX= latex
MAN1= latexmk.1
diff --git a/print/muttprint/Makefile b/print/muttprint/Makefile
index 03d74a077d30..f8918f495baa 100644
--- a/print/muttprint/Makefile
+++ b/print/muttprint/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/muttprint/muttprint/muttprint-${PORTVERSION}
MAINTAINER?= ports@FreeBSD.org
COMMENT?= Utility to print mail for most any mail client
-USE_PERL5= yes
+USES= perl5
.if !defined(PAPERSIZE)
PAPERSIZE= letter