aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-04-22 19:40:15 +0000
committerRene Ladan <rene@FreeBSD.org>2014-04-22 19:40:15 +0000
commitc6e1c30c97d7e8a3ea305175bf586a8e5fc5abaf (patch)
treec5f3a2ca6e75a0b18f7ee7d1e1cf682706988886 /print
parent129c91f1c6143ebb1e9966fa6a88ca97e171b5d6 (diff)
downloadports-c6e1c30c97d7e8a3ea305175bf586a8e5fc5abaf.tar.gz
ports-c6e1c30c97d7e8a3ea305175bf586a8e5fc5abaf.zip
- Add stage support [1]
- cups-image(1) is part of print/cups-image, so depend on that port instead of on print/cups-base [1] - Convert USE_GMAKE and USE_BZIP2 to their corresponding USES [1] - Fix pkg-plist - Use modern LIB_DEPENDS - Add dependency on print/cups-client for cups-config(1) and correctly reference it - Bump PORTREVISION PR: ports/188864 [1] Submitted by: Zsolt Udvari <udvzsolt@gmail.com>
Notes
Notes: svn path=/head/; revision=351880
Diffstat (limited to 'print')
-rw-r--r--print/splix/Makefile20
-rw-r--r--print/splix/pkg-plist2
2 files changed, 12 insertions, 10 deletions
diff --git a/print/splix/Makefile b/print/splix/Makefile
index d3d98fecabc0..599d79b3fec7 100644
--- a/print/splix/Makefile
+++ b/print/splix/Makefile
@@ -2,18 +2,18 @@
PORTNAME= splix
PORTVERSION= 2.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES?= print
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= CUPS printer drivers for Samsung Printer Language printers
-BUILD_DEPENDS= cups-config:${PORTSDIR}/print/cups-base
+LIB_DEPENDS= libcupsimage.so:${PORTSDIR}/print/cups-image
+BUILD_DEPENDS= cups-config:${PORTSDIR}/print/cups-client
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_GMAKE= yes
-USE_BZIP2= yes
+USES= gmake tar:bzip2
MODELS= DELL SAMSUNG XEROX
PPD_DELL= 1100 1110
@@ -28,7 +28,7 @@ PPD_SAMSUNG_JBIG= clp200 clp300 clp600 clx216x clx2170 clx3160
PPD_XEROX_JBIG= ph6110
FILTER_FILE= rastertoqpdl pstoqpdl
-CUPS_CONFIG= ${PREFIX}/bin/cups-config
+CUPS_CONFIG= ${LOCALBASE}/bin/cups-config
BIN_DEST_DIR= `${CUPS_CONFIG} --serverbin | ${SED} \
's|${LOCALBASE}|${PREFIX}|'`/filter
CUPS_DATA_DIR= `${CUPS_CONFIG} --datadir | ${SED} \
@@ -42,7 +42,6 @@ JBIG_DESC= Enable use of JBIG algorithm (pattented)
BLACKOPTIM_DESC= Enable black correction algorithm
OPTIONS_DEFAULT= JBIG BLACKOPTIM
-NO_STAGE= yes
.include "bsd.port.options.mk"
post-patch:
@@ -55,7 +54,7 @@ post-configure:
.if ${PORT_OPTIONS:MJBIG}
PPD_SAMSUNG+= ${PPD_SAMSUNG_JBIG}
PPD_XEROX+= ${PPD_XEROX_JBIG}
-LIB_DEPENDS+= jbig:${PORTSDIR}/graphics/jbigkit
+LIB_DEPENDS+= libjbig.so:${PORTSDIR}/graphics/jbigkit
.else
MAKE_ARGS+= DISABLE_JBIG=1
.endif
@@ -69,15 +68,16 @@ MAKE_ARGS+= CACHESIZE=${CACHESIZE}
.endif
do-install:
+ ${MKDIR} ${STAGEDIR}${BIN_DEST_DIR}
.for MODEL in ${MODELS}
- ${MKDIR} ${DEST_DIR_${MODEL}}
+ ${MKDIR} ${STAGEDIR}${DEST_DIR_${MODEL}}
.for PPD in $(PPD_${MODEL})
- ${INSTALL_DATA} ${WRKSRC}/ppd/${PPD}.ppd $(DEST_DIR_${MODEL})
+ ${INSTALL_DATA} ${WRKSRC}/ppd/${PPD}.ppd ${STAGEDIR}$(DEST_DIR_${MODEL})
.endfor
.endfor
.for FILTER in ${FILTER_FILE}
- ${INSTALL_PROGRAM} ${WRKSRC}/optimized/${FILTER} ${BIN_DEST_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/optimized/${FILTER} ${STAGEDIR}${BIN_DEST_DIR}
.endfor
.include <bsd.port.mk>
diff --git a/print/splix/pkg-plist b/print/splix/pkg-plist
index 0f7251b18ca4..51926de6a8c9 100644
--- a/print/splix/pkg-plist
+++ b/print/splix/pkg-plist
@@ -48,3 +48,5 @@ share/cups/model/xerox/wc3119.ppd
@dirrm share/cups/model/dell
@dirrm share/cups/model/samsung
@dirrm share/cups/model/xerox
+@dirrmtry share/cups/model
+@dirrmtry share/cups